Windows 10 Fix “You don’t currently have permission to access this folder” Windows 10


Well-Known Member
Have this issue, which manifested since failed wake from hibernate (first hibernate).
Have tried implementing the add user permissions outlined in this video -
This hasn't helped me. Have made the Everyone change no problem - not solved. Tried the User option, throws errors re accessing the specific folders contained in the drive.

Done CHKDSK scan

Also get "D: Recycle Bin is Corrupt..." errors. And programs can't see open folders.
Am able to access directly through Explorer.

This is affecting my HDD RAID array (mobo RAID).

Any tips gratefully received


W10 - 19045
Clean install

Asus Z390-F
1x SSD M.2 Boot
2x SSD 2.5 RAID
2x HDD 3.5 RAID
Which locations are having an issue specifically? Is this isolated to a particular drive or partition?
All the folders on a particular drive
Seems to be better since opening each folder and clicking ok to permission dialogue.
Also ran recycle bin repair which seems to complete successfully
Will be with the machine again later this week to check
Definitely don't want this to happen again
Won't be hibernating again, that's for sure
Have you tested the drive's health? I would suspect a potential a problem with the drive itself.