Home Network Issue

Discussion in 'Windows Vista Networking' started by luvflt, Jan 2, 2009.

  1. luvflt

    luvflt New Member

    Joined:
    Dec 24, 2008
    Messages:
    42
    Likes Received:
    0
    Ok, after batteling numerous hardware and software issues with my new Vista Home Premium computer I am now getting down to setting up my new Vista network. I had no problem with my XP machine but this is a tad differrent. I have a Vista desktop with a wired LAN connection to the router and a Vista laptop with a wireless connection to the router. I did everything like how I thought it should go and I see the network (HOME), I can access the files and folders on my laptop but I cannot access the files, folders or printer from my desktop. All the files and folders are shared as indicated by the shared icon. I went into Advanced Sharing and set the persmission to everyone and with full control. I can see all the files and folders on my laptop but if I try to access it, it says there is an error and to check the spelling or I don't have permission. I am sure it is something small but I am missing it here. Any help would be appreciated.
     
  2. Celestra

    Celestra Former Moderator

    Joined:
    Jan 15, 2008
    Messages:
    2,468
    Likes Received:
    14
  3. luvflt

    luvflt New Member

    Joined:
    Dec 24, 2008
    Messages:
    42
    Likes Received:
    0
    I guess I must be a real airhead. I have read those articles but I must still be doing something wrong. I have given permission both in sharing and security. In sharing it says "Everyone" and I gave that entry full control. In Security, System,
    Aministrators (Desktop/Adminstrators) and Users (Destop/Users) all have full control. That is all I know to do. I can share the Shared folders but that is it. None of my drives or other folders are sharing althought they do show up as being shared. Again, I can access all my drives and folders on my laptop from my desktop but can't access my drives and folders on my destop from my laptop. I did the sharing and permission the same on both desktop and laptop. I just don't understand what gives????
     
  4. Celestra

    Celestra Former Moderator

    Joined:
    Jan 15, 2008
    Messages:
    2,468
    Likes Received:
    14
    Did you have sharing turned on ? Are there any error codes ?
     
  5. luvflt

    luvflt New Member

    Joined:
    Dec 24, 2008
    Messages:
    42
    Likes Received:
    0
    Yes, sharing is on. Everything is on. The error reads:
    "Windows cannot access \\Desktop\C check the spelling of the name. Otherwise there might be a problem with your network. To try to identify and resolve problems click Diagnose. After clicking Diagnose:

    "C" is available but the user account that you are logged on to was denied access.

    Windows cannot further diagnose the problem because network diagnostics does not know the user namew and password required to connect to the shared folder (there really aren't any)

    Make sure you typed the path correctly and you have permission to access the shared folder

    If you are trying to access the shared folder with a user name and password that is different then that used to log onto this computer make sure you entered it correctly. (Again I don't use a user name or password)

    This is what I keep getting????
     
  6. luvflt

    luvflt New Member

    Joined:
    Dec 24, 2008
    Messages:
    42
    Likes Received:
    0
    Ok well I just read where it said if you can access the public files and folders but not other drives, files or folders than it is a permission issue. So knowing that I am out of things to do as I have give all the drives, files and folders all the permission I can unless I need to add a different name. Both machines have the same user name and no password assigned. Both machines have only one administrator login account and that is it. What name or group am I supposed to give permission to? As I mentioned above I have given full control to all the users and groups listed but I have not added anything. Still confused and very frustrated. XP was never this difficult!!
     
  7. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    If you open Windows Explorer and scroll down to the bottom, to "My Network Places" - "Entire Network" - "Microsoft Windows Network". As I understand you, you should then see your main computer, in the sub folder,, listed as "Home" (Or whatever you have called your Desktop) Correct?
    If you cannot see anything in that folder, try this.
    right click the lan icon on the toolbar and "Open Network connections"
    Right click your local area connection and properties.
    Make sure you have File and printer sharing" selected.


    If you still cannot see anything on your desktop from the laptop, go to the desktop and open the (in the same way - from the icon) "Network and sharing" window. Look at the bottom portion of the window and see if you have the various functions enabled.

    I must emphasise that I am no networking wizz. This is merely an outline of my own procedures, which works for me when I have visitors wishing to use my network facilities.
     
  8. luvflt

    luvflt New Member

    Joined:
    Dec 24, 2008
    Messages:
    42
    Likes Received:
    0
    DAvehc,

    I can see my "Desktop" and my "Laptop" in Networking. If I click on each of those I can see all the shared drives, folders and files. They are all there as shared. If I am on my Destop and do this I can access all the files on my Laptop. If I am on my Laptop and do this I can see all my "Destop" drives and folders but the only one I can access without an error is "Public" folders. I cannot access my drives. I set both computers up the same way (sharing and security) both computers have the same user name. Both computers are Vista Home Premium. Both computers have Internet access via the router. As I mentinoed about the fact that I can access my public files makes this a permission issues. I just don't know what or who else to give permission to. I know I have to be close for it all to almost work. Thanks.
     
  9. luvflt

    luvflt New Member

    Joined:
    Dec 24, 2008
    Messages:
    42
    Likes Received:
    0
    Ok, so maybe I am not an air-head after all. Once again my perservearance paid off. Actually I went in to the public folder to see how permission was granted and the light came on. For those having trouble like I have had, this is the answer.
    For Windows Vista Users:
    Oviously make sure file sharing is on then do the follow:
    Rt. click the drive or folder or file to share
    click properties
    click sharing
    click advanced sharing
    check the box share this folder
    click permission
    check the box full control
    click ok
    click ok
    click Security tab
    click edit
    click add
    under "Enter the object names" type the word everyone
    click ok
    ensure "everyone" is highlighted
    check the box for full control
    click ok

    Do that for every drive, folder or file you want to share and this will give full access to everyone

    I hope that saves someone the numerous hours it took me to figure this out! Good Luck :D
     
  10. Celestra

    Celestra Former Moderator

    Joined:
    Jan 15, 2008
    Messages:
    2,468
    Likes Received:
    14
  11. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Hi luvft. OK. If it works for you,then go for it. I think, though, you may have opened up your computer for anyone who cares to hack in. Mayb a security minded reader could confirm that?
    Celestra's last link gives some good tips. I can see one was very similar to mine and one was quite close to what you eventually achieved.
     

Share This Page

Loading...