How to change the network type?

#21
Connecting to my Access Point (WEP, Shared Key) works fine, but the network type becomes PUBLIC in the Network and Sharing Center and I cannot change it, it is read only there! My computer is not part of a domain but a member of a workgroup.

I need to change the network type for the above WiFi connection to WORK/HoME.

Please help. Thank you in advance.
Hi SkJOI2001,

I totally understand the issue you had face, I have the same problem too. Just bought 3 laptop and started to set up the network and I couldn,t recall how I end up setting up one of the 3 laptop into a "PUBLIC" network. The other 2 laptop which is in the WORKAREA network work just fine in my office wired network and manage to see all the user within the same network. As you had mentioned, in the Network place there is no option to change the PUBLIC network to other options as i found in the other 2 laptop which the option to change is available.... Frustratingly need help.......

Jeff Chun
 


#22
Hi SkJOI2001,

I totally understand the issue you had face, I have the same problem too. Just bought 3 laptop and started to set up the network and I couldn,t recall how I end up setting up one of the 3 laptop into a "PUBLIC" network. The other 2 laptop which is in the WORKAREA network work just fine in my office wired network and manage to see all the user within the same network. As you had mentioned, in the Network place there is no option to change the PUBLIC network to other options as i found in the other 2 laptop which the option to change is available.... Frustratingly need help.......

Jeff Chun
Check out the entire thread, this trouble is UNDERSTOOD and resolved with explanations.
 


#23
Another variant of the problem - please MS, re-model the Windows networking category architecture!

I have had this problem as well, again a little bit different from everyone else. I have a standard home network with a router/gateway with DHCP server. When I connected using DHCP IP assignment it worked normal, but when I set a static IP in Windows 7 (in the TCP/IP v4 configuration dialog) it would give me the unidentified network troubles.

The solution was linked to the 'no default gateway specified' issue, I think, even though I off course specified the correct default gateway (192.168.1.1 in my case). The problem was that it didn't apply this setting. When I changed it to 192.168.1.2 and then back to 192.168.1.1, it suddenly worked. No more unidentified network. It's the strangest thing!
 


#24
Re: How to fix UNDEFINED NETWORK :)

Not sure if I have the same root problem. I've just upgraded from Vista Home-P to W7 Home-P and the laptop connects to the router and to the internet, and stangely to the other home network shared resources too - but the network is showing as unidentified and I can not amend the location definition to HOME.

The only real problem is that the network tray icon shows as not connected - which is an irritant.

Anyway - I'l try with manual IP and default gateway tonight - see if I can kick it into the 21st century.

Thanks for your posts
 


#25
Re: How to fix UNDEFINED NETWORK :)

Hi guys, you need to set your default gateway within TCPIP 4 properties, go to setting within the respective network adaptor and then click advanced and then set the routers ip (internal not external) as the default gateway...

Once done, windows 7 will be able to identify the network and you can change it from Public to home or whatever you wish.

Thanks Jrouse!
 


#26
ok, I have read all thread here.

But there is one special case that I don't know how to fix.

Is when you have Windows 7, and use two Network Cards, one connected to Internet (Cable or DSL), and the other to connect to home computer network.

I'm using Windows 7 Sharing Utility, and by default the network card (home network) gets IP address 192.168.137.1 and subnetmask 255.255.255.0

There is not Default-Gateway or DNS setup, and if you try to place anything on those boxes it will reset back to only the two settings above (IP and mask).

So the network always appears as UNIDENTIFIED NETWORK and as type: PUBLIC

I would like to hear any suggestion on how to fix this as I would like very much to change the type of this to HOME as the network it is a home network (private network 192.168.137.0)

thank you very much for any solution.
 


#27
ok, I have read all thread here.

But there is one special case that I don't know how to fix.

Is when you have Windows 7, and use two Network Cards, one connected to Internet (Cable or DSL), and the other to connect to home computer network.

I'm using Windows 7 Sharing Utility, and by default the network card (home network) gets IP address 192.168.137.1 and subnetmask 255.255.255.0

There is not Default-Gateway or DNS setup, and if you try to place anything on those boxes it will reset back to only the two settings above (IP and mask).

So the network always appears as UNIDENTIFIED NETWORK and as type: PUBLIC

I would like to hear any suggestion on how to fix this as I would like very much to change the type of this to HOME as the network it is a home network (private network 192.168.137.0)

thank you very much for any solution.
Unfortunately, you need to remain like that. I understand your issue, because I had the almost same network topology at my home, one cable connection connected to the internet that had the default gateway settings and recognized well by the Windows 7, and another WiFi connection to my home network, that was not recognized by Windows 7 because it had no default gateway configuration. And you cannot set a default gateway for the home network's interface, why? Because that will cause redundancy as you already have a default gateway on your internet interface.

The most meaningful resolution to this trouble is to set up the entire through a router, inserting the internet connection to the router and making all the computers connect to the home network through the router. This way, you can join the home network and also to the internet using only one network card and bye bye to UNDEFINED NETWORK forever.
 


#28
Unfortunately, you need to remain like that. I understand your issue, because I had the almost same network topology at my home, one cable connection connected to the internet that had the default gateway settings and recognized well by the Windows 7, and another WiFi connection to my home network, that was not recognized by Windows 7 because it had no default gateway configuration. And you cannot set a default gateway for the home network's interface, why? Because that will cause redundancy as you already have a default gateway on your internet interface.

The most meaningful resolution to this trouble is to set up the entire through a router, inserting the internet connection to the router and making all the computers connect to the home network through the router. This way, you can join the home network and also to the internet using only one network card and bye bye to UNDEFINED NETWORK forever.
thanks for your reply.
What you just explained was exactly what I did and now all is working fine, except for one minor inconvenience.

When I had the old configuration, porT 80 was open and I had a home webserver running in that port, and with a free dns setup from zoneedit I had this server working great available with aN internet DNS name. But after installing this router and all computers sharing the internet, (only 1 NIC card in all PC's), the web-server just kaput, not more, . I did configured the router to placed the computer running the web-server in a DMZ zone, I even opened ports 80, 443 and other to this 'only computer', and still the web-server don't' show up. it only shows up as http: // localhost or http: // 127.0.0.1 but not with the DNS name.

the router is a Netgear CG814WG (wireless and 4 port Ethernet).
HELP APPRECIATED.
 


#29
thanks for your reply.
What you just explained was exactly what I did and now all is working fine, except for one minor inconvenience.

When I had the old configuration, porT 80 was open and I had a home webserver running in that port, and with a free dns setup from zoneedit I had this server working great available with aN internet DNS name. But after installing this router and all computers sharing the internet, (only 1 NIC card in all PC's), the web-server just kaput, not more, . I did configured the router to placed the computer running the web-server in a DMZ zone, I even opened ports 80, 443 and other to this 'only computer', and still the web-server don't' show up. it only shows up as http: // localhost or http: // 127.0.0.1 but not with the DNS name.

the router is a Netgear CG814WG (wireless and 4 port Ethernet).
HELP APPRECIATED.
Fortunately, I have the exact same setup at home as you have. Well, I have a real IP too, that is why I don't need to configure DNS through ZoneEdit or DynDNS or something like that.

a. Configure your router to assign the same static local IP always to your computer having the web server;
b. Configure your router to forward the ports 80 & 443 from internet to the computer having the web server;
c. Configure the Windows Firewall with Advanced Security (found in the Administrative Tools) to let IIS be called from Domain, Public & Private profiles under the Incoming rules node;
d. Now you should be able to access the web server from localhost, LAN & WAN (I assume you have a real IP to the internet);

The step 'c' is really important because Windows 7 disables that rule by default making IIS invisible to the outer world than localhost.

Another issue is, never enable the DMZ for any machine in your LAN from the router, you simply may lose the machine causing a reformat every week ;)
 


#30
Fortunately, I have the exact same setup at home as you have. Well, I have a real IP too, that is why I don't need to configure DNS through ZoneEdit or DynDNS or something like that.

a. Configure your router to assign the same static local IP always to your computer having the web server;
b. Configure your router to forward the ports 80 & 443 from internet to the computer having the web server;
c. Configure the Windows Firewall with Advanced Security (found in the Administrative Tools) to let IIS be called from Domain, Public & Private profiles under the Incoming rules node;
d. Now you should be able to access the web server from localhost, LAN & WAN (I assume you have a real IP to the internet);

The step 'c' is really important because Windows 7 disables that rule by default making IIS invisible to the outer world than localhost.

Another issue is, never enable the DMZ for any machine in your LAN from the router, you simply may lose the machine causing a reformat every week ;)
The main point (c) you made doesn't apply, I forgot to mention I am running Tomcat 6 apache webserver, and windows firewall is not in use, as it is controlled by Norton Internet Suite and this firewall has been setup to let tomcat app go through.

I did though configured static IP for the pc running tomcat webserver, but still not outside connection. Took this computer out of DMZ and still not connection. Set por-forward 80 and 443 on router to this computer and still not connection. Only localhost and 127.0.0.1 has connection.

I'm running Windows 7 64-bit
 


#31
The main point (c) you made doesn't apply, I forgot to mention I am running Tomcat 6 apache webserver, and windows firewall is not in use, as it is controlled by Norton Internet Suite and this firewall has been setup to let tomcat app go through.

I did though configured static IP for the pc running tomcat webserver, but still not outside connection. Took this computer out of DMZ and still not connection. Set por-forward 80 and 443 on router to this computer and still not connection. Only localhost and 127.0.0.1 has connection.

I'm running Windows 7 64-bit
Rule#1: Turn off any firewall before troubleshooting network related issues.

Then check you can access the web server from another machine in the LAN, if you cannot, then it is either that the TomCat is configured for LocalHost only or the firewall is blocking incoming connections.

If the web server is accessible from any machine within the LAN, then you should be able to access it from the internet through the router fi you have a real IP and port forwardings are correct.
 


#32
Rule#1: Turn off any firewall before troubleshooting network related issues.

Then check you can access the web server from another machine in the LAN, if you cannot, then it is either that the TomCat is configured for LocalHost only or the firewall is blocking incoming connections.

If the web server is accessible from any machine within the LAN, then you should be able to access it from the internet through the router fi you have a real IP and port forwardings are correct.
I do can access the webserver from inside the lan, the IP of the webserver is 192.168.0.10

And I do have an IP address (static from comcast) on the WAN side, and if I type that IP I get this message in Firefox:

"Unable to connect
Firefox can't establish a connection to the server at htt: // mywebsit.
The site could be temporarily unavailable or too busy. Try again in a few
moments.
If you are unable to load any pages, check your computer's network
connection.
If your computer or network is protected by a firewall or proxy, make sure
that Firefox is permitted to access the Web, TRY AGAIN"

in IE9 I get: "Internet Explorer cannot display the webpage"
 


#33
I do can access the webserver from inside the lan, the IP of the webserver is 192.168.0.10

And I do have an IP address (static from comcast) on the WAN side, and if I type that IP I get this message in Firefox:

"Unable to connect
Firefox can't establish a connection to the server at htt: // mywebsit.
The site could be temporarily unavailable or too busy. Try again in a few
moments.
If you are unable to load any pages, check your computer's network
connection.
If your computer or network is protected by a firewall or proxy, make sure
that Firefox is permitted to access the Web, TRY AGAIN"

in IE9 I get: "Internet Explorer cannot display the webpage"
Check with some network utility like CurrPort to check that your TomCap is really listenning on all TCP ports (0.0.0.0) or to the WAN TCP besides the LAN TCP port. This will ensure that TomCat is listenning on the appropriate network interface.

Once the above is okay, and if you still can't access the web server from the WAN, then the next thing to check out your firewall settings once again, it might be blocking the incoming connections through WAN while allowing through LAN, that is why you can access the web server within the LAN, but not from the WAN.

And if still you can't reach it from WAN, then it is definitely your router's configuration with port forwarding. Make sure you can access the router's admin panel from the internet (not within the LAN), this will ensure that the router is really accessible through WAN, and then check the port forwardings and LAN IP assignment to the web server.
 


#34
Hi Guys!

Read up all over the internet and found this forum and hope I can find some help. I am on Windows 7 Home Edition (upgraded from Vista).

I am currently baffled by the problem I am facing and would like to know what I can do to troubleshoot.

I have a setup, a PC running XP Home Edition, linking up to a LAN via onboard ethernet port. I installed a router via USB connection to the same pc. I read on the net and configured the PC to connect via LAN and use the router only to connect to the attached printers so that they can be shared via network.

Everything configured nicely until my Windows 7 laptop decided to place this wireless router connection under Public and no matter what I do, I am unable to link to this network. I tried to change my adapter settings and manually configured an IP Address 192.168.1.23 and I am able to link up to the Windows XP PC.

Question is, I was able to connect to the router without having to configure it and it was set as WORK under network type. However, one day, it suddenly switched to PUBLIC and from then onwards, no matter what I do, I will not be able to link up to it via WORK other than PUBLIC, the only way I can do wireless network printing was to manually set the IP Address and configure it for it to connect.

1. Will re-installing my Wireless Adapter driver help?
2. Could it be the Anti-Virus software that is causing the problem? Disabling it did not help.
3. Windows Firewall?

Please advise. Thank you.
 


Peterr

Honorable Member
#35
I just wanted you to know that my Belkin router has to be attached to my second pc in order to establish connectivity while settting up a homegroup' password.. After it is established I can remove the ethernet cable.
i only mention this to point out how fickle some software can be and the work arounds are not ez to come up with.
 


#36
Hi Peter!

Thanks for the feedback. Anyway, I went back and tried to manually assign the IP Address under the IPv4 of the Ethernet card that has problem connecting. I disabled the IPv6 on the same card and it could connected. The only remaining issue now is that it is displayed as 'Unidentified Network / No Internet Access' now, but I am fine with it as I can connect to the wireless printers attached to the Win XP PC, and I am able to connect to the Internet via my other Wireless Connection. My problems are resolved for now and I think disabling IPv6 solved this issue. Thank you.

However,
I just wanted you to know that my Belkin router has to be attached to my second pc in order to establish connectivity while settting up a homegroup' password.. After it is established I can remove the ethernet cable.
i only mention this to point out how fickle some software can be and the work arounds are not ez to come up with.
 


Peterr

Honorable Member
#37
I wish I had the skill to help. I am writing because I too have Norton's Internet Security Suite and it usually means there is an issue to be attended to as it causes trouble..
Example, you have to disable tamper protection to run system restore.
I hope the skilled users can help you here.
 


Peterr

Honorable Member
#38
I may be reading this wrong but;
1-first set up your router to wpa at least with a strong password and passphrase. Then set up a homegroup using the windows 7 prompts. Once the homegoup is set up you can then fileshare. Using work groups is the older way of file sharing . Both pcs must have Win 7 to run Homegroup.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.