How to disable double click

Discussion in 'Windows 7 Hardware' started by eladkatz, Jun 18, 2010.

  1. eladkatz

    eladkatz New Member

    Joined:
    Jun 18, 2010
    Messages:
    12
    Likes Received:
    0
    I want to disable the double click on my windows 7 (temporarily of course), not through the folder options menu but simply tell windows to think every double click is two seperate clicks. how do i do that?
     
  2. Digerati

    Digerati Fantastic Member
    Microsoft MVP

    Joined:
    Oct 25, 2009
    Messages:
    2,069
    Likes Received:
    159
    Don't click so fast! Alternatively, go into your mouse properties from Control Panel and change the double-click settings.
     
  3. eladkatz

    eladkatz New Member

    Joined:
    Jun 18, 2010
    Messages:
    12
    Likes Received:
    0
    PLS u dont understand my problem, i just need to disable double click at all, and make the computer think its just two clicks. the control panel only allows the maximum length of the double click up to a certain point, i need to disable it entirely (is there any way to make it zero?) perhaps there is a certain registery value i can change or something?
     
  4. Digerati

    Digerati Fantastic Member
    Microsoft MVP

    Joined:
    Oct 25, 2009
    Messages:
    2,069
    Likes Received:
    159
    I don't think you can diable it completely but if you go into Mouse Properties from Control Panel and change the setting all the way to the "fast" side, you would have to be Superman to click it fast enough.
     
  5. eladkatz

    eladkatz New Member

    Joined:
    Jun 18, 2010
    Messages:
    12
    Likes Received:
    0
    i can easily double click even if its fast, most of my double clicks are fast enough even for the "fast". i was thinking if there is a registry value for the maximal length of the double click, then maybe i can just set it to zero or something really low?
     
  6. Digerati

    Digerati Fantastic Member
    Microsoft MVP

    Joined:
    Oct 25, 2009
    Messages:
    2,069
    Likes Received:
    159
    Wow. I am surprised setting it to Fast does not work for you. Did you click "Apply" after moving the slider all the way over?

    Since double-clicking is such a integral part of using a GUI (graphical user interface) as well as many programs and add-ons, not sure totally disabling it is possible.

    You can disable double clicking for opening files and folders. Right click on Computer select Properties > Tools > Folder Options then under the General tab, select Single-click to open an item then OK.
     
  7. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,841
    Likes Received:
    1,568
    Here's how I do it (pretty similar to Digerati's method)
    View attachment 6685

    I know the OP said not to use folder options but I'm not sure there is any other way?
     
  8. eladkatz

    eladkatz New Member

    Joined:
    Jun 18, 2010
    Messages:
    12
    Likes Received:
    0
    something involving registry maybe?
    it just makes sense that if i can set the maximum double click speed through windows i can also set it through the registry, i just need to know the location of the appropriate value.
    yes, i did click "apply" and it isnt so difficult to double click, and im a heavy pc user.
     
  9. Nibiru2012

    Nibiru2012 New Member

    Joined:
    Dec 16, 2009
    Messages:
    466
    Likes Received:
    18
    eladkatz - This is very easy to accomplish.

    The situation is you're trying to make a "mountain out of a molehill" so to speak.

    It only takes 15-20 seconds to change the folder options from single-click to double-click.
    Just use that method.

    1. Go to Control Panel
    2. Go to Folder Options
    3. Select "Single Click to open an item"

    [​IMG]

    4. Click Apply or Okay and you're good to go! Easy peasy, lemon squeezy! :cool:
     
    #9 Nibiru2012, Jun 22, 2010
    Last edited: Jun 22, 2010
  10. Digerati

    Digerati Fantastic Member
    Microsoft MVP

    Joined:
    Oct 25, 2009
    Messages:
    2,069
    Likes Received:
    159
    Ummm, Nirbiru2012 - appreciate your input but that's the same thing suggested twice above, and what the OP said he wanted to avoid.
     
  11. Nibiru2012

    Nibiru2012 New Member

    Joined:
    Dec 16, 2009
    Messages:
    466
    Likes Received:
    18
    I understood that prior to posting. I was my attempt to have him realize that it's only a mere several seconds to change his options is all.

    Do you know of another way to do it? I don't, unless theres a tweak program somewhere.

    Like I stated: I think he's making a mountain out of a molehill,

    Thanks for the feedback Dig ;)
     
  12. eladkatz

    eladkatz New Member

    Joined:
    Jun 18, 2010
    Messages:
    12
    Likes Received:
    0
    i KNOW it only takes several seconds, several WASTED seconds as this is not what i want to do.
    i cant disable double click through "folder options", i can only change its purpose but i want to disable it not just for windows explorer but for other programs as well.
    like i said, it would be really helpful if someone knows the registry value of the maximum double click duration.
     
  13. Nibiru2012

    Nibiru2012 New Member

    Joined:
    Dec 16, 2009
    Messages:
    466
    Likes Received:
    18
    I have single-click enabled and I don't have any issues with it to open files, folders, programs, music, photos, install software, run executables,etc.

    What exactly is the issue you're having?
     
  14. eladkatz

    eladkatz New Member

    Joined:
    Jun 18, 2010
    Messages:
    12
    Likes Received:
    0
    the problem with the "single click" option is that it doesn't apply for other programs but windows explorer. if i double click in any other program but windows explorer, it is still recognized as double clicks and not two single clicks.
     
  15. xudo

    xudo New Member

    Joined:
    Feb 25, 2011
    Messages:
    2
    Likes Received:
    1
    Ok, this is an old thread but I happened to find my way here with a quick google search. My problem was a malfunctioning mouse which would give me two click is rapid succession with single click. Just needed a dirty fix until I get my new mouse. Didn't find my answer after few tries, so I decided to brute my way in to solution (Process Monitor, great tool).

    The registry entry you should look for is,
    "DoubleClickSpeed" in HKEY_CURRENT_USER\Control Panel\Mouse

    The default Control Panel values range from 900 (slow) to 200 (fast). So a small number should work, I found 50 be impossible for me to get a double click to happen. You can go as low as 1, but a 0 will not work good, seems revert to some slow value in practice.
     
    #15 xudo, Feb 25, 2011
    Last edited: Feb 25, 2011
    Sincrono likes this.
  16. Sincrono

    Sincrono New Member

    Joined:
    Feb 24, 2014
    Messages:
    1
    Likes Received:
    0
    Xudo your solution worked for me, but when using two monitors with an extended desktop, the double click is disabled only for elements in one of the monitors. On the principal monitor the double click persists, and in the secondary one is erased. Thqts very weird, itseems that mouse properties change when going frrom one portion of the desktop (in monitor 1) to the other portion displayed on the other monitor. I looked for other plqces of the registry and didnt find other place tu change mouse double click speed.
     

Share This Page

Loading...