How to stop Windows 7 from logging you out?

Discussion in 'Windows 7 Help and Support' started by xsirxx, Aug 9, 2009.

  1. xsirxx

    xsirxx New Member

    Joined:
    Aug 9, 2009
    Messages:
    10
    Likes Received:
    0
    I have tasks that I need to keep running while I am away from the computer and they are getting locked up and not running everytime Windows 7 logs me out after 10-15 minutes or so.

    So my question is, does anyone know how to stop Windows 7 from automatically logging you out? So I can stay logged in?

    Thanks!
     
  2. textureDnB

    textureDnB New Member

    Joined:
    Jun 29, 2009
    Messages:
    652
    Likes Received:
    6
    Is the machine a laptop, is it going to stand by? Check your power settings in the control panel. I don't believe W7 has the facility to auto log out native (if it does i would like to know i could use that on the comp. that has my financial data) however anytime vista and seven go into standby they auto log out.
     
  3. xsirxx

    xsirxx New Member

    Joined:
    Aug 9, 2009
    Messages:
    10
    Likes Received:
    0
    No its a regular desktop. If i leave it idle for 10-15 minutes, when i move the mouse when i get back on - i have to log back in. All my windows are still up but it seems to stall them all while im not at the computer.
     
  4. Camride

    Camride New Member

    Joined:
    Jan 17, 2009
    Messages:
    304
    Likes Received:
    12
    Start(Orb)>Control Panel (show all icons)>Power and select "Require Password on Wake up", then turn that off. That will keep it from locking the desktop when your screen saver pops up or your monitor turns itself off. Typically a program can continue to run without a problem with the computer locked, so I'm not sure why your program is having issues with that. I leave my desktop running 24/7 and remote into it all the time (which locks the local session out) and I never have problems with any of my background programs (uTorrent, Steam, etc).

    What program is it, and what happens when the computer locks?
     
  5. xsirxx

    xsirxx New Member

    Joined:
    Aug 9, 2009
    Messages:
    10
    Likes Received:
    0
    nzb-o-matic. It kicks off the internet connection it seems. It stops all transmission.

    Ahh under the power settings for some reason after 30 minutes it was told to sleep.... Changed that and I assume it should all work normally now... thanks
     
    #5 xsirxx, Aug 9, 2009
    Last edited: Aug 9, 2009
  6. Camride

    Camride New Member

    Joined:
    Jan 17, 2009
    Messages:
    304
    Likes Received:
    12
    Might want to check if Windows has your NIC set to power itself off to save power. Click Start>Right click on Computer and select Manage. Select Device Manager and find your network card, right click and select properties. Click on the power management tab and uncheck "turn this device off to save power".

    Hopefully between those two things it shouldn't disconnect your network session.
     
  7. xsirxx

    xsirxx New Member

    Joined:
    Aug 9, 2009
    Messages:
    10
    Likes Received:
    0
    ahh very nice yea that was set to power off as well. Man there anything else hiding around that would be good to change? heh again thanks alot for your time!

    Brad
     
  8. Camride

    Camride New Member

    Joined:
    Jan 17, 2009
    Messages:
    304
    Likes Received:
    12
    That should be anything that would effect your network connection. Let us know if it's still doing it after that.
     
  9. equinox

    equinox New Member

    Joined:
    Aug 15, 2011
    Messages:
    6
    Likes Received:
    0
    I have followed all the tips to this question and still my Windows 7 logs out when I am not using it. Help???
     
  10. Conduct

    Conduct Banned

    Joined:
    Jul 15, 2011
    Messages:
    167
    Likes Received:
    0
    Right click on desktop and click Personalize. Then go to screensaver, it should be on the bottom right area. Make sure the box that say "On resume, display login screen" is unchecked or if it is give it a longer time until you have to log in again.

    You can also change the sleep and dim settings for the screen by typing in sleep in the search box.
     
  11. equinox

    equinox New Member

    Joined:
    Aug 15, 2011
    Messages:
    6
    Likes Received:
    0
    :frown:Thank you for your response conduct BUT I have tried those suggestions and it still doesn't work for me
     
  12. Conduct

    Conduct Banned

    Joined:
    Jul 15, 2011
    Messages:
    167
    Likes Received:
    0
    Try this:

    If sleep,control panel>hardware and sound>change when computer sleeps>adjust accordingly.

    Good Luck with this one.
     
  13. equinox

    equinox New Member

    Joined:
    Aug 15, 2011
    Messages:
    6
    Likes Received:
    0
    I tried your latest suggestion conduct and still it logs out. Oh well, it's no biggie...thanks for your help anyway <S>
     
  14. Conduct

    Conduct Banned

    Joined:
    Jul 15, 2011
    Messages:
    167
    Likes Received:
    0
    I might have the same problem as you but it don't log me out all the time.
     
  15. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Not exactly the answer to your problem, but on the rare occasions I want my PC not go to sleep I run a free app. called Auto Clicker.

    I set it to give a mouse click every 10 minutes or so and it keeps the PC awake.
     

Share This Page

Loading...