Jedi Knight Academy OpenGL Prob...

Discussion in 'Windows Vista Help and Support' started by GUY_9000, Jul 24, 2006.

  1. Odiernod

    Odiernod Guest

    Download and install GLDirect. It makes OpenGL games use DirectX instead.

    You may need to download DirectX 9. Don't worry, it won't mess with any of your Direct X 10 stuff.

    Make sure that GLDirect has rendering set to your Video card rather than software rendering.

    Here is the link. ftp://ftp.scitechsoft.com/gld

    After install, click the free-gldirect-code.txt. The product used to be shareware, now they have released it for free. Got Jedi Academy running on Vista with this.
     
  2. I have that problem on Windows XP for some time now...i have a Radeon 9600 Family PRO, and 2 years ago, that game used to work...why isn't it working now? I get the same thing for Counter Strike 1.6 ...
     
  3. THANK YOU A LOT

    You have helped me in the fight against LucasArts (aka you have helped me get one of their games to frigging work).

    I am spreading the word about GLDirect as much as possible.

    LucasArts really piss me off how faulty their games are. I have a Best Of collection and so far only 1 of the games has worked properly!!
     
  4. i had the prob but i have a diff one now but if you get the update then right click the jk3 icon it should have the option to run as adminastrator do that hopefully it should work
     
  5. swoosh21

    swoosh21 New Member

    Joined:
    Dec 12, 2008
    Messages:
    2
    Likes Received:
    0

    the link is not working!!! can u upload it again please??

    does it work for win xp?, i have the same opengl problem :(
     
  6. vaderman212

    vaderman212 New Member

    Joined:
    Jan 9, 2011
    Messages:
    2
    Likes Received:
    0
    FYI for all of you playing the Jedi Knight series on Vista and 7, I'm 99% sure it's Windows' fault. My computer I'm trying to play Jedi Knight II: Jedi Outcast from the Fan Favorites or the Best of PC pack as I have both. I've also tried jedi Acadamy and found that that doesn't work either. Now my computer is an HP Pavilion Elite High Performance Edition. Look it up. It's awesome. Now THAT computer is definatley qualified to run that game and is unable for no discernable reason. Go figure. Let me know if anyone figures it out.
     

Share This Page

Loading...