Keep being asked for "network password"

Discussion in 'Windows 7 Networking' started by dre2112, Oct 24, 2011.

  1. dre2112

    dre2112 New Member

    Joined:
    Oct 24, 2011
    Messages:
    2
    Likes Received:
    0
    Here's the issue. I have 4 computers (3PCs and 1Laptop) on a home network (not a homegroup). All are connected to the same workgroup. All share the same internet connection. Up until last week, all of them had absolutely no issue sharing files or using the printer.

    Now however, my laptop will not connect to one of the PCs and that's the PC that is connected to our printer. Both the laptop and the printerPC are running the same version of Win 7 (Home Premium). The problem is connecting from the laptop to the printerPC I keep being asked for a "network password." I have file and printer sharing enabled and password protection disabled. Firewall and anti-virus are off. The strangest part is that my printerPC can access my laptop without passwords yet my laptop cannot access my printerPC without one and I've never even set up a login/password for network sharing to begin with so I don't really understand why this is happening or what's causing this because as I said earlier this wasn't a problem up until a week ago.
     
  2. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    Hi dre,

    You have identified two issues that likely have the same cause. These issues are:

    Unwanted printer sharing password requirements over a Windows 7 workgroup
    Unwanted file sharing password requirements over a Windows 7 workgroup

    Here are some tips to resolve your problem:

    Step 1: Enable Simple File Sharing in Windows 7

    Perform this task on all systems on your network that are having connection difficulties.

    In Windows Explorer, make sure Simple File Sharing is enabled. To do this, go to Start -> Search -> Folder options

    Scroll down to the bottom of the View tab:

    Make sure Use Sharing Wizard (Recommended) has a check mark.

    Step 2: Manage advanced sharing settings for Home or Work Profiles

    Go to Start -> Search -> Advanced sharing

    Optimal Settings:

    Turn on Network Discovery
    Turn on file and printer sharing
    Turn on public folder sharing
    Turn off password protected sharing

    Step 3: Make sure you are not on an "unidentified" or "public" network

    Go to Start -> Search -> Network and Sharing Center
    Make sure you are on a HOME network.

    Finally..

    Step 4: Make sure the username and password on both computers are the same

    You want to make sure that the login credentials are the same for both systems. Even though the Windows systems understand that these are separate accounts by using the account security identifier (SID), logging in with the same username will give you access a heck of a lot easier.

    Step 5: Consider actually using HomeGroups or an Online File Sharing System Like Dropbox

    This is a situation where you would really benefit from the use of HomeGroups. Why? Because your user accounts seem to be having authentication difficulties on the workgroup, HomeGroups mitigate that process. They are specifically designed as a new, secure feature for Windows 7 client machines where a Windows Server is not necessary, but a more robust system is required. Under HomeGroups, you never really have to worry about using passwords once every system is linked up.

    Similarly, for file sharing that works across computers universally, Dropbox is an excellent solution. Check it out to see how you can benefit from 2GB of free storage space and share your files universally across systems and networks with industry-accredited security. You can access your files from anywhere, even on the go using your laptop. I hope these tips help. Please let me know if any one of them resolves your difficulty. Generally speaking, we are looking at resolving any possible obstacles to sharing out your files without password protection on the local area network exclusively.
     

    Attached Files:

    #2 Mike, Oct 25, 2011
    Last edited by a moderator: Oct 25, 2011

Share This Page

Loading...