LAN shares not accessible

I'm a professional Windows user and technician, but I hate Win8 & 10, so I've never had either on my own devices to get familiar with...until Dec. 2018.

I have a Lenovo laptop running Windows 10 Home x64. I have disabled all telemetry user settings, added the "AllowTelemetry" registry entry with a DWORD value of 0x0 (zero), and disabled the 2 services associated with telemetry (dmwappushsvc & Connected User Experiences and Telemetry). I also have 2 custom built Windows 7 PCs and 2 Synology NAS servers.

The Win7 PCs and NAS servers are all accessible within the LAN via Ethernet cable and WiFi. However, the Win10 laptop is visible, but not accessible. I have a laser printer shared on the laptop, and a few folders so I can transfer files between devices, with the 'Everyone' group manually added with necessary permissions, but when I try to install the printer, or open a shared folder from a Win7 PC, it asks for a username and password, but there is no password, and an error message pops up saying I don't have permission to access the device. Occasionally, when trying to access either NAS, Windows will generate an error informing me to enable Network Discovery, but Network Discovery is already enabled, I triple checked.

So what the heck is going on with Windows 10? Is it just me, or is it disastrously flawed?
 

Neemobeer

Windows Forum Team
Staff member
Well for starters completely disabling telemetry will break Windows updates, you need to at least have basic telemetry enabled.

Have you gone through and "tweaked" or disabled anything else such as services? Do you have a firewall on the Win 10 host? A wireshark capture would also be very help in diagnosing the issue.
 

Josephur

Windows Forum Admin
Staff member
Premium Supporter
Make sure the network location is set as a Private network:
37757



Verify that Network discovery and File and printer sharing are enabled for Private networks:
37758


On your shared folder that you want with no password you may need to add Everyone and Guest to at least read access on the share. Even so I've seen issues with older versions of Windows still prompting for a password to the share, but I simply type in Anonymous as the username, and any password (I usually just type "x") and it should allow access to the share. Just be aware that passwordless file sharing is a huge security risk.
 

skvenus99

Senior Member
The password you're being asked for is your Windows login password. If you don't have a password set to login, create one and use the laptop's login details to access the share. Don't forget to tick 'remember details'.

Sent from my F8331 using Windows Forums mobile app
 
Top