Windows 7 Mass Effect will not install.

Discussion in 'Windows Games' started by pmm, May 18, 2009.

  1. pmm

    pmm New Member

    May 17, 2009
    Likes Received:
    Recently installed the 32bit client and am installing the games I still play. Mass Effect is not installing. Any assistance from those who may have run into similar problems and found a fix would be greatly appreciated. Otherwise, if you have any ideas, I'm open to suggestions to try to fix this problem.

    Problem: Will not install. Gets to a point and says it cannot open a particular file.
    Attempted solutions: Run as administrator: No Luck.

    Next attempt to install...failed at the same file.
    Still not installing...gets to a point and stops.
    Attempted workaround: I copied the disk to my hdd so I could run it from there as admin and run in compatibility mode. It got to the same point as when installing from disk and stopped.

    The Error:
    The error box says:

    Error opening file for writing
    C:\Program Files\Mass Effect\saferun.dll

    Attempted workaround:
    I manually created a directory called Mass Effect along the Program Files path, and placed a blank file I created called "saferun.dll", set the permissions to everyone and their brother and tried again, but no difference in results. Not sure if I can locate the file on the hdd copy of the iso, reset the permissions, and force it through, but I guess I will try that next...the idea just came to me as I wrote this.

    Anyway...any help would be appreciated...I can still play ME on my laptop at decent quality and framerates, but the screen is much smaller and the load times are excruciating.
    #1 pmm, May 18, 2009
    Last edited: May 18, 2009
  2. GreenxGreg

    GreenxGreg New Member

    May 12, 2009
    Likes Received:
    It doesn't sound like we had the same problem, but I'll offer up what happened to me just in case...

    My anti-virus kept quarantining some install files every time I tried to install Mass Effect. Running the installer with the anti-virus shut off let me install.

    Now I have to figure out why ME crashes every 20-30 minutes when I try to play :\....

    But anyway, it might be worth a shot, although it sounds like we had two different problems

Share This Page