Mass Storage Controller

Discussion in 'Windows 7 Hardware' started by H0lyGra1l, Apr 30, 2009.

  1. H0lyGra1l

    H0lyGra1l New Member

    Joined:
    Apr 30, 2009
    Messages:
    6
    Likes Received:
    0
    Hi,


    First of all, Great Os Windows 7.
    I have it running on my htpc with a Sempron 2800+ with only 756mb ram and it runs smooth as ever.

    Got it on my Dell Vostro 1510 as well,

    Only problem is it cannot detect the Mass Storage Controller.
    I have seen this problem on other forums as well, but nobody seems to know.

    I believe it is for my harddrive?
    Anyone knows how fix it?

    Drivers from the original vista dvd can't be found for Mass Storage Controller.
    And there are none downloadable.

    H0lyGra1l
     
  2. cmn

    cmn New Member

    Joined:
    Mar 17, 2009
    Messages:
    856
    Likes Received:
    45
    Hi H0lyGra1

    Where is the Motherboard SPEC? You might not have realized you have forgotten to post this MOST IMPORTANT information in answering the crux of your post i.e. why the new otherwise good win 7 system is ignoring the Mass Storage Controller on the Motherboard!

    You may download the Win Vista 32 or x64 ( appropriate to the Win 7 Bit you have installed) Chipset Driver - O2Micro OZH24 SD/MMC Host Controller from Dell download: Drivers and Downloads

    If you need help with install, please post back.
    Good luck and enjoy the Win 7 OS :)
     
  3. H0lyGra1l

    H0lyGra1l New Member

    Joined:
    Apr 30, 2009
    Messages:
    6
    Likes Received:
    0
    Yeah,

    Fixed that :)
    It was as you said the chipset driver. All is fixed now,
    Reinstalled to Vista tough cost i lost performance with my 8400M GS
    But when there's more support i will have another look.

    Till then still on my Sempron.

    Thanks.
     
  4. cmn

    cmn New Member

    Joined:
    Mar 17, 2009
    Messages:
    856
    Likes Received:
    45
    Glad to be of help. Will reread the post more carefully in about 4-6 hours to see if I can help you in fixing remaining problems as I will be away till that time.
     
  5. H0lyGra1l

    H0lyGra1l New Member

    Joined:
    Apr 30, 2009
    Messages:
    6
    Likes Received:
    0
    That won't be necessary.
    Dont think the GPU performance can't be solved.
    It doens't take the beta windows 7 drivers cuz they aren't for the mobile gpu's, at least not for the 8400 series.

    And, as is advised i used the vista drivers.
    But i still have an overall of a 10fps drope on most games.

    And because there's a lanparty tonight going on here, i changed back to vista :)

    Take care.
     
    #5 H0lyGra1l, May 1, 2009
    Last edited: May 1, 2009
  6. nuke49

    nuke49 New Member

    Joined:
    Jun 12, 2009
    Messages:
    2
    Likes Received:
    0
    mass controller storage

    I am having the same problem on my Gateway MA2 Laptop,can't see the drivers or update them! Help please.
     
  7. Nikoo

    Nikoo New Member

    Joined:
    Oct 13, 2009
    Messages:
    20
    Likes Received:
    0
    I have the same problem on my win 7 x64.

    I have tried some drivers for this motherboard but it always still singns that there is error and no drivers.

    My Motherboard is Asus M2N, and i hope im not rude but you know better, so can you give me the direct link to right drivers :D

    I have fought with this problem couple of weeks and really losing my mind here :p I have more info from this problem Here: http://windows7forums.com/windows-7-support/21047-problem-maxtor-sata-150-pci-card.html#post84978
     

Share This Page

Loading...