Missing drive Icon

#1
Hi

I am running Windows 7 and everything seems fine appart from the D drive showing a missing icon. The C drive is fine as are the DVD/DVDRW drives its only the D drive.

How do you go about replacing this? I had the same problem on Vista and when I installed 7 I thought that would be fixed but it isn't. Any help would be appreciated.

Thanks
 


cmn

New Member
#2
Hi

I am running Windows 7 and everything seems fine appart from the D drive showing a missing icon. The C drive is fine as are the DVD/DVDRW drives its only the D drive.

How do you go about replacing this? I had the same problem on Vista and when I installed 7 I thought that would be fixed but it isn't. Any help would be appreciated.

Thanks
Without knowing details of your Computer's hardware specification, anything anyone is trying to answer will be purely on guesswork. Since you have hinted about your Optical drives- "DVD/DVDRW drives ", I presume you are referring to your Hard disk drive when you said about Missing D drive icon. If you have only one HDD then your mention of "D-drive" must be your second partition on the single HDD ( HDD-0 or HDD-1 depending upon the MoBo BIOS designation).

One way to get a little more details about your Computer's Hard disk drives is to use the Computer Management Snap-in tool.

  1. Right-click Computer
  2. Click on Manage from the drop-down contextmenu
  3. In the Left Pane of Computer management window that opens, scroll down to Storage and click it to expand it and then click on Disk Management
  4. Now look at the Right pane and locate at the bottom of the divided pane the Disks and at the top box, the Volumes or the partitions with their drive letters. like C, D E F or whatever
  5. The bottom box shows your Disk numbers like 0 , 1 etc and your Optical drives like D or E or whatever alphabets the system has designated them to have and USB Flash drives or Hard drives if you have connected them to your machine.
Normally, if you have partitioned the HDD and designated a drive letter for each partition, you should see them when you click open Computer. If it is unallocated there won't be a drive letter and you won't see that in the Explorer view .
My assumption is that when you installed Win 7 either you used the whole disk as a single partition (or drive) or carved out a C: drive leaving the rest as Unallocated yet to be partitioned and formatted
I hope the above steps will help you solve the mystery of the missing D drive
 


unawave

New Member
#3
Perhaps could also be a switch in "Folder and search options" of Windows Explorer:
"Hide empty drives in the Computer folder" - if drive is empty.
 


#4
Sorry for not giving sufficient information. I have 2 500 GB samsung drives set as stripe0 raid. They are partitioned as C: and D: drives. I have a Maxtor 650 gb External Drive which shows as G: I have a DVD Rom Drive and a DVD Writer which show as E: and F: drives. All drives show ok (although the Maxtor external dtops showing if I reboot the PC and I need to unplug it then plug it back on for it to show again) with icons showing except for the D: which shows as in the attached image.
 


#5
Can anyone suggest a way to fix this?
 


#6
The question was answered with the assign drive letter post. I had the same issue with my 900G partition (raid 0). I could not access it in Explorer until I assigned it a drive letter. I have 1 50G (D) with XP x64, and one 50G (C) with W7 x64 7077. These are all drives from my 2 disk WD5000aaks array.
 


#7
Without knowing details of your Computer's hardware specification, anything anyone is trying to answer will be purely on guesswork. Since you have hinted about your Optical drives- "DVD/DVDRW drives ", I presume you are referring to your Hard disk drive when you said about Missing D drive icon. If you have only one HDD then your mention of "D-drive" must be your second partition on the single HDD ( HDD-0 or HDD-1 depending upon the MoBo BIOS designation).

One way to get a little more details about your Computer's Hard disk drives is to use the Computer Management Snap-in tool.

  1. Right-click Computer
  2. Click on Manage from the drop-down contextmenu
  3. In the Left Pane of Computer management window that opens, scroll down to Storage and click it to expand it and then click on Disk Management
  4. Now look at the Right pane and locate at the bottom of the divided pane the Disks and at the top box, the Volumes or the partitions with their drive letters. like C, D E F or whatever
  5. The bottom box shows your Disk numbers like 0 , 1 etc and your Optical drives like D or E or whatever alphabets the system has designated them to have and USB Flash drives or Hard drives if you have connected them to your machine.
Normally, if you have partitioned the HDD and designated a drive letter for each partition, you should see them when you click open Computer. If it is unallocated there won't be a drive letter and you won't see that in the Explorer view .
My assumption is that when you installed Win 7 either you used the whole disk as a single partition (or drive) or carved out a C: drive leaving the rest as Unallocated yet to be partitioned and formatted
I hope the above steps will help you solve the mystery of the missing D drive
The question was answered with the assign drive letter post. I had the same issue with my 900G partition (raid 0). I could not access it in Explorer until I assigned it a drive letter. I have 1 50G (D) with XP x64, and one 50G (C) with W7 x64 7077. These are all drives from my 2 disk WD5000aaks array.




Reading comprehension ahoy, wow. This guy has an ICON PROBLEM. He said everything is fine EXCEPT THE ICON.
 


#8
Now for an actual solution (well, three possibilities):

1. delete the autorun file in the drive root if there is one
2. delete desktop.ini in the drive root if there is one
3. follow Change Drive Name and Icon at Registry Guide for Windows and the icon you probably want is D:\Windows\System32\imageres.dll,27
 


#9
ayrshiredude:

Is the drive, and content usable, but has an ICON issue?
 


#10
Now for an actual solution (well, three possibilities):

1. delete the autorun file in the drive root if there is one
2. delete desktop.ini in the drive root if there is one
3. follow Change Drive Name and Icon at Registry Guide for Windows and the icon you probably want is D:\Windows\System32\imageres.dll,27
I have searched EVERYWHERE for a solution to this problem. It wasn't a problem with the partition or anything. Simply a broken icon. I had tried everything from editing registry files to changing settings in safe mode.

Deleting the autorun file worked for me on the first try. THANK YOU SO MUCH! This was annoying me to no end.

Thank you. Thank you. Thank you.
 


#11
Thank you !!!

Now for an actual solution (well, three possibilities):

1. delete the autorun file in the drive root if there is one
2. delete desktop.ini in the drive root if there is one
3. follow Change Drive Name and Icon at Registry Guide for Windows and the icon you probably want is D:\Windows\System32\imageres.dll,27
Deleting the 2 first files worked for me too. Thanks !!!
Sylvia :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top