Missing Right click sub menu

Discussion in 'Windows 7 Help and Support' started by pluto, Feb 10, 2010.

  1. pluto

    pluto New Member

    Joined:
    Jan 4, 2010
    Messages:
    14
    Likes Received:
    0
    Hi All
    I have W7 32bit and I have noticed that when I have been on the PC for some time and right click on the desktop it does not work, any ideas or suggestions on how to resolve this most welcome
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,810
    Likes Received:
    1,563
    Hi Pluto,
    could you post some details about your system? Like it's spec and also what type of installation you've got... Is an upgrade, clean install or came already installed?
    Thanks
     
  3. pluto

    pluto New Member

    Joined:
    Jan 4, 2010
    Messages:
    14
    Likes Received:
    0
    Right click missing

    Hi Yes it is a self build, 85oo ATI crossfire graphics card. Two ddr3 2 gig sticks. 3 - 320 gig hard drives, gigagbyte motherboard 775 socket, creative lab sound card, 650 watt PSU tow optical drives. Windows 7 32bit.
     
  4. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Sounds like something has disabled the right click from the group policy editor.
    Go to Run, or the Start search box and type gpedit.msc, then User Configuration - Administrative Templates - Windows Components - Windows Explorer. In the right hand pane, scroll down to "remove Windows Explorer ’s default context menu”, open its properties by double clicking it. It may be enabled or not configured, disable it and you should find the right click facility will be back.

    If you are using one of the "Home" versions of Windows 7, you will not have access to Gpedit.msc. The you may have to edit the registry.
    Again, type regedit in the Run or the Start search box. Go down to HKEY_CURRENT_USER - Software - Microsoft - Windows - CurrentVersion - Policies - Explorer. In the right hand pane find “NoViewContextMenu”, set its value to 0 (if it exists).

    If you still unable to right click the desktop, then find the same key here (again - if it exists): HKEY_LOCAL_MACHINE - Software - Microsoft - Windows - CurrentVersion - Policies - Explorer

    The change, if you have not accidentally caused it yourself, is most often caused by a virus or trojan. I would suggest you do a full scan of the computer.
     
    #4 RAK, Feb 10, 2010
    Last edited: Feb 10, 2010

Share This Page

Loading...