Need help connectin to the internet...

#1
Hello there everyone :) First off, my name is Gab and I just joined these forums ^^ I just got a quick question on how to get connected to the web using windows 7 which I just installed. Naturally, my motherboard wifi drivers didn't work to install as they aren't ment for w7 so I found someone with similiar problems on these forums. The solution to his problems was to set the installer in compatability mode for vista so I tried doing the same and it worked! Unfortunately however I still can't connect to any wireless network :/ Upon reboot it said something like drivers failed to install.

Incase it matters, I'm using a self-built stationary computer with a wireless card in it and my only possibility is to connect with it wirelessly. I'd be ever so greatfull if somebody could shed some light on my issue and help me get my internet going again :/

Edit: Oh, how foolish of me I forgot to tell you guys what mb I'm using. It's an asus m2n-32 SLI deluxe incase there might be some general incompatibility with that brand or model. Thanks :p
Thanks beforehand, Gabe.
 


Last edited:

iroken22

Extraordinary Member
Premium Supporter
#2
Hello there everyone :) First off, my name is Gab and I just joined these forums ^^ I just got a quick question on how to get connected to the web using windows 7 which I just installed. Naturally, my motherboard wifi drivers didn't work to install as they aren't ment for w7 so I found someone with similiar problems on these forums. The solution to his problems was to set the installer in compatability mode for vista so I tried doing the same and it worked! Unfortunately however I still can't connect to any wireless network :/ Upon reboot it said something like drivers failed to install.

Incase it matters, I'm using a self-built stationary computer with a wireless card in it and my only possibility is to connect with it wirelessly. I'd be ever so greatfull if somebody could shed some light on my issue and help me get my internet going again :/

Edit: Oh, how foolish of me I forgot to tell you guys what mb I'm using. It's an asus m2n-32 SLI deluxe incase there might be some general incompatibility with that brand or model. Thanks :p
Thanks beforehand, Gabe.
sounds like a driver issue and that you will just have to wait until a compatible driver comes out for windows 7.
 


#3
sounds like a driver issue and that you will just have to wait until a compatible driver comes out for windows 7.
Ah :/ I really don't want to revert to xp lol. I'm in love with this version :O Where can you find w7 drivers? Is there some kind of site that has them all in a db or do I just have to resort to wait for my manufacturer to post them? (which won't happen until w7 gets out of beta - a long time :().
 


#4
Ah :/ I really don't want to revert to xp lol. I'm in love with this version :O Where can you find w7 drivers? Is there some kind of site that has them all in a db or do I just have to resort to wait for my manufacturer to post them? (which won't happen until w7 gets out of beta - a long time :().
There is no database of Windows 7 drivers yet, It's still in BETA stages remember... therefore it will be a while before manufacturers release Windows 7 specific drivers... in the meantime, like Iroken22 said you'll have to fiddle around with the compatibility tab and see if that works.. if not then you could also try downloading the latest Windows Vista driver for your wireless card (or any other hardware your having problems with for that matter) and see if that works.. Windows 7 is built off the Windows Vista kernel (it is of course modified a bit) and as a result of this all Vista drivers are "supposed" to work with 7. So give that a try too.. If your having trouble locating a driver for your card try searching in google and I'm sure you'll find something.. ;) (If you can get to another compy that has internet abilities that is.. :)

Also, just to comment on that board.. I'm using the Asus M2N-E on my main compy and I had no problems with any drivers in Windows 7.. I mention this because my board is in the same family as yours.. I don't have a wireless card but I have all other drivers for it, if you need any other drivers for your board just pm me and I'll see if I can help ya out. they may not work but it's worth a try.. ;)
 


iroken22

Extraordinary Member
Premium Supporter
#5
There is no database of Windows 7 drivers yet, It's still in BETA stages remember... therefore it will be a while before manufacturers release Windows 7 specific drivers... in the meantime, like Iroken22 said you'll have to fiddle around with the compatibility tab and see if that works.. if not then you could also try downloading the latest Windows Vista driver for your wireless card (or any other hardware your having problems with for that matter) and see if that works.. Windows 7 is built off the Windows Vista kernel (it is of course modified a bit) and as a result of this all Vista drivers are "supposed" to work with 7. So give that a try too.. If your having trouble locating a driver for your card try searching in google and I'm sure you'll find something.. ;) (If you can get to another compy that has internet abilities that is.. :)

Also, just to comment on that board.. I'm using the Asus M2N-E on my main compy and I had no problems with any drivers in Windows 7.. I mention this because my board is in the same family as yours.. I don't have a wireless card but I have all other drivers for it, if you need any other drivers for your board just pm me and I'll see if I can help ya out. they may not work but it's worth a try.. ;)
Indeed there is no database of windows 7 drivers and radenight is correct that the drivers should work but for some reason windows 7 is rejecting them. I am guessing that whoever wrote the driver didnt follow microsoft guidelines but was able to get away with it in windows VISTA but now it is rejected in windows 7
 


#6
There is no database of Windows 7 drivers yet, It's still in BETA stages remember... therefore it will be a while before manufacturers release Windows 7 specific drivers... in the meantime, like Iroken22 said you'll have to fiddle around with the compatibility tab and see if that works.. if not then you could also try downloading the latest Windows Vista driver for your wireless card (or any other hardware your having problems with for that matter) and see if that works.. Windows 7 is built off the Windows Vista kernel (it is of course modified a bit) and as a result of this all Vista drivers are "supposed" to work with 7. So give that a try too.. If your having trouble locating a driver for your card try searching in google and I'm sure you'll find something.. ;) (If you can get to another compy that has internet abilities that is.. :)

Also, just to comment on that board.. I'm using the Asus M2N-E on my main compy and I had no problems with any drivers in Windows 7.. I mention this because my board is in the same family as yours.. I don't have a wireless card but I have all other drivers for it, if you need any other drivers for your board just pm me and I'll see if I can help ya out. they may not work but it's worth a try..
Thanks alot for that reply :) The thing is all the other drivers work for it except for my wireless :/ It doesn't seem to be a problem with my internet as it works if I plug in a lan cable. The catch is, I dont have a internet outlet in my room so if I want to be connected I have to go via wireless :/ aws. I've got all the newest drivers ready that worked a day ago on my xp :p
 


Joewho

Senior Member
#7
Check the device mgr., see if a yellow ! is next to the wireless card. If so, you'll have to download the latest drivers and install them. I'm using a dell and had to install drivers for sound and wireless seperately after the w7 setup.

Not sure if your'e saying you already did that with xp drivers or not. In any case, go to the site that supports the wireless card and get the latest drivers (vista if available).
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top