Need help with BSOD / ntoskrnl.exe+ 1c14e0

Brepsel

New Member
Hey all,

I've been having a lot of issues with a variety of BSOD's, but the one thing that they all have in common is the adress: ntoskrnl.exe+ 1c14e0. From the last couple of days its been:
KMODE_EXCEPTION_NOT_HANDLED
PAGE_FAULT_IN_NONPAGED_AREA
SYSTEM_SERVICE_EXCEPTION

Before that it has been a variety of other BSOD's, but unfortunately I don't have the minidumps of these BSOD's anymore.

The crashes seem to come at random. Except I can sometimes recreate it when I play Fifa. The latest BSOD happened whilst I was watching some Twitch. On the other hand, when I play alot of other games, I don't seem to get a BSOD. Can you guys help me? Because I'm at a loss here.

I've tried a variety of solutions: from the driver updates to diskcheck, scannow, memtest86, you name it.

I've attached the zipped W7F folder to the post.

Thanks in advance,
Brepsel
 

Attachments

  • W7F_26-01-2020.zip
    788.6 KB · Views: 69

Brepsel

New Member
My setup btw:
HyperX Predator HX432C16PB3K2 32 GB DDR4 3200 MHz
Intel Core i9 9900KS processor
MSI GeForce RTX 2080 SUPER Sea Hawk X
MSI MPG Z390 GAMING PRO CARBON
NZXT Kraken X62
Samsung 860 EVO 500GB SSD
Seagate ST2000DX001, 2TB SSHD
Sharkoon SilentStorm Cool Zero 750W PSU
 

kemical

Windows Forum Admin
Staff member
Premium Supporter
Code:
Microsoft (R) Windows Debugger Version 10.0.19528.1000 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\Ross Cameron\Downloads\W7F_26-01-2020\012520-6875-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available


************* Path validation summary **************
Response                         Time (ms)     Location
Deferred                                       srv*
Symbol search path is: srv*
Executable search path is:
Windows 10 Kernel Version 18362 MP (16 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Machine Name:
Kernel base = 0xfffff805`7dc00000 PsLoadedModuleList = 0xfffff805`7e048150
Debug session time: Sat Jan 25 22:04:26.840 2020 (UTC + 0:00)
System Uptime: 0 days 0:20:40.561
Loading Kernel Symbols
...............................................................
................................................................
.....................................................
Loading User Symbols
Loading unloaded module list
.......
For analysis of this file, run !analyze -v
nt!KeBugCheckEx:
fffff805`7ddc14e0 48894c2408      mov     qword ptr [rsp+8],rcx ss:0018:ffffe005`9910eea0=000000000000001e
3: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

KMODE_EXCEPTION_NOT_HANDLED (1e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Arguments:
Arg1: ffffffffc000001d, The exception code that was not handled
Arg2: fffff8057ddc8ebe, The address that the exception occurred at
Arg3: ffff84052196b080, Parameter 0 of the exception
Arg4: ffffe0059910eb20, Parameter 1 of the exception

Debugging Details:
------------------


KEY_VALUES_STRING: 1

    Key  : Analysis.CPU.Sec
    Value: 2

    Key  : Analysis.DebugAnalysisProvider.CPP
    Value: Create: 8007007e on DESKTOP-R3SQ3S0

    Key  : Analysis.DebugData
    Value: CreateObject

    Key  : Analysis.DebugModel
    Value: CreateObject

    Key  : Analysis.Elapsed.Sec
    Value: 5

    Key  : Analysis.Memory.CommitPeak.Mb
    Value: 69

    Key  : Analysis.System
    Value: CreateObject


ADDITIONAL_XML: 1

DUMP_FILE_ATTRIBUTES: 0x8
  Kernel Generated Triage Dump

BUGCHECK_CODE:  1e

BUGCHECK_P1: ffffffffc000001d

BUGCHECK_P2: fffff8057ddc8ebe

BUGCHECK_P3: ffff84052196b080

BUGCHECK_P4: ffffe0059910eb20

EXCEPTION_PARAMETER1:  ffff84052196b080

EXCEPTION_PARAMETER2:  ffffe0059910eb20

CUSTOMER_CRASH_COUNT:  1

PROCESS_NAME:  LEDKeeper.exe

FAILED_INSTRUCTION_ADDRESS:
nt!KiStartUserThread+4e
fffff805`7ddc8ebe 440f285980      movaps  xmm11,xmmword ptr [rcx-80h]

STACK_TEXT:
ffffe005`9910ee98 fffff805`7de2fda7 : 00000000`0000001e ffffffff`c000001d fffff805`7ddc8ebe ffff8405`2196b080 : nt!KeBugCheckEx
ffffe005`9910eea0 fffff805`7ddd341d : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiDispatchException+0x1689d7
ffffe005`9910f550 fffff805`7ddcd9ab : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiExceptionDispatch+0x11d
ffffe005`9910f730 fffff805`7ddc8ebe : ffffd000`c91d6180 ffff8405`2196b080 ffffd000`c91e7440 00000000`00000000 : nt!KiInvalidOpcodeFault+0x32b
ffffe005`9910f8c0 fffff805`7ddc8e00 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiStartUserThread+0x4e
ffffe005`9910fa00 00007ffd`aebf17f0 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiStartUserThreadReturn
00000000`00e5f5e8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x00007ffd`aebf17f0


SYMBOL_NAME:  nt!KiStartUserThread+4e

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

IMAGE_VERSION:  10.0.18362.592

STACK_COMMAND:  .thread ; .cxr ; kb

BUCKET_ID_FUNC_OFFSET:  4e

FAILURE_BUCKET_ID:  0x1E_c000001d_BAD_IP_nt!KiStartUserThread

OSPLATFORM_TYPE:  x64

OSNAME:  Windows 10

FAILURE_ID_HASH:  {1c874fab-38ab-b8d4-3f72-89e0bab0a6d0}

Followup:     MachineOwner

Hi,
the last dump file I checked mentioned LEDKeeper.exe. This apparently belongs to an app called 'Mystic Light' from MSI and is known to cause issues.
Try removing it and see if the issues stop.
 

Brepsel

New Member
Hi kemical,
Thanks for checking out my issues. I had indeed noticed that LEDKeeper.exe was mentioned in the last dump file as well and have removed it to be sure. I'll let it know if I run into new BSOD's or if it fixed the problem. :)
 

kemical

Windows Forum Admin
Staff member
Premium Supporter
I created a RGB system myself but i didn't realise how awful some of the software is. Anyhoo I hope this works out, nothing worse than having an itch you can't scratch lol.. :)
 

Brepsel

New Member
Well unfortunately that wasn't it. It crashed again whilst playing fifa. I can play a game like Rocket League fine for hours and no crashes at all. But when I play Fifa, it gives me a BSOD pretty quickly. This time I got:
DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)

I checked the minidump but I couldn't get any information that I could do anything with. If anyone can have a look, that would be great!

Attached the new W7F folder, with the latest BSOD
 

Attachments

  • W7F_30-01-2020.zip
    883.9 KB · Views: 44

kemical

Windows Forum Admin
Staff member
Premium Supporter
Hi,
I saw dump files for LEDKeeper and HyperX Nguity software. If the LEDkeeper didn't change anything when removed try uninstalling the HyperX stuff.
If this still fails to sort the issue you could try running driver verifier.

Before you do make sure you have a recovery usb at hand as the verifier can cause a boot loop. If this occurs you boot into safe mode using the recovery usb and turn the verifier off.
This guide helps some:
Driver Verifier - BSOD related - Windows 10, 8.1, 8, 7 + Vista
 

Brepsel

New Member
So I ran Driver Verifier, after I got another crash saturday evening after no crashes for the entire day (after having played a variety of games, it crashed later in the evening whilst playing 'Gang Beasts'). Whilst running Driver Verifier I had put Fifa on so I could easily force a BSOD. But that wasn't the case. I had put it on for a large portion of the day, but I couldn't get a BSOD. Yesterday evening I decided to turn Driver Verifier off again and try to put Fifa on. And what do you know, SYSTEM_SERVICE_EXCEPTION within minutes.

Turned Driver verifier back on following the guide @kemical posted and let it run overnight with nothing else running. Woke up this morning and couldn't get my screen to show me an image so I had to restart. I checked to see if I had a minidump and I did have one from this morning when I restarted: WHEA_UNCONTROLLABLE_ERROR.

So i'll let driver verifier run a bit longer but I've got doubts if it'll find a driver.
(Added the latest two minidumps to the zip file, if anyone can have a look to see if they can find anything, that would be awesome :))
 

Attachments

  • W7F_03-02-2020.zip
    1 MB · Views: 47

kemical

Windows Forum Admin
Staff member
Premium Supporter
I had a look through but nothing driver wise was showing. Bugcheck 124 can be caused by a large number of things ranging from overheating, hardware issues and buggy software. I've even known Chrome to cause this issue (found by accident).
Your best bet is to ensure all your drivers and bios are the latest versions. Go to your motherboard support page and update if need be:
Support For MPG Z390 GAMING PRO CARBON | Motherboard - The world leader in motherboard design | MSI Global

Also view any third party software with suspicion, if you don't use it anymore then remove it. Anything you do use ensure it's the latest version.

Try running the Intel diagnostic Tool: Download Intel® Processor Diagnostic Tool

How long did you run Memtest86 for?
 

Brepsel

New Member
I already ensured my drivers and bios were the latest versions.
Since I didn't know anymore I went to a computer repair store with my system. They installed a different psu (1000w vs the 750w I had before) telling me that the the power supply was sufficient enough. They also checked the rest of the hardware with BurnInTest and it came out without any errors.

So once I got the system back friday I was in high spirits, hoping and thinking the problem was fixed. However it was not... Upon testing it once again with Fifa I got a BSOD again. And testing again this morning, another one:
SYSTEM_SERVICE_EXCEPTION
IRQL_NOT_LESS_OR_EQUAL

Memtest86 I did twice for about 4 hours I think. No errors both times.

Did the Intel diagnostic Tool as well, no errors there.

So I'm at a loss. It doesn't seem hardware related, but I also can't find any driver that could be causing it. I find it so odd that the system won't crash when I have driver verifier on. How come I get a BSOD with Fifa without driver verifier within minutes. But when I turn on driver verifier it won't happen?

Kind regards,
Brepsel
 

kemical

Windows Forum Admin
Staff member
Premium Supporter
Hi,
sorry to hear your issue continues.

Chasing down a bsod cause can sometimes be a pain and i understand your frustration.

Is your Windows install from an iso or usb? Also when was the last time you installed windows?

Can you post the dump files as the more we see the better.
 
Top