No microphone boost in Windows 7

Xaith

New Member
#1
Hello people!

First of all:
I'm having a Creative Soundmaster Audigy 4 SE 7.1 soundcard and the (according to the Windows update manager) latest driver availabe.

I recently installed Windows 7 because I always wanted to know how it was.
Everything went fine, the Update Manager automatically installed all the drivers I needed, but now there's a problem with my audio settings.
Since I've been switching over to Windows 7 people have told me that I'm very very quiet in Teamspeak or Skype, so I tried to activate the microphone boost in the audio settings.

But when I open the settings of my microphone and click the "custom" tab, all I see is "Do not monitor".
There's no microphone boost. I heard from some people they had the same problem under Windows Vista and solved it by switching to newer drivers, but alas, it seems I have the newest beta driver for Windows 7.
Is there any other way towards activating the boost or do I just have to wait until Creative releases a Windows 7 beta driver with microphone boost included?

I also checked if the problem comes from my headset, but it's working fine under Windows XP with microphone boost enabled. The voice recognition experience didn't help, too. The voice activation bar barely showed any activity, only when I'm almost screaming.

Any help is much appreciated and I thank you in advance!
 


stueycaster

Millennium Celebration Award Winner
Premium Supporter
#2
I have a crummy little mic plus the one in my webcam on my computer. Like yours the one in my Logitech webcam has no microphone boost. However my computer mic does.

When I installed the webcam, trying to get the Logitech software to install was a total nightmare. Through the help of someone on this forum I found out how to install the drivers without the rest of the software. Maybe if I could have got the software to work I might have mic boost on it.

I don't know if this helps but I thought it was worth mentioning. Maybe someone at Creative could help you but I doubt it since W7 is still not released to the public. I know Logitech wouldn't even try to help me.

Sorry I can't be more help.
 


#3
Hello stueycaster!
Thanks for your reply, but I managed to solve my problem already :)
I continued google-ing (stange verb) for similar problems and I eventually found a workaround for my problem.

I "just" had to browse my registry to the point where my creative soundcard entry was and manually set the value of mic boost from 0 to 1.
After a reboot of the computer it worked just fine, everyone is able to understand me once more in Teamspeak, Skype and the likes.

Nonetheless, thanks again for your efforts, stueycaster :)
 


#4
Hello stueycaster!
Thanks for your reply, but I managed to solve my problem already :)
I continued google-ing (stange verb) for similar problems and I eventually found a workaround for my problem.

I "just" had to browse my registry to the point where my creative soundcard entry was and manually set the value of mic boost from 0 to 1.
After a reboot of the computer it worked just fine, everyone is able to understand me once more in Teamspeak, Skype and the likes.

Nonetheless, thanks again for your efforts, stueycaster :)
Which registry did you modify the value to 1?

Can you tell me please?
 


#5
Which registry did you modify the value to 1?

Can you tell me please?
I'll make a step-by-step for you:

Easy path:
Open regedit.exe
Goto Edit -> Search. Enter "MicBoost" and let it search.
Doubleclick the registry and change its value to 1.
Close regedit.exe, reboot PC, done.

Hard path:
Open regedit.exe
Then go to the following registry folder:
Computer -> HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> Class
Now there are a dozen of registry folders with long number names, I'm not sure wheter or not yours have the same names as mine.
For me the correct folder was:
{4D36E96C-E325-11CE-BFC1-08002BE10318} -> 0007 -> Settings
In the settings registry search for MicBoost REG_DWORD 0x00000000. Double click it and set its value to 1.
Leave the registry and reboot your PC and you should be all set.

If the above long-number-name is not in your registry you have to search for yourself, I'm afraid.
 


#6
I'll make a step-by-step for you:

Easy path:
Open regedit.exe
Goto Edit -> Search. Enter "MicBoost" and let it search.
Doubleclick the registry and change its value to 1.
Close regedit.exe, reboot PC, done.

Hard path:
Open regedit.exe
Then go to the following registry folder:
Computer -> HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> Class
Now there are a dozen of registry folders with long number names, I'm not sure wheter or not yours have the same names as mine.
For me the correct folder was:
{4D36E96C-E325-11CE-BFC1-08002BE10318} -> 0007 -> Settings
In the settings registry search for MicBoost REG_DWORD 0x00000000. Double click it and set its value to 1.
Leave the registry and reboot your PC and you should be all set.

If the above long-number-name is not in your registry you have to search for yourself, I'm afraid.
There isn't a file that contain the word micboost... The folder {4D36E96C-E325-11CE-BFC1-08002BE10318} -> 0007 -> Settings does not contain MicBoost REG_DWORD 0x00000000 either...
 


#7
There isn't a file that contain the word micboost... The folder {4D36E96C-E325-11CE-BFC1-08002BE10318} -> 0007 -> Settings does not contain MicBoost REG_DWORD 0x00000000 either...
Mh, that's odd.
Which sound card do you own?
 


#8
Mh, that's odd.
Which sound card do you own?
I have a Pentium 4 and a Intel motherboard. So it is integrated audio.
 


#9
I have a Pentium 4 and a Intel motherboard. So it is integrated audio.
Ah well, I'm using a Creative soundcard, I don't know anything about onboard sound chips, sorry :/
 


#10
I'll make a step-by-step for you:

Easy path:
Open regedit.exe
Goto Edit -> Search. Enter "MicBoost" and let it search.
Doubleclick the registry and change its value to 1.
Close regedit.exe, reboot PC, done.

Hard path:
Open regedit.exe
Then go to the following registry folder:
Computer -> HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> Class
Now there are a dozen of registry folders with long number names, I'm not sure wheter or not yours have the same names as mine.
For me the correct folder was:
{4D36E96C-E325-11CE-BFC1-08002BE10318} -> 0007 -> Settings
In the settings registry search for MicBoost REG_DWORD 0x00000000. Double click it and set its value to 1.
Leave the registry and reboot your PC and you should be all set.

If the above long-number-name is not in your registry you have to search for yourself, I'm afraid.
i followed your steps to change my micboost to 0x00000001 but after rebooted the PC i still dont see mic boost option just the "do not monitor" , i checked the regitry and it showed value is 1 (0x00000001) , any idea ?
btw i'm using creative SB audigy SE and window 7
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.