Odd Port Issue

Discussion in 'Windows 7 Help and Support' started by UFO64, Nov 2, 2009.

  1. UFO64

    UFO64 New Member

    Joined:
    Nov 2, 2009
    Messages:
    2
    Likes Received:
    0
    I am currently running the Windows 7 RC, updated fully from Microsoft. Several times I have attempted to function as a server/host for various applications that have resulted in hit/miss results.

    Most of the time we diagnose this down to a port issue. My first response was usually to disable the windows firewall when on a LAN. This didn't apear to open up any ports, and many still refused connections. Attempting to telnet/detect port responses from various programs always fails.

    Digging deeper into my rather skim knowledge of windows networking led me to the netstat command in command prompt. After turning the windows firewall back on, and specifically adding an incoming rule for the given port (lets say 7777 for the time being), the port never shows up on netstat. Restarting the connection/firewall/computer, as well as releasing and renewing connections, going to a static IP, all fail.

    I had added numerous ports with the Control Panel -> Windows Firewall -> Advanced Settings -> New Rule, and none seem to work. I have tried opening up ALL incoming/outgoing ports (TCP & UDP) with the firewall on/off. I still cannot find anyway to get a response from those ports with a local testing method (telnet/netstat) or a remote method (Port checking sites from beyond my router, or a local Macbook).

    I am at a complete loss as to why windows 7 seems to refuse to open a given port with this control panel. I get the feeling I am missing some blazingly obvious default setting someplace that ignores the overriding of rules to the firewall.

    I am not running any third party software to block ports, and tests have been done with router port forwarding turned on, its own SPI firewall turned off, and the computer in question set to be the default DMZ.

    Thanks in advance to anyone who has a clue what I am missing!
     

Share This Page

Loading...