"Page by E-Mail" and "Link by E-Mail" options are grayed out in Internet Explorer

Discussion in 'Windows 7 Help and Support' started by Cheena, Apr 21, 2009.

  1. Cheena

    Cheena New Member

    Apr 13, 2009
    Likes Received:
    Resolution This helped me.:p

    This happens if a default mail client is not correctly set. Using the Default Programs - Set your default programs, and selecting your mail client (for example, Windows Mail) also may not help.

    Follow these steps to resolve the problem.
    1. Click Start, select Default Programs
    2. Click Set program access and computer defaults
    3. Click Custom, and select your mail client (for example, Windows Mail)
    4. Click OK
    Note: If User Account Control is enabled, you'll be prompted for an administrator password or for confirmation after following the step 2 above. When the prompt appears, type your password, or click Continue.
  2. reghakr

    reghakr Excellent Member

    Jan 26, 2009
    Likes Received:
    That's because Windows7 stripped out their own Windows Mail program and are urging people to download their Live Essentials pack.

    I download and installed Mozilla Thunderbird open source, looks very familiar to Windows Mail.
    you can download it here:

    Thunderbird - Reclaim your inbox

Share This Page