Permissions problems with my network shares

Discussion in 'Windows 7 Networking' started by donbailey, Mar 22, 2010.

  1. donbailey

    donbailey New Member

    Joined:
    Oct 22, 2009
    Messages:
    48
    Likes Received:
    0
    I have two computers on my network. Both use Windows 7-64 and both have Homegroups enabled with all the file types enabled (video, printers, etc).
    My problem is that I get an error message when I try to connect to any subdirectory under the users name (on the other computer). I can see the file structure and can see the subdirectory, I just cannot open it up when I click on it (using Explorer under the "Network" heading. The error message is something like this: You do not have permission to access (network directory name and file name). By the way, I have enabled sharing with my C: drives on both machines and I can share files with other drives and subdirectories, just not the ones under C:\Users\(UserName) . Any ideas of what setting I am missing?
     
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    1. Make sure your machines are in the same workgroup and have libraries to share.

    Change HomeGroup settings

    2. Right-click on files/folders shared > Properties >
    Advanced Sharing > Check Share this folder box > Permissions > Add :

    [​IMG]
     
  3. donbailey

    donbailey New Member

    Joined:
    Oct 22, 2009
    Messages:
    48
    Likes Received:
    0
    I think I found the solution to my problem, since I have already done those things. I did the following on both computers and it works now:
    I opened Win Explorer and went to C:\Users\UserName.
    Then on the toolbar just above Win Explorer, I clicked on "Share With", then Specific People.
    Then I clicked on the dropdown and selected "Everyone", then clicked on ADD, and it added Everyone to the box below.
    Then next to Everyone, under Permission Level, I checked Read/Write.
    Then I clicked on "Share" at the bottom and closed everything else down.

    I hope this will help others with this same problem.
     

Share This Page

Loading...