Windows 7 Random frames per second (FPS) drops!

Discussion in 'Windows Games' started by andri, May 26, 2009.

  1. andri

    andri New Member

    Joined:
    May 26, 2009
    Messages:
    4
    Likes Received:
    0
    I installed Windows 7 Release Candidate edition and it's been going pretty smoothly so far, but one thing I notice, this happens quite randomly (that is, sometimes often, sometimes it just runs for hours/days perfectly) that the frame rate of the games just drops massively, nothing is running in the background or anything, just BAM!
    This happened with so far.. Counter Strike 1,6, Need for Speed Underground 2. These are both completely legal versions of the games so it's not the game, it's something with Windows 7. The graphic drivers I use? I don't even recall Windows 7 updating them for me but I'm sure Windows did cause I sure didn't install any (unless my memory is seriously ill) and the screen don't lag when I scroll down web sites etc like happens when I haven't installed drivers on XP or Vista.


    Some info I've gathered from dxdiag...

    Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7100)
    System Model G1S (Asus)
    Processor: Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz (2 CPUs),~2.2GHz
    Memory: 4096MB RAM
    DirectX Version: DirectX 11

    Display...
    Name: NVIDIA GeForce 8600M GT
    Approx Total Memory: 2033MB
    Driver..
    Main Driver: nvd3dumx.dll, nvwgf2umx.dll, nvwgf2 (I can't see more :S)
    Version: 8.15.11.8585
    Date: 30.4.2009 22:02:00
    WHQL Logo'd: Yes
    DDI Version: 10
    Driver Model: WDDM 1.1


    Now, you can't possibly ask for MORE information can you? I want this problem diagnosed and solved and I'm probably right when I say that many others want it too. IF this has been solved before but I just couldn't find it, I'm very sorry for spamming this forum with my wall 'o text!

    Btw, I had Windows Vista Ultimate 32 bit and 64 bit before installing Windows 7, never any similar problems, or any problems at all aside from the usual Vista crap :) So I'm just SO SURE that this problem lies with Windows 7, Now.. I'm NOT saying that it's supposed to be perfect, I mean it's pre release edition and I didn't pay anything for it so I'm not in a position to demand anything or wipe my ass in MS' faces I'm just (hopefully) politely enough asking if anyone has a solution to my problems. If there's anything more you need to know just tell me. ;)


    Thanks in advance,
    Andri
     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hello Andri,

    Welcome to the Windows7forums.

    Yes, I could ask for a lot more information;)

    But, first off,

    Did you perform a "clean" install rather than an upgrade?

    Newer drivers are available from Nvidias site here:
    GeForce Release 185

    Nvidia's official Windows 7 drivers will work better.
     
  3. andri

    andri New Member

    Joined:
    May 26, 2009
    Messages:
    4
    Likes Received:
    0
    EDIT** It does not work.
     
    #3 andri, May 27, 2009
    Last edited: May 28, 2009
  4. Elrom

    Elrom New Member

    Joined:
    Aug 19, 2009
    Messages:
    6
    Likes Received:
    0
    I think it's the drivers. I have similar problems with two games I've tried. I have a Geforce 8600 too. Even the score from Windows 7 in the graphics card performance is lower than it was for Vista.
    I'm getting a 4,9, and in Vista it was minimun 5,3. I don't exactly remember what was the final score in Vista, but my final score in Windows 7 has been set to 4,9 because of that.
     

Share This Page

Loading...