Remote Assistance stopped working on both ends.

Discussion in 'Windows 7 Networking' started by Osprey, Apr 27, 2011.

  1. Osprey

    Osprey New Member

    Joined:
    Apr 27, 2011
    Messages:
    10
    Likes Received:
    0
    Need a little help from an expert on Remote Assistance…

    I use windows remote assistance (RA) often to preclude the painfully grueling challenge of explaining computer stuff to elderly (and grossly inept) computer users. RA works great to show these users how to do something in a snap, but lately Easy Connect and standard email invites are NOT working. I know some will suggest “use TeamViewer or RealVNC (which I use)”; however, most of these people that I help don’t know how to install these apps or use them, so it’s a huge can of worms. That is why I really need someone to give me a straight answer on configuring W7 RA, or tell me definitively that RA is an unreliable feature.
    On my local network:
    OS: W7 Ultimate 64
    PC Firewall: Norton 360
    Router: Linksys E3000
    Modem: Arris
    Cable Service: Comcast
    Up until just recently, RA/Easy connect worked great. I could send and receive invitations via Easy Connect or Email.
    The problem started when the “novice” I was trying to help added a Linksys E3000 router to the remote network. Prior to adding the router, her computer was connected directly to the modem and RA/Easy Connect worked perfectly for months.
    On the remote network:
    OS: W7 Ultimate 64
    PC Firewall: Norton 360
    Router: Linksys E3000 (currently added)
    Modem: Ubee
    Cable Service: Charter
    Initially when we would remove the remote Linksys E3000 from the mix it would work again, but as soon as we reconnected it, back to failure. And after a lot of trouble shooting, now my RA/Easy Connect does not work either. I believe this is a MS Windows configuration (glitch) issue. Something needs to be reset in Windows is my guess. I am well aware of how to enable RA and remote connections, that is not what I am referring to.
    I did a lot of grueling testing for three days and read a lot of different posts.
    1. I disabled all FWs on each pc and each router (even though RA worked with both N360 and my local E3000), rebooted all PCs, modems, and routers; but still no go.
    2. I contacted Charter and Comcast, they assured me that they are not blocking ports or throttling bandwidth. Neither modem has any configuration / firewall features to change.
    3. I rebooted and tested both routers with MS Internet Connectivity Eval Tool; both routers pass and are UPNP compatible.
    4. I matched the settings in the remote E3000 to my local E3000, and even assigned the remote pc a STATIC internal IP (previously it worked with a DHCP internal IP); still RA will not work via Easy Connect or email invitation. Linksys assured me that the E3000 is not blocking the port but I forwarded 3389 to the static IP anyway, still no go.
    5. I matched the LAN private and public (advanced sharing) settings on both PCs which did not do anything.
    I keep getting “Cannot Connect to the global peer-to-peer network”, is that a server on the internet cloud or something? I have checked all the required services that others have mentioned and they seem to be running…. I even tried to delete a file that was suggested in another post; however I could not delete the file…
    It seems that Windows7 must have a bug or I need to make a change/refresh something… because the routers, N360, modems, and ISP service don’t seem to be the problem. I am able to RDC with port fwd 3389 to the remote pc... But RA just won’t work on either system now.
    DOES anyone truly know what is going on with RA? Is there a way to reinstall RA?
     
  2. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    I will tell you that I do not and have never considered Remote Assistance to be reliable. Remote Desktop in Windows has come a long way, but as you have already mentioned software solutions such as TeamViewer, RealVNC, and even CrossLoop will always have an edge. This is primarily because, as you likely know, these businesses dedicate all of their resources to providing remote access solutions.

    This has me a bit clueless, but my initial instinct was that you've created a private network that uses NAT and now you're dealing with firewall issues. At the end of the day I would imagine its going to come down to some kind of bizarre routing issue. Network address translation is likely messing something up. Personally, I do not use Remote Assistance but am certainly aware of the feature.

    If you want someone to tell you that this feature is somewhat unreliable, I am more than willing to do so. And I am certified and well versed in the technology. In emergency situations we could use port forwarding for reliable Remote Desktop (not invitations) over a wide area network (i.e. the Internet), but its not a commercial solution unless you are using it on a local area network or over extremely high speed VPN (even then we get into a sticky grey area somewhat).

    I am literally mind boggled by this problem, as if RDC is working with port forwarding, the remote access invitations should not be problematic.

    However, this may help:

    How do I... Provide remote assistance on computers behind a NAT device? | TechRepublic

    Supported connection scenarios for Remote Assistance

    The invitations may be referencing a local private IP in the 192.168.* range since you've created a private network. I know it seems like you've looked at that issue, but something must be wrong with the invitations themselves.

    Make sure firewall exceptions for inbound and outbound traffic exist in Windows Firewall for Terminal Services and port 3389 (I'm sure you've done it). The above mentioned links may help, but I have a CCNA on Skype telling me you should just use TeamViewer...

    Send them the link to get the software click on run twice and they're pretty much gold for connectivity. I'm sorry to have had to tell you something you probably already know. I would begin to look at moving away using Remote Assistance unless you are on a LAN. For any outfit I have worked for we have used RDC over Internet as a fail-over because it simply will not give you the tools you need to support the end-user.

    Really, if anyone has a solution for this one, I would be surprised. In the meantime, start looking at alternatives, because everyone and anyone who has done remote support has run into trouble using RDC/RDP/Remote Assist at one time or another and an entire business sector in IT has been created so that you can avoid using it!
     
  3. Osprey

    Osprey New Member

    Joined:
    Apr 27, 2011
    Messages:
    10
    Likes Received:
    0
    Mike Thx, agreed with what you are saying, something is being blocked or not sent correctly.

    I copy LC on your closing comments, but I am a bit fixated in understanding the RA/Easy Connect/PNRP Cloud, etc...

    Has anyone ever found a detailed description/diagram of how RA and Easy Connect work and all the required ports, services, protocols, etc.?

    From what I read (if I understand correctly) W7 automatically participates in the PNRP Cloud, even if you disable RA and remote connections... that seems like a sure way to be attacked, perhaps that is what happened, is there a way to disable being part of the PNRP cloud?

    If anyone can explain the whole PNRP cloud and RA/Easy Connect (and dumb it down a bit) I would appreciate it.
     
  4. Osprey

    Osprey New Member

    Joined:
    Apr 27, 2011
    Messages:
    10
    Likes Received:
    0
    BTW, I have unsuccessfully tried to edit the invite files, they seem to be encrypted, and the example in the link you posted does not display... so if anyone also finds a tutorial on editing W7 encrypted invite files, much appreciated...
     
  5. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    This is one of those nightmare problems. I have stuck the thread so that someone with more knowledge of the inner workings of Remote Assistance can provide additional support and information. Finding a solution to this one would be very useful for future reference.
     
  6. nguyenvinh

    nguyenvinh New Member

    Joined:
    Mar 16, 2013
    Messages:
    4
    Likes Received:
    0
    Thank you for information sharing, it is very useful to me
     

Share This Page

Loading...