Security setting

me johnson

Extraordinary Member
#1
I have the following error in Event Viewer which I'm having trouble correcting:

Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 1/10/2010 5:58:44 AM
Event ID: 10016
Task Category: None
Level: Error
Keywords: Classic
User: SYSTEM
Computer: MEJ-PC
Description:
The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
{C97FCC79-E628-407D-AE68-A06AD6D8B4D1}
and APPID
{344ED43D-D086-4961-86A6-1106F4ACAD9B}
to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="49152">10016</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2010-01-10T11:58:44.000000000Z" />
<EventRecordID>62755</EventRecordID>
<Correlation />
<Execution ProcessID="0" ThreadID="0" />
<Channel>System</Channel>
<Computer>MEJ-PC</Computer>
<Security UserID="S-1-5-18" />
</System>
<EventData>
<Data Name="param1">application-specific</Data>
<Data Name="param2">Local</Data>
<Data Name="param3">Launch</Data>
<Data Name="param4">{C97FCC79-E628-407D-AE68-A06AD6D8B4D1}</Data>
<Data Name="param5">{344ED43D-D086-4961-86A6-1106F4ACAD9B}</Data>
<Data Name="param6">NT AUTHORITY</Data>
<Data Name="param7">SYSTEM</Data>
<Data Name="param8">S-1-5-18</Data>
<Data Name="param9">LocalHost (Using LRPC)</Data>
</EventData>
</Event>

I have tried changing the settings but keep getting the message. I don't know what to do...
 


#2
The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID.


This security permission can be modified using the Component Services administrative tool.

Open Component Services and find the application's security properties:

1.Click Start, and then click Run.
2.Type comexp.msc, and then click OK.
3.To locate your application, click Component Services, click Computers, click My Computer, and then click COM+ Applications.
4.Right-click the application name, and then click Properties.
5.In the application properties dialog box, click the Security tab, and then adjust the security settings to allow the requested operation to complete.

Your account must have administrative privileges.
 


me johnson

Extraordinary Member
#3
Com+

I have for Component Services > COM+ Explorer> Com+ QC Dead Letter> COM+ Utilities> System Applications

When viewing properties of each one the Security tab is grayed out except for the Authentication Level for Calls

I don't know how to change the security level when I can't get to it.

I do have Administrative rights.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top