VPN connection drops instantly after connection

dejhost

New Member
Hello!

I was asked to check an malfunctioning VPN-connection on a Lenovo laptop today. It uses the "Secure Socket Tunneling-Protokoll (SSTP)".

It seems the connection is established, and drops instantly again. I removed the network-adapter and setup the connection again.
I also turned off windows firewall and whitelisted the server-adress on the router. Same result.
In order to verify username and PW, I created the same connection on my own PC (different LAN). I successfully connected instantly.

The event log of the lenovo-laptop is full of the following error:
Überspringen: Eap method DLL path Fehler bei der Überprüfung. Fehler: Type-ID=18, Autor-ID=8086, Lieferant-ID=0, Lieferant-Typ=0
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
<Provider Name="Microsoft-Windows-EapHost" Guid="{6eb8db94-fe96-443f-a366-5fe0cee7fb1c}" />
<EventID>2002</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>2</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000001</Keywords>
<TimeCreated SystemTime="2021-10-04T12:59:19.3997296Z" />
<EventRecordID>30773</EventRecordID>
<Correlation />
<Execution ProcessID="6588" ThreadID="14916" />
<Channel>Application</Channel>
<Computer>Thinkpad</Computer>
<Security UserID="S-1-5-21-4187841508-1825797483-3342513265-1001" />
</System>
- <EventData>
<Data Name="Key Name">Eap method DLL path</Data>
<Data Name="TypeId">18</Data>
<Data Name="AuthorId">8086</Data>
<Data Name="VendorId">0</Data>
<Data Name="VendorType">0</Data>
</EventData>
</Event>

Could you please help me to troubleshoot this? Is the error above possibly connected to the VPN-issue?
 
Last edited:

Neemobeer

Principal Cybersecurity Architect
Staff member
Are you sure it's successful? I would run wireshark and capture the packet exchange to see what's going on.
 

dejhost

New Member
Are you sure it's successful? I would run wireshark and capture the packet exchange to see what's going on.
No, actually not really sure. 2 indications: 1) I am connected through a remote-desktop software to the lenovo notebokk. Everytime I try to get the VPN up and running on the lenovo, my remote-desktop-connection drops. 2) I can see briefly (for less than a second) the sign "connected".

I haven't used wireshark yet, but I'm more than happy to give it a try.

BTW: I tried WLAN and Ethernet - both with the same result.
Other suggestions are highly appreciated!
 
Last edited:

dejhost

New Member
The Problem diappeared - for unknown reasons. The connection was definitively working, but dropped. Something to do with windows not being able to chose the right network.
 

wahaha

New Member
Hello friend, if your issue still persists? For the future help, you can try to disable UDP in Local Group Policy and then connect again to see whether the issue has gone. Navaigation: Computer Configuration > Administration Templates > Windows Components > Remote Desktop Services > Remote Desktop Connection Client > Turn Off UDP On Client Good luck!
 
Top