Windows 10 Network Connection Drops on Cable

LessGonza

New Member
I have the following setup:
2 x windows 10 and 1 X windows 7 computers connected to the same router through cable having 192.168.0.1 as the router gateway.
  1. win7-box: 192.168.0.38
  2. win10-box1: 192.168.0.211
  3. win10-box2: 192.168.0.24
I am connecting from win7-box, which I'm using as the main machine, through RDP to the other 2 win10 machines.
The connection to 192.168.0.211 runs smoothly but when I connect to 192.168.0.24, the connection gets interrupted after 30-60 seconds and I get the "This computer can't connect to the remote computer" error:
enter image description here
While ping 192.168.0.24 -t from 192.168.0.38 was running I got this:
enter image description here
Even if after the The connection has been lost error that corresponds to the Request timed outping error - the connection seems to be restored (as ping is up again), if I try to RDP again I get the "Destination host unreachable" error.
enter image description here
Now I cannot RDP to 192.168.0.24 anymore until I manually log into this host by physically using its keyboard.
I also did a ping 192.168.0.1 -t on 192.168.0.24 and noticed the General Failure error that corresponds to the Request timed out from the win7-box
enter image description here
I also noticed that I get the General Failure error intermittently, even if don't try a RDP connection on this win10-box2 machine.
What I did:
  1. I tried a Network Reset from the Network&Internet settings:
enter image description here
  1. Tried switching the cable itself and the cable port on the router
  2. Tried using a different static ip, other than 192.168.0.24
  3. Tried using the wireless connection to the same router and noticed that even if do get some isolated Request timed out error when continuously pinging win10-box's ip, no issues are found and RDP connection is stable.
I assume this has to be something wrong in my current win10-box2 configuration as the router seems to be working fine on other devices.
The network configuration on win10-box2 is as follows:
enter image description here
The question would be - what else should I try/check in order to solve this issue?
 

Neemobeer

Windows Forum Team
Staff member
Have you replaced the cables? Generic Failures could be a sign of a bad cable or even NIC
 
Top