setting permissions in windows 7 home

Discussion in 'Windows 7 Networking' started by thegen99999, Oct 6, 2015.

  1. thegen99999

    Joined:
    Oct 6, 2015
    Messages:
    2
    Likes Received:
    0
    Hello all, First off I'd like to thank anyone who helps me with this in advance.

    I recently built a dedicated server system for my home to serve movie files, music, pics, things of that nature and we have a few kids in the household who like to click without thinking and delete things and I'm scared my stored files are going to be deleted accidently by one of the kids if I don't restrict their access. I am computer savvy and have knowledge of drive permissions to a point but I cannot get the server to allow unlimited access to me but restricted access to the kids. The server is running windows 7 Home Premium X64.


    Here's what I've tried to no avail.

    1. created local user accounts on the server for everyone in the family.

    2. shared the drives, I removed "everyone" from both the security tab and the sharing tab. added the specific users to both the security tab and the sharing tab and set the permissions according to whether I want read or read/write access. I also left SYSTEM and administrators intact in both tabs.

    3. went to the client computers and created accounts that mimmick both the user names and passwords of the accounts on the server.

    When I try to access the drives from the client computers I get "Windows cannot access \\server\X you don't have permission to access \\server\X If I go into the drive properties and Re add "Everyone" then it allows me in but with all read/write access. From what I've read this should work, what am I missing? Any help would be GREATLY appreciated!!

    Thanks.
     
  2. thegen99999

    Joined:
    Oct 6, 2015
    Messages:
    2
    Likes Received:
    0
    Sooo 140 views and not 1 reply? Is there nobody out there that has the knowledge to help?
     
  3. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,535
    Likes Received:
    315
    • You are using an old type file share so therefore you need to put "everyone" in and give them (at least) "read" permission.
    There are lots of forum posts around saying remove "everyone" but they are talking about real servers... which you don't have mate.

    The type of Windows share you are using will make a copy of the file that people view and is a VERY slow network solution because of this; i.e.
    • The good news is that the kids cann't delete files because you didn't give "everyone", "write" permission... only "read".
    • The bad news is this type of share puts heavy loads on your network and will frag the shit out of your storage hdd... I recommend;
    1. moving to a real Windows 12r2 server, a professional system designed to handle more than ten networked computers at the same time...* if you have under 10 systems its better to pick one of the other options.
    2. or a cheap NAS box, a seagate central starts under $200 for a 2t drive that is a "self contained" network storage system... these are designed to be used by people with little to no network knowledge and are normaly the simplest fix. * Western digital also make a NAS aimed more at Linux users but its worth your time to shop around before picking a NAS that suits your needs.
    3. or using a homegroup... the cheapest option (if you don't need help setting it up) because its built in to Windows 7 & above... it assumes all systems on the network are the same type i.e. all Windows 7 or all Windows 8.1 and can be tricky to set up correctly if you have different machines like eg, 3 Windows7 and 2 Windows 8 with 1 Windows ten machine but it can still handle a mix after you have a dip in networking or get a professional to help you set it up.
     
  4. chaucaphu

    chaucaphu New Member

    Joined:
    Nov 20, 2015
    Messages:
    1
    Likes Received:
    0
    I think you can run win 7 driver to set the permissions???
     

Share This Page

Loading...