Sigmatel Line In problem

Discussion in 'Windows 7 Hardware' started by WhiteWolf, Aug 8, 2009.

  1. WhiteWolf

    WhiteWolf New Member

    Joined:
    Jan 21, 2009
    Messages:
    12
    Likes Received:
    0
    Hi all,

    I seem to have a problem with the Sigmatel drivers. I have a Dell Vostro 1700 with a Sigmatel STAC 92XX C-Major HD Audio card and the RC installed, which has been giving me quite a bit of worry of late.. With the standard Win 7 installed drivers, the sound works fine, but no input gets detected from the mic plugged into the Line In. It works fine on my Win XP and Slackware boots so there's nothing really wrong with any of the hardware.

    I've searched a lot on Google, came across the forums a few times with other Sigmatel problems, and I've tried just about every driver I could find. The only one that worked, for a while, seemed to be the Vista 32-bit driver from the Dell Support site for my Service Tag. It was the only one that recognized any sound input from the Line In, but for some reason it only worked once and after a reboot it just stopped completely, like most other drivers, and would recognize a Line In/Mic installed, but not pick up any input from it.

    Does anyone perhaps have any other solutions or drivers that I possibly haven't tried yet? I did find a specific driver recommended, for a Win XP build, but wherever I try to find it, it keeps listing to the same site and apparently it hasn't got the driver anymore or I can't seem to download it any case ( ftp://aiedownload.intel.com/df-support/8658/eng/5.10.5067_XP32_XP64_MCE_2K_IAS.EXE ).

    I've tried a lot of different Dell drivers I found, both meant for my Vostro and not, tried drivers from IDT with a modded INF from laptopvideo2go as well, installed manually and in compatibility mode each and every single one, but I just can't seem to get it to work again.

    I'm open to any suggestions!
     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    How old is this computer?

    Did this happen on install or has Windows 7 been up and running for a while.

    Do not try XP drivers for Windows 7 and the majority of them fail and leave unnecessary files on your computer.

    Also, was this an upgrade or a "clean" installation?
     
  3. WhiteWolf

    WhiteWolf New Member

    Joined:
    Jan 21, 2009
    Messages:
    12
    Likes Received:
    0
    This laptop is about 1,5 years old, the install has been running cleanly for a good while already, never had any major problems apart from this. And it was a clean install, not an upgrade from a previous version.

    Anything else? :)
     
  4. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    #4 reghakr, Aug 8, 2009
    Last edited: Aug 8, 2009
  5. WhiteWolf

    WhiteWolf New Member

    Joined:
    Jan 21, 2009
    Messages:
    12
    Likes Received:
    0
    Not at all, at the moment I've rolled back to the original Win 7 standard driver and removed everything from Sigmatel I could find, file wise and registry entries. Right now it's working fine, but only for sound, Win 7 knows there's a Line In, but still can't get anything from it.
     
  6. GFunk

    GFunk New Member

    Joined:
    Aug 10, 2009
    Messages:
    2
    Likes Received:
    0
    Now I've not tried using the microphone jack on windows 7 but I remember when I used the line-in port as a line-in for Vista I needed to change a registry value somewhere to change from one to the other. I know it's not much help as the driver is probably different now?
     
  7. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    WhiteWolf,

    Were there Sigmatel drivers listed in the Dell Support link I provided above?

    ==============================

    GFunk,

    Hello and welcome,

    In order to troubleshoot your problem we need to know more detailed specs of your system hardware.

    1. Go to Start > Run, and type msinfo32, look under the Components section for hardware identification
    2. Go to Control Panel > Device Manager and look for any entry that has a yellow flag beside it
    3. The manufacturer name and model number of your PC, if applicable
    4 Please fill out your computers specs in the User Control Panel (UserCP) here on the site as well. It will then appear next to your name. look at my posting and you'll see the drop-down arrow.

    The exavct make and modelk of your motherboard would be of great help also.
    Are you using the 32-bit or 64-bit version?
     

Share This Page

Loading...