Solved Netflix N8151 DRM error (Silverlight issue)

Discussion in 'General Computing' started by GomJabbar, Jul 29, 2013.

  1. GomJabbar

    GomJabbar Senior Member

    Joined:
    Jan 25, 2009
    Messages:
    203
    Likes Received:
    2
    Something happened and I could no longer watch videos on Netflix due to the above error (on a Windows 7, 64-bit machine). Googling, I discovered this is a Silverlight error. Tried uninstalling and reinstalling Silverlight, but that made no difference. Also tried deleting the file C:\ProgramData\Microsoft\PlayReady\mspr.hds as I had read in some guides, but that didn't solve the issue either.

    What finally worked was changing permissions on the following folder. I had to give my user full control.

    C:\ProgramData\Microsoft\PlayReady

    Before changing permissions, I would try reinstalling Silverlight and deleting mspr.hds first. But if that doesn't work for you, check the permissions on the PlayReady folder.
     
  2. Libertarian

    Libertarian New Member

    Joined:
    Nov 5, 2014
    Messages:
    1
    Likes Received:
    0
    I granted my browser admin rights, and now it works. Good idea for browser to have admin rights? Probably not.

    Further research shows MS has another version of this file for AMD x64 PCs. I installed the AMD version and it now works fine.

    microsoft dot not com damit because this forum won't let me post links to microsoft /en-us/download/confirmation.aspx?id=36501
     

Share This Page

Loading...