Sony Vaio PCG-71511L BSOD

Discussion in 'Windows 7 Blue Screen of Death (BSOD)' started by Tink Brat, May 30, 2011.

  1. Tink Brat

    Tink Brat New Member

    Joined:
    May 30, 2011
    Messages:
    4
    Likes Received:
    0
    ok, so my VAIO is starting to BSOD more frequently now. I rolled it back to a day before it first started acting up, but it is still happening. here is all the data for it. Hope someone can help me out :(. Thanks in advance for the help and info :razz:
     

    Attached Files:

  2. kaos

    kaos Senior Member

    Joined:
    May 9, 2011
    Messages:
    1,747
    Likes Received:
    33
    Code:
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high.  This is usually
    caused by drivers using improper addresses.
    If kernel debugger is available get stack backtrace.
    Arguments:
    Arg1: 00000000000015d0, memory referenced
    Arg2: 0000000000000009, IRQL
    Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
    Arg4: fffff88000eb266a, address which referenced memory
    Debugging Details:
    ------------------
    
    READ_ADDRESS:  00000000000015d0 
    CURRENT_IRQL:  9
    FAULTING_IP: 
    amd_sata+266a
    fffff880`00eb266a 488b81d0150000  mov     rax,qword ptr [rcx+15D0h]
    CUSTOMER_CRASH_COUNT:  1
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    BUGCHECK_STR:  0xD1
    PROCESS_NAME:  System
    TRAP_FRAME:  fffff8800311b840 -- (.trap 0xfffff8800311b840)
    NOTE: The trap frame does not contain all registers.
    Some register values may be zeroed or incorrect.
    rax=0000000000000002 rbx=0000000000000000 rcx=0000000000000000
    rdx=0000000000000022 rsi=0000000000000000 rdi=0000000000000000
    rip=fffff88000eb266a rsp=fffff8800311b9d0 rbp=fffff8800311bb00
     r8=0000000000000029  r9=0000000000000000 r10=fffffa8004310008
    r11=0000000000000001 r12=0000000000000000 r13=0000000000000000
    r14=0000000000000000 r15=0000000000000000
    iopl=0         nv up ei ng nz na pe nc
    amd_sata+0x266a:
    fffff880`00eb266a 488b81d0150000  mov     rax,qword ptr [rcx+15D0h] ds:ffff:00000000`000015d0=????????????????
    Resetting default scope
    LAST_CONTROL_TRANSFER:  from fffff800030892a9 to fffff80003089d00
    STACK_TEXT:  
    fffff880`0311b6f8 fffff800`030892a9 : 00000000`0000000a 00000000`000015d0 00000000`00000009 00000000`00000000 : nt!KeBugCheckEx
    fffff880`0311b700 fffff800`03087f20 : 00000000`00000000 00000000`00000000 00000000`00000000 fffffa80`0431bf70 : nt!KiBugCheckDispatch+0x69
    fffff880`0311b840 fffff880`00eb266a : 00000000`00000000 fffffa80`04310008 fffffa80`04311b68 fffff880`00eb38a0 : nt!KiPageFault+0x260
    fffff880`0311b9d0 00000000`00000000 : fffffa80`04310008 fffffa80`04311b68 fffff880`00eb38a0 fffffa80`04311b28 : amd_sata+0x266a
    
    STACK_COMMAND:  kb
    FOLLOWUP_IP: 
    amd_sata+266a
    fffff880`00eb266a 488b81d0150000  mov     rax,qword ptr [rcx+15D0h]
    SYMBOL_STACK_INDEX:  3
    SYMBOL_NAME:  amd_sata+266a
    FOLLOWUP_NAME:  MachineOwner
    MODULE_NAME: amd_sata
    IMAGE_NAME:  amd_sata.sys
    DEBUG_FLR_IMAGE_TIMESTAMP:  4bedc8c7
    FAILURE_BUCKET_ID:  X64_0xD1_amd_sata+266a
    BUCKET_ID:  X64_0xD1_amd_sata+266a
    Followup: MachineOwner
    ---------
    
    
    
    AMD_SATA.SYS is your culprit my friend

    Update your AMD Advanced Host Controller Interface driver (amdsata.sys)

    you can get this from AMD's website :)
    hope it works
     
  3. Tink Brat

    Tink Brat New Member

    Joined:
    May 30, 2011
    Messages:
    4
    Likes Received:
    0
    I installed the driver and not getting BSODs anymore....now i'm getting blackscreen shutdowns. The screen will turn black, with no backlight, but the power button remains lit. Only way to shut it down is to hold the power button down and then restart it. But now when i select the option on the start menu to Restart, the laptop shuts down, but never reboots. So i have no idea what to do now. Any suggestions?
     
  4. kaos

    kaos Senior Member

    Joined:
    May 9, 2011
    Messages:
    1,747
    Likes Received:
    33
    ifu just have windows installed

    boot in safe mode with command promt

    run these commands

    chkdsk /f /r

    sfc /scannow

    then boot from your origonal windows disk and select repair

    then go to advanced options

    type

    bootrec.exe /fixmbr

    bootrec.exe /rebuildbcd
     

Share This Page

Loading...