Source Path Too Long - Can't delete folder!!!!!

Discussion in 'Windows 7 Installation' started by Deezal, Mar 4, 2010.

Thread Status:
Not open for further replies.
  1. Deezal

    Deezal New Member

    Joined:
    Mar 4, 2010
    Messages:
    2
    Likes Received:
    0
    Hi. I just upgraded from Vista to Windows 7 last weekend and I must say its been a really bad decision, Win7 is not so much of an improvement to me. We always think the grass is greener. The other idiot thing I did or didn't do was not back up so I could roll back to Vista so I am stuck with this now and I really hate it.

    My issue (1 of many) is I can't delete a folder, I am guessing its some residual from Vista its 'My Documents' but inside it is an endless list of empty folders 'My Documents/My Music/My Documents/My Music/My Documents/My Music/My Documents/My Music...etc.

    When I try to delete I get this message...

    "The source file names are larger than is supported by the file system. Try moving to a location which has a shorter path name, or try renaming to shorter names before attempting this operation"

    I have tried everything, I have tried renaming every file in the folder, they just keep coming back, no matter how many i delete. I have tried using software such as Unlocker or devices to delete on boot, I have moved the folders location, even tried mapping a drive and deleting with command prompt - nothing.

    I am at a loss, I have been trying to delete this thing since last sunday night after the upgrade, i must have spent hours doing this. Done everything suggested here:

    Cannot delete file or folder | Windows Problem Solver

    Any help would be appreciated.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, I am counting on when you say "My Documents" that you mean it and not Documents.

    Anyway, the My Documents folder in Win 7 is just a link or "node" to your Documents folder. I was thinking possibly it had gotten in some type of loop and kept making new links, or the links somehow were pointing at each other.

    So, first, right click on the My Documents folder or My Music folders and select properties. Then go to the Location tab. It should point back to the Documents folder or Music folder. If the path is different from below, that may be your problem.

    C:\Users\YourUser\Documents

    C:\Users\YourUser\Documents

    You might check a couple of levels down to make sure it does not change. If it is different, post back.

    If it is not that, possibly some flag is not being set to tell the system the link has already been made and to stop making more. I have no idea where such a flag might be, even if there is one, but I will try to find it.

    Have you ever tried to move your My Documents folder in XP or Vista or Win 7?

    And anytime a system is doing something it should not, one answer might be to do a repair install.
     
  3. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Be aware that ______
    will put a demo folder for you to try. Which you then need to buy their program to delete your new "too long name" folder.
     
    #3 Elmer, Nov 3, 2010
    Last edited by a moderator: Dec 21, 2010
  4. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Go and grab yourself a copy of Puppy Linux. Then grab yourself a copy of ImgBurn and install it.

    Load a blank CD-RW into your driver and burn the Puppy Linux.iso file to disc. Leave the disc in your player/burner.

    Re-boot. You are instantly taken into Puppy Land (Aah! Cute!). It's worth the 5 - 10 minutes to set up your keyboard etc. so I suggest you do it as it saves your initial setting onto the CD.

    You now have access to your C:\ drive through Puppies Desktop Icons. The Drives are called sda1, sda2 etc. so you just need to search for the right one.

    Dig down to your "too long name" folder and delete the mo. Linux gives you a couple of options in the recycle bin, just pick the "brute force/sledgehammer" option and hit it (HARD!!).

    That should solve your problem.

    Finally, keep the disc. A handy little tool.

    And I've just seen the date of the OP :redface:8->
     
    #4 Elmer, Nov 3, 2010
    Last edited: Nov 3, 2010
  5. Jaco38

    Jaco38 Member

    Joined:
    Feb 15, 2014
    Messages:
    1
    Likes Received:
    0
    You can try Long Path Tool.
     
  6. seekermeister

    seekermeister Honorable Member

    Joined:
    May 29, 2009
    Messages:
    1,499
    Likes Received:
    85
    The only time I had a problem similar to this is when I first installed W7, and because some folders that I thought shouldn't be were locked. After taking ownership of them, I had infinite folder path lengths like your's. I suspect that something else went awry with your's, because I was advised that Vista and W7 had similar locked folders, but I upgraded from XP, without ever going through Vista, and was in the dark.

    There probably is a better way to solve the problem, but I just did a clean installation of W7, and never touched the locked folders again.
     
  7. davehu

    davehu New Member

    Joined:
    Oct 27, 2015
    Messages:
    1
    Likes Received:
    0
    Friend recommended me Long Path Tool for fixing this.
    I am skeptic with this king of tool but I was wrong.
    This tool can do anything."
     
  8. raymono

    raymono New Member

    Joined:
    Feb 12, 2016
    Messages:
    4
    Likes Received:
    0
    Long Path Tool is a best software to solve this issue. 5++ Rating. Long Path Tool is a best software it is a free software. You can Try it
     
  9. fransdaniel

    Joined:
    Aug 16, 2016
    Messages:
    2
    Likes Received:
    0
    Long too path error!
    "Long path tool" is very helpful for this problem. You can solve this problem like copy, delete, long path files by using this tool.
    I used to have similar problems too, but after using "long path tool" everything was solved.
     
Thread Status:
Not open for further replies.

Share This Page

Loading...