Startup not launching all preset programs right...

Nomad of Norad

Extraordinary Member
#1
I have been having an intermittent problem with my Win7 machine. I have several programs that automatically launch at startup, but sometimes it gets stuck partway through this process and leaves only some of the programs launch, with some of them apparently having hung, and never launches the remaining ones. A lot of the programs are Gadget apps, and when this happens, only some of the Gadgets launch, and then (some of?) the non-Gadget programs that usually launch after them fail to appear. And then I sometimes starts having issues with the Start bar not responding. If the start bar IS responding, I can try to issue a shutdown from there, but sometimes it doesn't act on it.

The non-Gadget programs that are supposed to launch that aren't include Pidgin, which doesn't launch at all now, and Skype via SkypeLauncher, which seems to launch but gets no farther than the point where the SkypeLauncher shows the name of the account its meant to be launching, and then it just stops at that point and gets no farther.

I could usually get around this startup problem by shutting the machine off and restarting it, and to keep doing this until I finally got to a session that everything launches normally, but today I'm not getting any luck on that. This time, I can't get this workaround to work at all. Sometimes it declares it needs to do CheckDisk at power on, but when it tries to, it gives an error that some other thing recently installed on my machine has disabled it, and suggests I either uninstall that, or do a rollback.

This startup issue used to show up only occasionally... maybe every few weeks. Lately it has been doing this every couple of days. Where do I go from here? This is really frustrating, particularly because it has locked me out of an event I needed to be attending tonight. oO

editted to add: Also, once it has gotten to this point, often I can't get other programs to launch, either. For instance, if I Ctrl-Alt-Del to try to launch TaskManager, the screen I would select TaskManager from never comes up. Oo

edit2: I finally captured the error that I was getting when trying to do checkdisk at startup. The system was clearing the message away before I could fully read it, so I had to snap a picture of it with my iPad. oO The message I get is:

Cannot open volume for direct access.
Autochk cannot run due to an error caused by a recently installed package.
Use the system restore feature to restore to a point prior to the recent software package installation.

edit3: In safe mode, from the CMD prompt, I invoked chkdsk C: and it gave no apparent indication of trouble.

edit4: Argh, now the machine is mistakenly convinced "This copy of Windows in not genuine" and leaves me staring at a blank, black screen at startup.

edit5: The exact message is:

Windows7
Build 7601
This copy of Windows is not genuine.
 


Last edited:

BIGBEARJEDI

Fantastic Member
Premium Supporter
#2
Hi Nomad,

Sounds like you have a myriad of problems on an aging computer. Sounds to me like you have a failing or failed hard drive, and that's why Windows repair tools like CHKDSK aren't catching or fixing the problem. When was the last time you did a Windows reinstall on that PC? Have you ever done one on that computer since you bought it?

Bear in mind that you are running Win7, and that your hardware is at least 6 yrs.old or older if you didn't upgrade your machine from an earlier version of Windows such as Vista or XP. Hard drives in desktops start to fail at 3 yrs. old, laptops, 2 yrs. old. Hard drive failures are the number 1 cause of failure in Win7 machines.

It would be helpful to have your actual machine specs to further advise you. Make/Model of your PC. Desktop PC or a laptop? OEM computer (DELL, HP, ACER, ASUS, ETC.) or self-built PC?? If you have trouble determining this, ask a friend for help, or you can download the free SPECCY diagnostic tool from piriform.com and post back the output text file back to this forum thread.

In the meantime, take a look at this troubleshooting document I created for another Win7 user having big problems:
Cursor cannot reach top of Quick Launch area

Post your specs back here, and don't hesitate to ask for further questions or help.

Best of luck,
<<<BIGBEARJEDI>>> :tribal:
 


Nomad of Norad

Extraordinary Member
#3
Self built machine. MSI 970A-G46 motherboard, AMD FX-8320 Eight-Core Processor, 3500 Mhz, bios is American Magatrend Inc. V2.0, 1/7/2013

edited to add:
Okay, THIS is flipping strange... NOW everything's back to normal. oO Every autostarted thing launches fine, and no more "This copy of Windows is not genuine" message either. I didn't do anything under the hood to fix it, it just finally decided to go back to normal again. :/

On a different note.... If I want to image the drive onto another drive, what would be the best live-CD based system to go with? Ideally I want to image the internal drive onto an unformated drive that's mounted via a USB adaptor. (I have a USB-to-regular-HDD-adaptor someone gave me years back, it does PATA and SATA.) I tried the free Clonezilla Live CD, but it refused to recognize I had a USB-connected HDD on the machine. Mind you, SOMEwhereorother I had an old, bootable-CD version of Norton Ghost, but it seems to have sprouted legs and crawled behind a shelf. Oo

If need be, I'll go track down another SATA cable and mount the blank drive internally, but I don't have one of those handy at the moment.
 


Last edited:

Nomad of Norad

Extraordinary Member
#4
Aaaaaannnnnd now it's back to doing the stuff-isn't-launching-right song and dance. It seems to do this every OTHER day of late.... and always seems to do it the day I have an online event at a particular time that I ABSOLUTELY MUST attend.

It gets as far as the point where desktop icons come up, but then I see no disk activity after that, and nothing else that is set to autolaunch starts. I can click the Start button and the relevant pane comes up, but all the items listed on the left side (the frequently-used programs list) arrive with blank icons. Clicking one of the buttons on the right wither does nothing, or I get a window with just about nothing in it.

At some point, I'll get the busypointer on the mouse, particularly when mousing over the start bar, at which point I can't get the start bar to do anything... and then I get a pop up saying this program has stopped, with an End button. When I click that, the wallpaper goes blank white, the start bar complete disappears along with the desktop icons, then the wallpaper comes back up, but no start bar ever comes back up. I have no choice then but to shut the machine off via the power button.

I can launch into Safe Mode without any of this, though. It works fine in Safe Mode.

Thing is, when it does this stuff-isn't-launching-right thing, it does it EVERY startup in a row that day... maybe it EVENTUALLY starts back to working right after X-number of repeated reboots and restarts. Then everything goes fine the rest of the day, and it starts okay the next day, too. But then the day after THAT, we're back to the stuff-isn't-launching-right song and dance. Aaargh!

I'm assuming there's something under the hood of the OS that is crucial to the launching-of-preset-programs stuff that itself is tripping over itself and falling over, and that other things are dependant on that one thing to be there to do THEIR thing...

Is there an analyze-the-startup program I can install that might tell me what's going on?

Oh yes, and forgot to mention that at other times, instead of it busypointering the start bar, it will busypointer the desktop... and I can click the Start button and select Shutdown from there, but... it doesn't seem to act on the shutdown command. No disk activity shows. So, I still have to power off via the power button.

edited to add: Okay, someone else I was talking to in chat suggested the problem might be "...an internet comms problem - something jamming up windows IP stack" and suggested I try uninstalling certain apps, but also that I try booting with the ethernet cable disconnected.

So, (while in SafeMode) I went into MSConfig, Startup tab and unchecked these programs from the list:

iCloud for Windows
Dropbox for Windows
iCloud for Windows (dunno why that one is there twice. oO)
Wootalyzer
Bitcoin (a wallet program)
Dropbox
MEGAsync

...then let the machine do the reboot-for-the-changes thing. It booted to a totally unpopulated desktop (no desktop icons), and then showed no disk activity. Trying to do something in Start pane (I was trying to open a window from there, and again the program icons on the left of the Start button pane showed blank icons, and no other windows would open from it) just made it disappear the start bar again. oO So, NOW I disconnected the ethernet cable, hit the reboot button... and this time after a bit, all the (other remaining) auto-launched apps and things launched as normal, and the machine seems to have gone back to working fine. oO

Does this suggest a more specific place to look?
 


Last edited:

BIGBEARJEDI

Fantastic Member
Premium Supporter
#5
Hi Nomad;

Ahhh. Now I see your problem; it's a self-built machine!!! There are 2 things that are common mistakes in self-built or custom-built rigs that people on this forum and the other tech forums I volunteer on cause your kind of problems; both easy to fix:

1. Failed hard drive; re-read my Post #2 above! Test and replace if test fails. simple.

2. Underpowered or failing PSU. WE'LL NEED YOUR EXACT SPECS ON BOTH THE PSU AND YOUR DISCRETE GPU VIDEO CARD TO FIX THIS!! We need the Make/Model, Wattage, and Amperage of both the +12V & +5V rails. To do this, you'll probably have to open your case and disconnect the PSU, take it out and look at it, unless you have those specs on hand. You won't be able to get this from SPECCY either unfortunately; but you should still continue running SPECCY for us, as it will give us to poop on your GPU card specs.

It's almost 1 or both of these 2 problems with self-built machines that have your symptom issues. Now we are solving probably 80%-90% of these kinds of failures once we figure out it's a self-built PC. Here's your problem--and please don't take offense to this. People who build their own PCs; especially us tekky or IT guys are very remiss to admit they had a design problem or a failed device (hdd or RAM stick or Mobo), so they try to fix the software, over and over and over.o_O They go through much of the stuff you have and of course more if your are getting BSOD error codes which require dump analysis; but most of these are correctable if you start with testing and fixing your hardware FIRST, and then if the software misbehaves, going through the software troubleshooting decision trees.
Here's the deal: "NO SOFTWARE ON THE PLANET CAN FIX BROKEN HARDWARE!! PERIOD!!".
If you can accept this statement, and move on with testing your hardware, you can get your problem fixed.:D Having 3 degrees in Computer System Electronics and Design and 44 years in the Industry, I'm telling you this is the best way to troubleshoot your system; I've been doing it for many years successfully and have made a good living doing so. Of course, you can do whatever the heak you want with your system. Advice you get from folks like this on this forum is as good as it gets; and you've been here for awhile I see, so you get that: that's why you're here asking for professional help.

So, stop focusing on fixing all your problems with software solutions, and test your Hardware!! Replace failed components as necessary. If you go through all my steps, especially the link in my Post #2 to HW & SW testing, this will result in a fixed system more than likely. People often ignore this advice, and spend weeks or months trying to fix their Windows build, and tell us that it's too much work to test their hardware, too difficult, and of course they often don't believe us that it will fix it. Sometimes, they give up, trash their entire system and start over (a very drastic step!), or replace their Motherboard--but the problem often comes back, especially if they re-use a failed (or non-tested failed hdd) hdd from the original build on the new Mobo. All the same problems come back, and often more, as they build the new system and don't take all the necessary precautions--such as checking their PSU ratings, cables, other stuff that a shop tech would always go through.

Enough on the lecturing; can't help it; I'm also a teacher; what can I say?

If you're willing to take a few days and go through everything I've provided to you, you should wind up with a fixed system. If not, you can always scrap and rebuild a new one that works properly from scratch, or take into a good repair shop and PAY them to fix it for you! DIY guys like us hate to do that--not because we can't afford it, but rather it's a pride issue; we can't accept the fact that something was designed wrong from the git-go, or that a piece of hardware broke. What's the big deal? If something in your car breaks, and it doesn't go--you troubleshoot it, find the bad part and replace it. If necessary, you pay a mechanic to do for you if you don't have the right tools, knowledge, skill, etc. and soon your car is driving again! Take a few minutes, step back, and think about what I've said here; take a deep breath, and then think about what I'm telling you and you can get this computer on the road again!;)

Post back your HDD, PSU, GPU Card specs, and that will help us to guide you further.

Best, :peace:
<<<BBJ>>>
 


Last edited:

Nomad of Norad

Extraordinary Member
#6
Well, the machine is one I've had for at least a year or two.... tho I had to replace the PSU recently... twice.

Anyway, copypasting from Speccy....

HDD info:

ST31000333AS ATA Device
Manufacturer Seagate
Form Factor 3.5"
Heads 16
Cylinders 121,601
Tracks 31,008,255
Sectors 1,953,520,065
SATA type SATA-II 3.0Gb/s
Device type Fixed
ATA Standard ATA8-ACS
Serial Number 9TE0YN72
Firmware Version Number CC1F
LBA Size 48-bit LBA
Power On Count 2804 times
Power On Time 1473.0 days
Speed 7200 RPM
Features S.M.A.R.T., AAM, NCQ
Max. Transfer Mode SATA II 3.0Gb/s
Used Transfer Mode SATA II 3.0Gb/s
Interface SATA
Capacity 931 GB
Real size 1,000,204,886,016 bytes
RAID Type None
S.M.A.R.T
Status Good
Temperature 39 °C
Temperature Range OK (less than 50 °C)
Partition 0
Partition ID Disk #0, Partition #0
File System NTFS
Volume Serial Number D0F367C9
Size 199 MB
Used Space 49 MB (24%)
Free Space 150 MB (76%)
Partition 1
Partition ID Disk #0, Partition #1
Disk Letter C:
File System NTFS
Volume Serial Number 50EFD824
Size 931 GB
Used Space 503 GB (54%)
Free Space 427 GB (46%)

PSU (taken from box, not from speccy):

Ultra LS 500
max output current, current, max, combined, wattage:
+3.3V, 24A, 130W, 584W, 600W
+5V, 19A, 130W, 584W, 600W
+12V, 46A, 552W, 584W, 600W
-12V, 0.3A, 3.6W, 16W, 600W
+5VSB, 2.5A, 12.5W, 16W, 600W

GPU:

NVIDIA GeForce GT 520
Manufacturer NVIDIA
Model GeForce GT 520
GPU GF119
Device ID 10DE-1040
Revision A2
Subvendor EVGA (3842)
Current Performance Level Level 2
Current GPU Clock 810 MHz
Current Memory Clock 500 MHz
Current Shader Clock 1620 MHz
Voltage 1.110 V
Die Size 79 mm²
Release Date Apr 12, 2011
DirectX Support 11.0
OpenGL Support 5.0
Bus Interface PCI Express x4
Temperature 77 °C
Driver version 9.18.13.3221
BIOS Version 75.19.1b.00.26
ROPs 4
Shaders 48 unified
Memory Type DDR3
Physical Memory 2047 MB
Virtual Memory 2048 MB
Bus Width 32x2 (64 bit)
Filtering Modes 16x Anisotropic
Noise Level Silent
Max Power Draw 29 Watts

I am running two monitors on the video card.
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#7
Nomad,

Good job posting back your specs, especially your PSU.:applaud:

Here's the link you need for testing your Seagate hard drive and your RAM sticks:
Cursor cannot reach top of Quick Launch area
Pay particular attention to the section on using the free SEATOOLS drive diagnostic from seagate.com.

Next, you have an underpowered and low-quality PSU here. No offense. Especially given your are using an AMD processor; they use more power than the equivalent Intel processors of similar speed and performance. And the fact that you are using a dual-monitor 2GB DDR3 video card. That alone suggests your PSU is not powerful enough. Your +12V rail is 46A; that's too small for this combination of AMD CPU and the dual-monitor video card. I believe you need at least 55A problably 60A would be better. How do I know this? Take a read here on this excellent article from another tech forum I volunteer on: Power Supply Information and Selection - Tech Support Forum
This not only explains how to calculate the Wattage and Amperage of the PSU you need, but your PSU is not even rated at the BRONZE level of performance (explained in the article); the lowest of the 4 required performance certification levels needed. I currently use the Seasonic X-Series 750W 80PlusGold PSU. I'm using this on a 2008 Dell Studio 540 as a replacement supply, as the last 3 I've replaced only last 1-2 yrs. including the one that came with the Dell from the factory. It was getting really annoying replacing them. Luckily, none of them fried my Motherboard! I strongly suggest you go with at least the 80Plus Gold 750W supply as I have or similar.

Also, pay attention the brands mentioned in the same article. Only brands that are recommended are: COOLER MASTER, CORSAIR, SEASONIC, XFX, and THERMALTAKE. Avoid all others; these have been thorougly tested by the experts, techs who make gaming and professional custom-rigs for a living. The article is informative and well-researched and written. I'm sure you will understand why you need to spend more money and get a better PSU after reading this. I've finally stepped up to a quality PSU, and since the replacement I did last year; I've had zero power-related problems; and my system is more resistant to brown-outs and black-outs of which we have many since I live in the Mountains and we get lots of thunderstorms with lightning strikes and snow.

Another point to make is that the article talks about using 25-30% MORE POWER in your PSU than your actual calculated value. In Engineering school, this is more like 50%, for "over-engineering". So, I tended to go even higher wattage/amperage specs than was recommended. This method is also used by Mechanical Engineers when they design span bridges. You certainly wouldn't want to drive over a bridge with a 1000 ft. drop that was under-engineered, now would you?

Test your hard drive, and read the 2 articles I provided; it will help you get going. You DEFINITELY need to replace that PSU (that's why you keep having to replace them as I was doing). To help you with your Budget, I paid $139.74 for my Seasonic 750W 80PlusGold supply. I think you could go a little cheaper, but not much. You should plan on spending about $125 or more based on my analysis. You'll be glad you did the upgrade!

Keep us posted on your progress!
<<<BBJ>>> ;) :lightbulb:
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#8
Self built machine. MSI 970A-G46 motherboard, AMD FX-8320 Eight-Core Processor, 3500 Mhz, bios is American Magatrend Inc. V2.0, 1/7/2013

edited to add:
Okay, THIS is flipping strange... NOW everything's back to normal. oO Every autostarted thing launches fine, and no more "This copy of Windows is not genuine" message either. I didn't do anything under the hood to fix it, it just finally decided to go back to normal again. :/

On a different note.... If I want to image the drive onto another drive, what would be the best live-CD based system to go with? Ideally I want to image the internal drive onto an unformated drive that's mounted via a USB adaptor. (I have a USB-to-regular-HDD-adaptor someone gave me years back, it does PATA and SATA.) I tried the free Clonezilla Live CD, but it refused to recognize I had a USB-connected HDD on the machine. Mind you, SOMEwhereorother I had an old, bootable-CD version of Norton Ghost, but it seems to have sprouted legs and crawled behind a shelf. Oo
>>>I've done extensive testing over the last 20 years on this; and especially in the last 3 years for my computer repair business. The best 2 products I've used are both free: (1.) MACRIUM REFLECT; and (2.) ACRONIS TRUEIMAGE. I've tested them on all versions of Windows back to Win2k, and they are both around 99%; no products on the market are 100%; especially Norton Ghost. That product never worked reliably while I used it in business corporate environments and is not consistent across the thousands of combinations of hardware and brands. And that included the Enterprise version we spent $1,200 per year on! What I like also about the Macrium and the Acronis, is that I've thoroughly tested them on Win10 as well. There is another product that some of the guys on the W10 Insider Team like which is EASEus TODO. I haven't tested it; but it's got a good reputation.
These are WAY easier to use than the Linux-based Clonezilla; which I taught myself to use. It's difficult even for experts, and is quirky at best when you start using on different types of computers; much like Norton Ghost. I think you'll be quite pleased with the Macrium or Acronis. Also, since you will cloning a Seagate drive, you can get the Acronis free at seagate.com website, and it's guaranteed to work with any major drive vendor, as long as 1 of the 2 drives (source or target) being used is a Seagate. This is a licensing requirement that Acronis has with Seagate. Also, I've used the Acronis on my Sony laptop with Kingston SSD drive (Acronis licensed their program to Kingston as well); and that works great with my SSD drive on Win7 & Win10.

Hope that proves helpful!<<<<<<

<<<BBJ>>> :l:

If need be, I'll go track down another SATA cable and mount the blank drive internally, but I don't have one of those handy at the moment.
>>>You can buy SATA cables from Radio Shack or online through cables.com etc. They are $5-$20 depending on how long you need the cable to be. Of course that varies with the size of the case your computer is; larger cases like full-towers require longer cables; 18"-36" or longer depending on how crowded your case is with electronics. Also, I must mention that if you are cloning OSes, such as Windows or Linux; the above mentioned programs don't work on many computers due to subtle differences in the BIOS and the way they handle the USB ports. Most of the testing I did shows that you will be most successful if your 2nd drive (target drive) is physically cabled inside the case to the Motherboard SATA drive connector. This of course is tricky on laptops, except those special models that provide 2 drive slots. Most do not.<<<
<<<BBJ>>> :l:
 


Nomad of Norad

Extraordinary Member
#9
Actually, I think I gave you the wrong PSU specs, I have two different boxes sitting here, one of them was for the PSU I had in before, the one that quit after a good while and that I then replaced recently. THAT one had lasted me since I built the machine, which might have been a year or two ago, I forget exactly how long.

The PROBABLY correct one is:

Sentry BXP600

AC Input
Voltage 115v/230v~, Current 7A/4A, Frequency 50HZ/60HZ

DC Output
+3.3v 13A, +5v 15A, +12v 20A, -5v 0.5A, -12v 0.5A, +5vsb 2A, COM GND

I HAD replaced the previous one with a Thermaltake of the same wattage, but it kept shutting off suddenly, at random, usually at least once every other day. It was driving me batty.
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#10
I see. Well Sentry is not on the TF PSU Guide approved list either, and I've never heard of it. The real problem with that one, if it's indeed the one you installed in your current computer case; it's even WORSE than the other spec unit. This one only has a +12V rail of 20A; absolutely way below what you need for that system!! It's amazing that it didn't blow up or catch on fire when you first turned the computer on with that thing installed!! :noise:

Sounds like the Thermaltake you got was simply defective, as they are an approved PSU brand. You should have just returned it for exchange or money back and gotten a different brand from a different store or online location.

Like I said, neither of those supplies is an approved brand, and neither has enough amperage on the +12V rail to properly supply smooth continuous power to your hardware devices. Period.

Also, since you have multiple boxes from the PSUs laying around, how can you be sure EXACTLY which PSU you have inside that computer case?? You really need to open that case up and pull out the PSU and read the specs directly from the PSU and post those back and confirm what you just posted. You shouldn't be afraid to crack the case on it since you built it yourself; you've been in there before.

<<<BBJ>>> :scratch:
 


Nomad of Norad

Extraordinary Member
#11
I just have the two boxes here. The Ultra LS 500 box I had over here because I was trying to search online for something equivalent in spec. The other box is what the replacement came in. I've verified the first mentioned box is from the older PSU because the old PSU is sitting on the dead-hardware pile in another room and I matched up the name of them from that.
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#12
Ok, thanks. So you get that neither one of these PSUs is going to work? (obviously, the dead one isn't an issue and shouldn't be replaced with the same make/model).

Did you get a chance to run SEATOOLS on the hard drive yet?

BBJ
 


Nomad of Norad

Extraordinary Member
#13
Does the seatools util make any alterations to the drive that might mess things up?
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#14
No, absolutely not. However, the program does have the capability to completely ERASE or WIPE the drive clean in a separate option; not in the Testing menu. This is why we caution all Users here about ensuring that they backup all their personal data to external media--just in case they do something stupid. Has happened before many times to other people.

This is true with just about all the other manufacturer-provided drive diagnostics tools out there, such as WD DLG, HGST, TRIM, etc. Also, with 3rd party tools such as HD Tune Pro. Just make sure you stick to the testing options; Short & Long tests as mentioned in my previous posts. Those are completely non-destructive tools and have use them many times. However, as I said, I'm a professional so I expect that when people's computers are busted they panic and therefore will often click on every single option in a diagnostic program, not understanding what that can do in a program like SEATOOLS, as it has both non-destructive testing tools and destructive testing & repair tools.

As an aside, you can also use SEATOOLS, even on non-Seagate branded drives, however, it's testing capability is limited or may not work at all. Again, if you're planning on using SEATOOLS on a non-Seagate drive, make sure to use Testing mode only, as wiping a non-Seagate drive with SEATOOLS can render your drive unuseable in certain cases.

Hope that answers your question (probably more than you wanted to know!). ;)
<<<BBJ>>>
 


Nomad of Norad

Extraordinary Member
#15
Okay, short test and long test both gave Pass.
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#16
That's Great! :) The drive is useable then, and not likely to be a source of your problem. How are you doing with replacing the PSU??

<<<BBJ>>>
 


Nomad of Norad

Extraordinary Member
#17
I have ordered a Corsair RM Series 750 Watt ATX/EPS 80PLUS Gold-Certified Power Supply - CP-9020055-NA RM750
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#18
Oooh! Very nice. :star: Corsairs are on the TSF Build Guide recommended list. 80Plus Gold-Certified is what you want. 62.5A on the 12Vdc rail. This should provide plenty of Clean Power to your Mobo and devices. You may notice general improvement of your entire system too. I did with mine. It looks very state-of-the-art, and you'll love those modular cable plugins; much like my Seasonic--I love mine!! Let us know how you like it and of course if your problem abates.

Keep in touch!
<<<BBJ>>> :shades:
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.