Strange Win7 DHCP issue take a look!...please

Discussion in 'Windows 7 Networking' started by nsperduti, Mar 14, 2013.

  1. nsperduti

    nsperduti New Member

    Mar 14, 2013
    Likes Received:
    Hello all,

    I've got a bit of a strange issue going on with a PC i just put together.
    Its a Win7 Home Premium machine will all updates and service packs installed.
    There is no antivirus software or security software or 3rd party firewall software installed...machine is clean though only play games on it.
    its built on a MSI 970A-G46 motherboard and the issue involves the built in LAN Realtek port with latest drivers from MSI site.
    Im trying to get the machine on the internet with my old pelican wireless 360 adapter. The pelican wireless 360 adapter is configured and setup properly for my wifi network. If i connect it via Ethernet cable to my ps3 or my macbook and tell them to configure via DHCP they get IP addresses and get on the internet fine. With the built in LAN port on the MSI board i get nothing, if i configure the IP manually with an address in the proper range it gets on the internet fine. I thought maybe there is somthing wrong with the NIC itself so i put in an old HD and downloaded the netinstaller for debian to see if it would grab an IP on its own during the install and that worked i was able to download and install debian without issue i did not need to manually enter the IP. So i guess that means the NIC is working fine, which leaves windows or driver issues. I ran the netsh ipreset command and that did not change anything, i also tried changing the speed and duplex from the advanced tab for the NIC from auto to 100 full duplex and that did not change anything either.

    Any tips or advise or thoughts or anything its not a major issue as i can just assign a manual address but i'm pretty good with all things computers and such and its bugging me that i can't get it to work with DHCP.

    Thanks in advance for any responses.
    #1 nsperduti, Mar 14, 2013
    Last edited: Mar 14, 2013
  2. helpifIcan

    helpifIcan Extraordinary Member

    Jun 20, 2009
    Likes Received:
    To help us help you when it's not working goto a command prompt and do "ipconfig /all" and post it here. That will allow someone to better help with possibly solving your problem.
    As an extra help also post one when you use the static IP.
  3. TimeIsMoney

    TimeIsMoney New Member

    Jul 27, 2013
    Likes Received:
    No AV on the machine? that's like having unprotected sex. No telling what you may have picked up.

    Sounds like the LAN Realtek port is not compatible with the old pelican wireless 360 adapter?

    PS: How old is the old pelican wireless 360 adapter?, what is the model number and revision /build number?

    When I first set up Win7 x64 I was using some old (Win2000/XP) network cards and had to do several work arounds to get them working, can't remember the specifics, sorry.

    Unless you want to buy new hardware, I'd just assign the address manually.

    Ah, man I see this thread is from

    nsperduti, Mar 14, 2013

    What was the problem?
    What was the fix?

Share This Page