Toshiba L505 with Realtek RTL8191SE wireless Lan - problem connecting wirelessly to DLink DI524 rout

Discussion in 'Windows 7 Networking' started by dumas9, Mar 20, 2011.

  1. dumas9

    dumas9 New Member

    Joined:
    Mar 20, 2011
    Messages:
    6
    Likes Received:
    0
    I have a Toshiba L505 laptop that came with Windows 7 Home Premium. I have a home network setup through a DLink DI-524 router. With Windows 7 Home Premium - I had no issues connecting wirelessly to this router. However, after several security upgrades and also upgrading to Windows 7 Professional - I can no longer connect. It does detect the home network but will not allow me to connect. I even tried disabling the Windows 7 Prof. Firewall - but not luck.

    Any suggestions ?
     
  2. helpifIcan

    helpifIcan Extraordinary Member

    Joined:
    Jun 20, 2009
    Messages:
    768
    Likes Received:
    23
    The first thing you need to try is to turn off router security to make sure that the WEP, WPA, etc is not preventing connection.
     
  3. dumas9

    dumas9 New Member

    Joined:
    Mar 20, 2011
    Messages:
    6
    Likes Received:
    0
    I can definitely try turning of router security. But the confusing thing is that the same settings were working with Windows 7 Home Premium but do not with Windows 7 Professional.

    Thanks....
     
  4. helpifIcan

    helpifIcan Extraordinary Member

    Joined:
    Jun 20, 2009
    Messages:
    768
    Likes Received:
    23
    Yes I understand the thing is you need to get to simplist set of variabales to be able to solve the problem.
     
  5. dumas9

    dumas9 New Member

    Joined:
    Mar 20, 2011
    Messages:
    6
    Likes Received:
    0
    Thanks......
    That worked.
    I tried several encryption settings - WEP/shared also worked.

    Thanks......
     
  6. helpifIcan

    helpifIcan Extraordinary Member

    Joined:
    Jun 20, 2009
    Messages:
    768
    Likes Received:
    23
    Great glad I could help, enjoy.
     

Share This Page

Loading...