two tabs always open in firefox

Discussion in 'Windows 10 Help and Support' started by makapa46, Aug 24, 2016.

  1. makapa46

    makapa46 Member

    Aug 28, 2015
    Likes Received:
    when i start firefox, it always opens with 2 tabs at the top, one being yahoo, and the other is google.

    surely it should start with only one tab and i have made google my start page.

    hopefully someone will know why this is happening.

    many thanks


    BIGBEARJEDI Honorable Member
    Premium Supporter

    Jan 28, 2013
    Likes Received:
    Hi and welcome to the forum :up:

    It could be that you have some spyware toolbar or home page hijack virus loose on your PC. If not, and someone else has been using your account on your PC--this happens a lot, take a look at this page on the Firefox-Mozilla support page:
    Startup, home page, tabs, and download settings | Firefox Help

    It will show you how to add/remove/modify one or multiple home pages on your browser's startup.

    This should take care of it unless you have a virus; in which case you need to scan/remove any viruses found by your built-in Antivirus program (such as Norton, Avast, McAfee, TrendMicro, etc.). And it's a good idea to download the Free MALWAREBYTES antispyware program from and scan specifically for spyware viruses. Many of those are known to scramble or hijack your home pages. And if you've installed any Toolbars in any of your browsers (IE11, Edge, Chrome, Firefox, Safari, Opera) with the exception of Google Toolbar, you are pretty much guaranteed to have from 1-1,000 spyware viruses in your computer. The symptom being home-page hijacking, which you can google and lookup or go to and lookup.

    That should take care of it and get you back on the road again! :up:

Share This Page