Ventrilo Lagging Audio Issues

#1
*I apologize, I posted this in hardware first, unaware of where I was :)

Hi everyone,

I'm not sure how many of you use Ventrilo to play online games (i.e. CS 1.6) but I've had a few minor issues with the program. For starters I've had this problem in both the 32-bit and 64-bit version of the program. The issue is sporadic but happens every time I run the program. Voice chat will appear to be working just fine, however after a few minutes you'll notice that when you talk there are no immediate responses. After a few minutes more you hear all the previous dialog linked together in one big audio stream, like it lagged and tried to catch-up in fast-forward. Has anyone else experienced this? I'm hoping this, along with the ATI OpenGL issue will be addressed soon. Other than that, I've had a great initial experience with 7 thus far. Love the forum as well!

Mike
veritas
 


#2
Hmm, now that you mention it, this issue happened to me when I was talking to my friend the other day. I thought it was only him lagging, but he insisted that it was me. :p
 


#3
Hah

I had a feeling it wasn't just me. I tried it on both the 32-bit and 64-bit Windows 7 Beta (and Ventrilo client). Both have yielded the same results. Hopefully Ventrilo will be proactive and release a beta for 7. Thanks for the reply!

Mike
veritas
 


#4
Just had this happen to me and checked out this thread. Sad to see there doesn't seem to be any immediate fix.
 


mynd

New Member
#5
There actually is a fix. I was able to achieve great communications by choosing SFX settings with your hardware and direct sound and choosing left and right front speaker ( add ). Give it a whirl you will be surprised that it might work.
 


#6
There actually is a fix. I was able to achieve great communications by choosing SFX settings with your hardware and direct sound and choosing left and right front speaker ( add ). Give it a whirl you will be surprised that it might work.
Thanks for the suggestion - I'll try it tonight come raid time. I noticed though that you are running the 32-bit version of Ventrillo - are you doing so with Windows 7? Have you tried the 64 bit of Ventrillo?
 


mynd

New Member
#7
I am not running the 64 bit version of ventrilo. I am indeed running windows 7 build 7000. Good luck to you.. I also run ventrilo as compatibility admin. This allows on games like DDO or NWN the ability for it to exist in the background and still run properly. I came across an OPTION on my sound device ( properties ) that enable the application to take full control of the device. I removed that check mark cause I did not want the foreground application ( as I saw it, ddo ) to restrict ventrilo in any way. You might want to look into that on your sound device options and configuration tabs.

Good Luck
 


#8
I am not running the 64 bit version of ventrilo. I am indeed running windows 7 build 7000. Good luck to you.. I also run ventrilo as compatibility admin. This allows on games like DDO or NWN the ability for it to exist in the background and still run properly. I came across an OPTION on my sound device ( properties ) that enable the application to take full control of the device. I removed that check mark cause I did not want the foreground application ( as I saw it, ddo ) to restrict ventrilo in any way. You might want to look into that on your sound device options and configuration tabs.

Good Luck

Hmmm...the screen print you linked shows the 32 bit version though. Thank you for your responses and help. I'm going to give your suggestion a try tonight.
 


#9
There actually is a fix. I was able to achieve great communications by choosing SFX settings with your hardware and direct sound and choosing left and right front speaker ( add ). Give it a whirl you will be surprised that it might work.
This seems to be working alright for me.

I'm starting to get annoyed with windows 7 though, initially there weren't many bugs and I figured I could just use it until beta ended or it was released. Sadly though, windows installation issues and the lack of ability to use internet explorer 8 and windows live messenger and stuff are pushing me away from it =(

Sorry, not trying to push off topic.
 


#10
Great news/// However, not sure why you are having issues with IE8 and WLM for windows 7.. I have both and both are working perfectly.. Did you download the latest WLM for windows 7? Google it.. or check here as I have posted a link to the new WLM in another thread.. If you need help let me know.. :D
 


haxcid

Senior Member
#12
As for the original post regarding lag in ventrilo.

Set the process priority to above normal or high. That fixed the issue for me. No more lag. It is not a great solution but it works until the issue can be resolved by the ventrilo software people.
 


#13
awww

hy, got anyone a solution for ventrilo 2.1.4 for lagg on win7? thx;)
 


whoosh

Cooler King
Staff member
Premium Supporter
#14
This seems to be working alright for me.

I'm starting to get annoyed with windows 7 though, initially there weren't many bugs and I figured I could just use it until beta ended or it was released. Sadly though, windows installation issues and the lack of ability to use internet explorer 8 and windows live messenger and stuff are pushing me away from it =(

Sorry, not trying to push off topic.
At a later date MS are releasing an XP mode update . So all your software issues will in the near future be a thing of the past . Good luck and hope this helps in some small way :)
 


whoosh

Cooler King
Staff member
Premium Supporter
#15
Vetrilo try it with win7 winXP compatibility mode

Lots of folks are reporting big issues with ventrilo . Try it with windows XP compatibility mode and it should in theory work .
 


#16
There actually is a fix. I was able to achieve great communications by choosing SFX settings with your hardware and direct sound and choosing left and right front speaker ( add ). Give it a whirl you will be surprised that it might work.
Hehe thats a nice solution but what if I use older version of ventrilo ? I cant see any SFX options :'< Is there a solution for 2.1.x ones aswell?
 


#17
I'm glad I found this thread, as I thought I was going out of my mind. I just installed Windows 7 today and have the same problem as everyone else here. I have not yet tried the solution, but just wanted to make note that this is still occurring on Windows7/Ventrilo as of today.
 


whoosh

Cooler King
Staff member
Premium Supporter
#18
I'm glad I found this thread, as I thought I was going out of my mind. I just installed Windows 7 today and have the same problem as everyone else here. I have not yet tried the solution, but just wanted to make note that this is still occurring on Windows7/Ventrilo as of today.
Yes following this thread because I am a member of a clan playing UT- Unreal Tournament . So Ventrilo has some importance in planning while playing etc . Glad to say have not played for some time while exploring windows 7 . Issue with Vent are a worry .
 


#19
Any updates on this?
 


#20
i'm having the same issue with 64 bit ventrilo on win 7. I am going to try setting priority to above normal.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.