w7 has stopped searching in libraries

ruggb

Honorable Member
#1
when i try to search for something in a library folder, windows explorer does nothing.
If I go to the actual folder search works fine.

Libraries
My Documents <-- WE will not run a search here, I type in search box and nothing happens

Users
myprofile
My Documents <-- search works fine here.

Search - using the start menu - only finds some things like CMD. I can't define it, but it won't find anything under myprofile folder.
I appears to do something but says it can't find anything.

what's happening???
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
The biggest thing you need to make sure of in searching is where the search is starting. Make sure an highlight the folder you want searched.

But there are several settings to aid you is search options. Open Explorer and look at the Organize, Folder and Search options to see if you need to change anything to get the searches you want.
 


ruggb

Honorable Member
#3
thx saltgrass -- but.............
Nothing happens when i enter a word into the search bar in WE
it isn't an issue of not finding what i want -- the search function does not even run when the folder selected in the left pane is under the LIBRARIES folder. If i select the drive or any real folder under it, the search runs normally.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
I am in Windows 8 right now so I need to get back to Windows 7, but do you have indexing turned on from the control panel, and can you check Task Manager or Services.msc to see if Windows Search (WSearch) service is running. Looks like it should be set to an Automatic (Delayed) start.
 


ruggb

Honorable Member
#5
windows search is running, indexing is not.
HOWEVER, if it searches drive c & d why would u think the services r not running.
I didn't say it was slow, it does not search at all in libraries.
I purposely turned off indexing long ago.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
If I open Explorer and select the Libraries heading or one of the sub-folders, then enter a search in the window, all it will find is the wildlife video. I have many documents in the other folders.

So I am going to say what you are seeing is normal. Possibly because the Library folders are not really folders, but pointers to the actual folders and Search can't cross that boundry. But this is only a guess.
 


ruggb

Honorable Member
#7
thx for the follow up.
I guess u have the same problem.
on my laptop - same system, same configuration, I select LIBRARIES, enter a search and it finds files with the name and cotent in the files - i guess indexing is on here.
on the DT it just sits there looking dumb. it does not say it is searching or that the search did not find anything - it just sits there
it doesn't matter what folder - LIBRARIES or under
but it works fine under the drive folder.

i had a situation when w7 first came out - or maybe beta - where it would search My Documents under Libraries but never would find anything. At least it acted like it was searching - which I guess was worse 'cause I thought I lost the files. But if I searched My Documents under the drive it would find everything I was looking for.
Somehow that got resolved - don't know if it was a reinstall or an update that fixed it.
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#8
I just did something that helped my search and it was go to the Indexing Options in control panel, select modify and see if under the OS partition label, you show Users as being an indexed location.

I do not have indexing turned off, but I don't index much.
 


ruggb

Honorable Member
#9
I turned indexing on
services shows it as being on automatic and started
windows search has always been on
if I go to Indexing Option in control panel it is telling me it is off - there is nothing in the include or exclude columns
I have rebooted.
it has not changed the problem.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#10
I must be confused about what is going on. It appears, in order to turn off Windows indexing, you need to disable the WSearch service. I am assuming when you say Automatic and running, you are referring to that service.

If you open Indexing Options, you do not show a modify button? If you have the button, there are no selections as to which folders to be indexed?

If that is the case, all I might suggest now is to rebuild the index and see what happens.

Could you post a snipping tool picture of the Indexing Options window using the paperclip on advanced replies?
 


Last edited:

ruggb

Honorable Member
#11
no, the search service has always been on. I had to turn on the indexing feature to get the service listed. It was automatically set to be on at that point.
There is a grayed out modify so I cant set anything there.
I'll try the index rebuild.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#12
I notice in Programs and Features, Windows features on or off, there is an "Indexing Service" which is unchecked by default. It does start an Indexing Service that can be seen in the Services Panel, but it should not be there. It is for an older version of Windows and should not normally be turned on.

There is a Search Troubleshooter you might try. Maybe if would find something that is not running correctly. I will look to see if I can find a reason your modify button would be greyed out, but it appears something is not running that should be. You may even want to open an administrative command prompt and type SFC /scannow to check your system files.

If you have made some modification to the registry or some other setting to turn the normal indexing off, you might revisit that.

Edit: If I stop the Windows Search (WSearch) service, I get an Indexing Options windows with no locations listed, the Modify button is greyed out, and it says Indexing is not running.... sounds like what you show. SearchIndexer.exe is the component that seems to be doing the work, if that helps any...
 


Last edited:

ruggb

Honorable Member
#13
ah the sweet smell of victory over Windoz..........

I turned off the indexing service, looked at the search service again and found the it was on automatic but not started - guess I didn't look hard enough before.
when i tried to start it it gave me error 2147218174.
a quick google revealed that i needed to reindex (which i didn't do yet).
I did and it populated the columns and search started working
interestingly - it did not find the first word i entered.
when it found the 2nd & 3rd, I went back to the 1st and it found it this time.
obviously it has to be indexed to find a word.

I'm wondering what causes the need to reindex?

thx for ur guidance......again
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#14
Glad you got it worked out...
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.