Win 7 x64 - BSOD - win32k.sys

#1
Hello everyone :)

Specs:
- build 7057, x64
- 4 GB ram
- Intel Core 2 Duo E8400 (3.00 Ghz)
- Nvidia GeForce 8800 GT (running latest drivers - GeForce/ION Driver Release 185 )
- No OC'ing
- No custom drivers

Problem:
My computer goes BSOD randomly. The most common reason is whenever I exit Neverwinter Nights 2. That gives me a BSOD every single time - no exception. I choose exit from the menu, the screen goes black (game shutting down) - and it returns the BSOD. The BSOD mostly refere to the file win32k.sys (C:\windows\system32\win32k.sys), and is most often returning the bug check code VISTA_DRIVER_FAULT. I have investigated the .DMP files, produced by the crash, and they ALL give me the BUGCHECK string of 0x3B.

I have tried:

I tried to google this problem, attacking it from any possible angle, but none of the results matched my story - the closest was a guy with busted RAM - but i just checked mine 20 minutes ago with MemTest86+, from a Hirens Boot CD - they passed (as expected). I even tried renaming the file, though I was positive that it would render my system unbootable - it did :D.

From the dump files:
Below I have included some of the things that I see in all the dump files:
(as they might give someone here a general idea or direction to go, without having to open the entire dmp file as I did)

BugCheck 3B, {c0000005, fffff9600012661f, fffff88008f82090, 0}
SYSTEM_SERVICE_EXCEPTION (3b)
An exception happened while executing a system service routine.
Arguments:
Arg1: 00000000c0000005, Exception code that caused the bugcheck
Arg2: fffff9600012661f, Address of the exception record for the exception that caused the bugcheck
Arg3: fffff88008f82090, Address of the context record for the exception that caused the bugcheck
Arg4: 0000000000000000, zero.
MODULE_NAME: win32k

FAULTING_MODULE: fffff80002c13000 nt

DEBUG_FLR_IMAGE_TIMESTAMP: 49b0e320

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

FAULTING_IP:
win32k!xxxRequestOutOfFullScreenMode+6b (that is ALWAYS listed! Weird)
fffff960`0012661f 488b8858020000 mov rcx,qword ptr [rax+258h]
SYMBOL_NAME: win32k!xxxRequestOutOfFullScreenMode+6b

FOLLOWUP_NAME: MachineOwner

IMAGE_NAME: win32k.sys

STACK_COMMAND: .cxr 0xfffff88008f82090 ; kb

BUCKET_ID: WRONG_SYMBOLS

Followup: MachineOwner
Attached 14 dump files.
If anyone would look at these, or if anyone has suggestions, I would LOVE to hear about it!

Any help is really appreciated! I am really out of options

Kind Regards
TwinA

I know that RC1 is released, but I do now wish to format before RTM is released! Formatting is not an option.
 


Last edited:
#2
Thanks to those who looked, and thanks to those who downloaded the dumps..

I found the issue though!
- I updated my audio driver, and disabled Outpost Firewall (from Agnitum). Though it is a world class firewall, its still beta for Win7, and its rather intrusive regarding protection - so disabling it while gaming did it :)

Thread can be locked.
 


#3
thanks for posting your solution! It's very usefull for me!
I spent all night looking for solution!
by the way have you got any way to keep outpost working during videogames session?
 


#4
OK, i've got a workaround for that:

Thank you for your message.
Please, try to rename the driver specified below temporarily in order to find possible reasons of the problem.
Use the following
instruction:
1. Load Windows in Safe mode.
2. Find the following file: sandbox64.sys (usually, it can be found in the following folder:
C:\Windows\system32\drivers\). If you are
using Windows Search, make sure you ticked option to search in hidden and system folder as well.
3. Rename it to sandbox64.sys.tmp
4. Reboot your computer in Normal mode, ignore “unable to load driverâ€Â￾ error and check, whether this problem
would re-occur with modified
configuration.
Please, tell us about the results.
this is part of an email sent by agnitum support center to an user who was experiensing the same bug. It's work for a couple of users and me too.

Waiting for a new outpost's release fully working on 7. :D
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.