Win10 upgrade from 7 quits during updating phase

Garykf16

New Member
Hi all. I'm trying to install 10 to replace 7 Pro on my Dell laptop, and having trouble with getting past the 2nd stage of the process. Problem I'm having is the install dies shortly after the first reboot at about 15% into the blue screen where it's downloading updates.

I have temporarily uninstalled my antivirus and VPN, lest they get in the way. I ran Windows Updates in 7 and got them all installed first. Next downloaded Windows 10 with Media Creation Tool, and created a bootable flash drive. Fine so far.
Booted from the flash drive, install goes all the way through fine. PC restarts, Win10 logo appears, then updates start downloading on a blue page. Here comes the problem - at about 15%, PC reboots with a message "we're restoring your computer back to the previous state" (I forget the exact words). All changes are dumped, the install fails and Win 10 does not get installed, right back in 7 where I started.

I have run sfc /scannow, tried DISM to no avail. DISM commands give me an error 87. Don't know what is causing the installer to hang during the updating phase. I'm stuck, can't figure out how to get past this problem. How do I proceed?
 

Neemobeer

Windows Forum Team
Staff member
Unfortunately there wasn't a ton of info in that log. The drive letters get logically assigned so there may be a more detailed log on the drive in the system, but it may have a different drive letter.

The only error listed in the uploaded logs was the following

2019-09-25 13:13:47, Info MOUPG Finalize: Remapping install error [0x8007001F] -> [0xC1900108] for telemetry.
and
2019-09-25 13:13:51, Info MOUPG CSetupUIManager: Rollback Error [0x8007001F] - Showing rollback message

with the same error code

ERROR_GEN_FAILURE
31 (0x1F)
A device attached to the system is not functioning.

Any hardware is considered a device, but typically these occur with regards to hard drives.
  • I would test the health of the internal disk as well as the media you're installing from
  • If you have any other drives or media cards (SD) I would remove them as they can halt the upgrade process
 

Garykf16

New Member
Thanks for your analysis and help. I'm going to try a different approach. I stepped back a version and direct-downloaded the Win 10 1803 ISO. I'll create a bootable USB using Rufus, and run a clean install. Just have to back up and reinstall programs, not as easy but doable. My 7 Pro is an OEM license. From what I'm seeing this should allow me to register with that key.
 

Garykf16

New Member
Got Windows 10 successfully installed today. Turns out you need to perform this as a clean install rather than an upgrade. Seems this was my problem earlier.

I downloaded an ISO of 1803 here (you can get whatever version you need)

I wanted to avoid using the media creation tool.
Next I downloaded Rufus and used it to create a bootable USB Drive. One note here, you need to select use MBR partition scheme to enable UEFI. It isn't set by default. Takes about 5 mins to create the install on the drive

Reboot, set BIOS to boot from the drive, and install begins. A USB 2.0 port must be used, not sure exactly why. But it worked as stated

Windows 10 Pro install onto my Samsung 970 Pro NVME 512GB drive is wicked fast, less than 10 mins total. Restart, resetting boot order in BIOS, done. Now time to activate Windows 10 with my Windows 7 Pro OEM product key. It was valid and activated online no problems

All I need to do now is reinstall programs, drivers (I keep a folder of basic system and peripheral drivers so I don't need to hunt them down all over) and any updates, since I used 1803.
I would have stayed with 7, but since support has been shut down, time to move forward.
 
Top