Win7 64bit USB Issues

LyleC

New Member
#1
After updating my HP a6500f desktop to Windows 7 Home Premium I am experiencing the following issue:

Any of my 3 brands of External USB drives disconnect in 64 bit Windows 7 OS when transferring large files to USB from internal drive. After they disconnect "Unknown device" shows up in device manager. USB drives are then unreadable. Once computer is rebooted, the drives are recognized again and will remain in that state until large amounts of data are sent to one of them. This problem occurs on any USB port that I connect to, and with any of the ext. HDD I use.

HP has told me that I should not have upgraded my desktop to windows 7...go figure! Microsoft has told me to contact HP.

My system information is as follows:

HP a6500f Desktop Upgraded from Vista 64 to Windows 7 64 using custom install
Processor: Pentium E2220 (C) 2.4 GHz (65W)
Nvidia Geforce 7100/630i chipset (these drivers have been updated to the Win7 drivers from Nvidia website)
Motherboard: Napa-GL8E (bios updated to current)
4gb ram
Geforce 7100 Video
WD 320GB External HDD
Seagate Free Agent 500gb External HDD

If anyone has any suggestions or work around let me know. Thanks

LyleC
 


#2
I do not know the answer I get a Unknown :confused:device under USB also but it does not seem to effect my file transfers so far I just transfered 73 gig to make sure. I did however disable the unknown device in device manager, maybe that will help. Do not delete it as it just re-installs on the next re-start or re-boot
 


LyleC

New Member
#3
Super Sarge

Thanks for the info. I will most certainly give this a shot. If my machine would transfer 1/4 of what you are transferring I would be happy. Its about 2gb for me and the ext hdd disconnects.
 


#4
Hi LyleC, this issue can be temporarily solved by "cutting" a piece of your RAM waiting for a nforce 5XX and 6XX series chipsets driver patch for win 7 64 bit.
You can choose if to use all of your 4 GB RAM but no USB ports or 3.25 GB RAM and full USB ports.

From an elevated command prompt (right click on the command prompt shortcut, run as administrator):
1) Type "bcdedit /set truncatememory "VALUE" (no quotes) explained below
2) Reboot
3) Go to control panel -> System and Security -> view amount of RAM and processor speed.
- It should report 4GB (2GB available)

To undo this, open an elevated command prompt again:
1) Type "bcdedit /deletevalue truncatememory" (no quotes)
2) Reboot
3) Go to control panel -> System and Security -> view amount of RAM and processor speed.
- It should report 4GB.

Here is explained how to calculate the "VALUE"

  1. Calculate your amount of memory in bytes in hexadecimal and substract 1 . You can use google to do the calculations or use scientific calculator. If you have 8GB like me just type in google (without quotes) "8 * 1024^3 - 1 in hexadecimal" and the result will be 0x1FFFFFFFF . For 6GB it is 0x17FFFFFFF and for 4GB it is 0xFFFFFFFF .
  2. Type "bcdedit /set truncatememory 0x1FFFFFFFF " (no quotes) in an elevated command prompt if you have 8GB, or use the other hexadecimal numbers for other amounts of RAM.
  3. Reboot
  4. You will have, depending on the number used in step 2, either 7GB or 5GB or 3GB available, but the problem is solved.
 


LyleC

New Member
#5
Bernie,

Thanks, I have already made these changes and my system is running great. Hopefully there will be a patch here soon.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top