Windows 7 compatibility issues with certain software?

Discussion in 'Windows 7 Help and Support' started by painofloss, Jan 22, 2010.

  1. painofloss

    painofloss New Member

    Jan 22, 2010
    Likes Received:
    Hello all, this is my first post and my first time using Windows 7. My fiancee and I just bought a Toshiba Satellite L455D-S5976 laptop and it came with the new OS. I've been having a few compatibility issues with certain programs that I use on a daily basis, some that will not install and others that will not work, once installed.

    My biggest problem, so far, is with Yahoo! Messenger. The installer will complete about 75% of the installation, then close with an error. I've tried several times but it's always the same result.

    Also, I've not been able to download or install Mozilla Firefox, which is bad because I'm a habitual Firefox user and I feel like I'm missing a piece of my soul. A handful of errors appeared, a "file corrupt" error, in particular. Every time I attempt to run the installer, it won't even start.

    Another, with a game, Diablo II. I checked the Blizzard forums and found results of a "known compatibility issue" between Diablo II and Windows 7 but I got that one cleared up.

    Basically, I'm just having a little bit of a hard time getting the simple every day programs (ie. Yahoo! Mess., etc) to install properly. Again, my computer is 1 day old so I see no problem why this problem cannot be resolved. Is there a new service pack or patch I might need to get?

    I've updated via Microsoft Update to the furthest extent, incl. priority and reccommended updates.
    Any insight on the subject matter would be GREATLY appreciated.

    Sic vis pacem parabellum,
    Patron Saint Of Pain ~;{@
  2. Trouble

    Trouble Noob Whisperer

    Nov 30, 2009
    Likes Received:
    Just a thought but I noticed that your laptop comes with Nortons Internet Security Suite, preinstalled. It shouldn't be causing the problems you are experienceing but perhaps uninstalling and maybe going with something a little more user friendly like Microsoft Security Essentials. It would seem that either your download of the programs install is being corrupted or the actual install is being inhibited by something. Like I said, just a thought.
  3. busydog

    busydog New Member

    Feb 11, 2009
    Likes Received:
    You probably have one of two things....

    A corrupt installation or something loading at startup that is causing you problems.

    For #1, type "sfc /scannow" from an elevated command prompt and see if you have any corrupt system files. You may have to insert your system disk.

    For #2, type "msconfig" from a command prompt and disable all programs and non-Microsoft Processes running at startup. If you can download/install OK, add the programs back a few at a time until you find the culprit. Toshiba (as does others) install a bunch of crapware because they get a kick back from the vendors. One of these maybe giving you fits.

Share This Page