Windows 7 Wireless is not currently enabled

#1
I'm trying to help repair a computers wireless connectivity for Windows 7. I keep getting an error saying Wireless is not currently enabled. I tried going to the services.msc and enabling stuff based on a guide I found online for fixing the issues but it doesn't resolve problem. I have never used Windows 7 so not sure what steps to take from here.

The computer is a Compaq laptop CQ56. I don't know the ending model number but can provide that later if needed. When connected to wired connection the internet works just fine. It use to connect to the internet just fine and didn't start having errors until someone else used PC so not exactly sure if they accidentally change settings or something.

Thanks, for your help!
 


helpifIcan

Fantastic Member
#2
I know this may be to simplistic, but most laptops have a button that turns the wifi on and off. It usually is on by default when the laptop it is shipped to you. Some people do not realize that it exsists and somtimes inadvertenly turn it off. If you already tried this I'm sorry to waste your time, just trying to help.
 


#3
I tried the stuff you mentioned and the wireless was turned on both on the software side as well as the wireless button being illuminated on keyboard. I tried uninstalling and reinstalling drivers and that didn't fix the problem either. Other suggestions are welcomed.
I know this may be to simplistic, but most laptops have a button that turns the wifi on and off. It usually is on by default when the laptop it is shipped to you. Some people do not realize that it exsists and somtimes inadvertenly turn it off. If you already tried this I'm sorry to waste your time, just trying to help.
 


Twinnii

Well-Known Member
#4
Please go to Control panel and "View network status and tasks" and select "Change adapter settings" and make sure the wireless connection isn't disabled or gray. If not, right click and go to Properties and select Internet Protocol version 4(TCP\IP0 assuming you're not using IPv6 and choose properties. Please tell us that information so we know it matches a typical setup.
To determine set up is in the ballpark, you can connect the laptop to wired network and go to start, type in cmd in search box and type ipconfig /all to view ip address settings then compare to wireless settings. You can do the same for wireless if it's enabled, but we need to know if this is even enabled or pulling an ip address. I have witnessed winsock problems due to corruption or malware.
 


#5
It doesn't appear to be disabled and it is not greyed out just has red "X" next too it. Went to the properties and it doesn't show anything for IP address it has the option selected for "obtain ip address automatically.
Please go to Control panel and "View network status and tasks" and select "Change adapter settings" and make sure the wireless connection isn't disabled or gray. If not, right click and go to Properties and select Internet Protocol version 4(TCP\IP0 assuming you're not using IPv6 and choose properties. Please tell us that information so we know it matches a typical setup.
To determine set up is in the ballpark, you can connect the laptop to wired network and go to start, type in cmd in search box and type ipconfig /all to view ip address settings then compare to wireless settings. You can do the same for wireless if it's enabled, but we need to know if this is even enabled or pulling an ip address. I have witnessed winsock problems due to corruption or malware.
 


#6
By the way I checked properties without wired connection in other words I checked it for wireless. If needed I can connect it via hard wire to get ip address.
It doesn't appear to be disabled and it is not greyed out just has red "X" next too it. Went to the properties and it doesn't show anything for IP address it has the option selected for "obtain ip address automatically.
 


Twinnii

Well-Known Member
#7
Ok, is there some type of software that is associated with the wireless device? It's usually found by the clock or in all programs. See if you can open something up to determine if you can even view the SSID being broadcast.
If you select manage wireless connections by the location I directed you above, Select add and create the info manually and let me know what happens then.
 


#8
Do you mean add ip address information manually for ipv4?
Ok, is there some type of software that is associated with the wireless device? It's usually found by the clock or in all programs. See if you can open something up to determine if you can even view the SSID being broadcast.
If you select manage wireless connections by the location I directed you above, Select add and create the info manually and let me know what happens then.
 


Twinnii

Well-Known Member
#9
Please go to Control panel and "View network status and tasks" and select manage wireless networks"
Here you will select Add and follow the wizard of manually setting up the wireless card.
After you input the wireless network info into the fields, the red x should go away and it should supply you with some sort of ip address.

The next suggestion would've been to manually put in your ip address. What I'm saying, the red x means that there is no wireless network associated with this device so it doesn't know what to do, but you have to set one up for it to work.
 


#10
When I go to "view network status and tasks" it doesn't show an option for "manage wireless networks". The only options I have are:

"setup a new connection or network"
"connect to a network"
"Choose Homegroup and sharing options"
"Troubleshoot Problems"
"Change advance Sharing Settings"
"Change Adapter Settings"

Please go to Control panel and "View network status and tasks" and select manage wireless networks"
Here you will select Add and follow the wizard of manually setting up the wireless card.
After you input the wireless network info into the fields, the red x should go away and it should supply you with some sort of ip address.

The next suggestion would've been to manually put in your ip address. What I'm saying, the red x means that there is no wireless network associated with this device so it doesn't know what to do, but you have to set one up for it to work.
 


Twinnii

Well-Known Member
#11
Ok, so right click on Computer and select Properties. Device manager and open Network Adapters by pressing + sign. What does the wireless card say there and is there an exclamation mark or something next to it.
 


#12
It says:

"Realtek RTL8191SE 802.11b/g/n adapter"
"Realtek PCIe FE Family Controller"
"PdaNet Broadband Adapter"

It doesn't have any exclamation marks or errors shown.

Ok, so right click on Computer and select Properties. Device manager and open Network Adapters by pressing + sign. What does the wireless card say there and is there an exclamation mark or something next to it.
 


Twinnii

Well-Known Member
#15
Did it install correctly?
Go to Start and select All programs and look for Realtek folder or program and start it up. Take screenshot if you can.
 


#16
When I search for realtek it only shows "Realtek HD Audio Manager". I looked for the folder also but doesn't show a realtek folder available. The only other thing it shows is the file I downloaded from website link you sent me.

Did it install correctly?
Go to Start and select All programs and look for Realtek folder or program and start it up. Take screenshot if you can.
 


Twinnii

Well-Known Member
#17
Did you go to the folder C:\SWSetup\SP49542 and run setup.exe?
 


Twinnii

Well-Known Member
#19
Create a new user and see if the wireless program launches and make sure you restart computer.
 


helpifIcan

Fantastic Member
#20
It seems you have tried everything on the software/driver side, maybe the wireless card is just bad. If you have or know someone that has a wireless USB dongle you could try that it will at least show that you can connect wireless with the PC.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top