Windows 7 XP wirelss connection problems

#1
Windows 7 XP wirelss connection problems [SOLVED - sort of]

I have a 3 PC network (no WEP or WPA security) attached to a Thomson 760W wireless router with the latest Firmware (6.3.27.2)
2 PCs (Angua and Carrot - dont ask!!) run XP SP3 (all latest updates); 1 PC runs Windows 7 Ultimate (all latest updates)
There are no active firewalls
When all PCs have a wired ethernet connection to the network, everything (shares etc) works fine
When the W7 PC is connected to the network wirelessly
W7 can access the shares on Carrot
cannot access the shares on Angua (). I suspect it cannot even see Angua and the reference is there from an earlier wired connection
cannot access a network drive that points to a share on Angua
Angua can access the shares on W7

A 4th PC running XP SP3 (not a normal part of the network) connected wirelessly can access Angua and can be accessed by Angua and the W7.

W7 can ping Angua and the 4th PC (time=1ms)
And Angua can ping the W7

I have the same items showing under the Wireless network Connection properties on both Angua and Carrot. They are
Client for MS Networks
File and Printer sharing
QoS packet scheduler
TCP/IP

Under Network Connction details everything seems to be OK. There is an IP address and NetBIOS over TCPIP says Yes
The Troubleshooter (Shared Folders) quite unhelpfully said 'Couldn't identify the problem' and under details "no issues detected" but attempts to access a share in explorere are met with \\Angua\folder is not accessible. You might not have permissions etc etc"
(When hooked up wired W7 reports the permissions on the shared folder as everyone)

So it seems that is is something to do with the combination of settings on W7 and Angua
So please, what do I have to do to get the wireless component of this network working remembering that
1. it works wired and not wirelessly
2. it works on two XP machines but not on a third.
 


Last edited:
#2
In desperation, I tried replacing the router (i had an old 3com router lying around) and the problem went away. So I guess it was a router issue but whether it was a router settings issue or a more basic fault, I guess we will never know
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.