Windows 8 image backup fails-"Backup engine could not be contacted"

Saltgrass

Excellent Member
Microsoft Community Contributor
#1
Since Microsoft is removing the Backup utility from Windows 8.1, I have been exploring alternatives to that very useful utility. I know there are third party utilities that will work fine, but I would rather stay with a native version, if possible.

It seems the utility WBADMIN is capable of creating a backup image just as the Backup utility did. So I started to experiment and found some interesting things.

First, the command to start the backup, which will work in the Administrative version of a Command Prompt or PowerShell.

WBADMIN START BACKUP -backupTarget:f: -allCritical

With f in my case being the target drive to store the backup image. There are additional flags for including other partitions.

But when I tried it on my Windows 8 to 8.1 upgraded system, it would not work. On another system with the 8 to 8.1 upgrade, it also failed giving me the message:

The Windows Backup engine could not be contacted. Retry the operation.
The remote procedure call failed.
So I reinstalled Windows 8 to test and it worked, for one day, and then started to fail again. So after much research and testing, I found I needed to go into the Hidden System Folder, System Volume Information, and remove the WindowsImageBackup directory.

I don't recommend anyone else do this unless they have taken precautions in case of problems. But to remove the directory, I had to boot to the Install media and select Repair your computer. Using the Command prompt option and dir /a to find the folder and directory. Then using rmdir WindowsImageBackup /s I was able to remove it.

Both of my systems are now completing the backup process..

I do not know for sure what caused the problem, but I believe the directory had some confusing or corrupted information, possibly because of multiple OS installs on different hard drives and confusion over target drive locations which had been tried.

Another interesting item that came up, is the situation with the Recovery partition. As you can see from the message below, the Recovery partition is not included in the image by default. The reason is the 8 to 8.1 update install no longer uses it since the Recovery image has been moved to the C: partition. It will be interesting to see how the imaging software, native or third party, will handle an image recovery and what it does with the 300MB of space not included in the image by default. If you have a Legacy (MBR) install, it will still be included because of the combined Boot/Recovery partition.

Retrieving volume information...
This will back up (EFI System Partition),Windows 8(C: ) to f:.
Thanks for reading....
 


Last edited by a moderator:

Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Since the real 8.1 is gone public, I have confirmed the problem with creating a System Image using the Windows utility. 8.1 went back to putting the Recovery files in the Recovery partition, which 8 did not. Because of that, on some UEFI installs with the 300 MB Recovery partition, the Winre.wim file will be too large to allow Shadow Copies to be made and throw that error.

The solutions are to use a third party software, or increase the size of the recovery partition by 50 MB to 350 MB, as it is in the Legacy installs. Changing the partition size is always dangerous, so be aware of the risks. Do not make the partition larger than 350 MB or recovering an image will cause another Recovery partition to be created on the system and the larger one ignored.

If you already have an image, you should be able to recover it fine, although I am not completely certain about the ability of a Recovery Drive to do so.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#3
The situation with the Recovery Partition and Shadow copies seems to be growing since the public release. It does appear Microsoft is doing something to alleviate the situation. Below is my Disk Management window after a Store Update from 8 to 8.1. Even though I had already added space in the Recovery partition for the increased size of the Winre.wim file, the upgrade added another partition anyway... probably just ignored the original one.
 


Attachments

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.