Windows Explorer

Fjelljeger

New Member
Hello.

Why do the same disks appear in the Windows Explorer twice and how do I fix this?
See the picture.

Fjelljegeren
 

Attachments

  • Diskene vises 2 ganger i utforskeren.jpg
    Diskene vises 2 ganger i utforskeren.jpg
    316.3 KB · Views: 50
Last edited:

GDany

Well-Known Member
I have the same problem, for years now, and I couldn't find a solution. It looks like the system sees them both as internal disks and external (usb) disks. I got used to it, but I also would be interested to know if it is possible to change this behavior.

Sent from my SM-N975F using Tapatalk
 

davehc

Essential Member
Premium Supporter
Download this reg fix. Unzip and run. There is also a reg file to reverse the procedure, if you feel like it.
 

Attachments

  • remove-duplicate-drives.zip
    670 bytes · Views: 24

davehc

Essential Member
Premium Supporter
I should have mentioned. A reg fix always neeðs a reboot or log out, in order to read the alteration. Also, a word od caution. Windows major updates often include a new registry. Keep the fix handy!,
 

samK

Member
1. Press WIN+R keys together to open RUN dialog box. You can also open it from WIN+X menu. Now type regedit in RUN dialog box and press Enter. It'll open Registry Editor.

2. Now go to following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\DelegateFolders

3. Under "DelegateFolders" key, you'll find {F5FB2C77-0E2F-4A16-A381-3E560C68BC83} key.
4. Now delete the {F5FB2C77-0E2F-4A16-A381-3E560C68BC83} key and it'll immediately remove the duplicate drive icons from This PC's Navigation Pane.

Now you'll no longer see any drive icon twice in the Navigation Pane of This PC.

NOTE: If you are using 64-bit edition of Windows 10, you may notice that the drive icon is still present in "Browse" dialog box such as Save, Save as or Open in some 3rd party 32-bit programs. To remove the duplicate drive icon from there, you'll need to perform the same steps in following key as well:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\DelegateFolders

Under "DelegateFolders" key, delete {F5FB2C77-0E2F-4A16-A381-3E560C68BC83} key.
 
Top