WMP12 hangs when I choose Close Captions at DVD Playback

#1
I am using a Dell Dimension 3100 with an Intel Pentium 4 2.8 GHz with 2GB RAM. Also, I am running Windows 7. I am currently using WMP 12 to play DVDs and AnyDVD to help Iplay DVDs I buy when travelling. Recently, in England, I just bought a Star Trek: First Contact DVD.

When I put it in my computer, for some reason, I tried to put close captions. I didn't know it was there to begin with, so I tried to see what it was like. Then that's where the bad news starts: the computer hangs. It is not responsive when I move the mouse, it just freezes. I had to try it many times to realise that was the problem. Other than that WMP12 is working fine.

I have no problem against using it despite the problem, but I would like to know why it is like that. Can it be that the Dell hardware is getting old (i.e. it's 10 years old coming 2016), or is it a software problem? There was no blue screen error so I cannot determine what the error type is; I'm sorry.

Also, on occassion, when I try to resize the window, it hangs as well. Again, no blue screen error, just a freeze. The computer/Windows 7 doesn't even have the courtesy to tell me what the error is!


If you have the time, please look up where the problem is and I will be very grateful.
 


#2
I changed the drivers.

My computer 's graphics capability was embedded on the motherboard, in this case, 82915G.

I went to the Intel website, not the Dell one, and downloaded the version 6.14.10.4670 and everything was done like dinner.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.