Windows 7 2 Monitor Panoramas Not working


Active Member
I have a 2 monitor system and I'd like to put a panorama from a game across the two monitors.
I looked it up on the web found that I could build a double size image - 3840x1200 in my case - and the Tile it across the two monitors. So I made a test image and it worked. But since my primary monitor is on the right, the halves were reversed. Not to worry. I can reverse the halves of the image that I'd like to use.

So, I went off using hugin and gimp and made an image from the game with the halves reversed and made it precisely 3840x1200.. And when I applied it, it failed.
It tiled up and down on each monitor instead of across the two monitors. And if I go back to the original test image, it still doesn't work. Recall that it worked the first time flawlessly. The halves were reversed but I expected that. So it worked the first time, but try as I might, I can't get either the new or old image to work now.

It is almost as if Clippy is in the back ground saying - "Oh.. I see you are tiling, you must want this rather than that." and changed how tiling works for desk top images.

Where are the rest of the settings so that I can make this work?
Did something get flipped in the registry?
Sure would like to be able to tile a single image across my 2 monitors.

Maybe someone makes a screensaver that just does this right? Now there's a thought...

PS - here's the image I'm trying - the non-reversed version.

Last edited:


Senior Member
I don't know if you got this fixed already but I'm going to try to help anyway.

Right-click anywhere in your desktop and select "Screen Resolution" (See pic below):


Click "Identify" (marked 1) and big numbers will pop-up on your screen. Make sure that 1 is on the left and 2 is on the right. If this is reversed, your wallpaper will appear reversed as well. If the numbers are not in the right order, just drag and drop the monitor icon to the proper location to match screens 1 & 2.

Then highlight the right screen as shown in above photo (the one that you want to make a primary screen) by clicking on it once and then check the "Make this my main display (marked 3). Click "Apply" and "OK" and it should fix the problem.