64bit Only recognises 3.2 out of 8 Gig RAM

#1
Hi I have recently installed the 64 Bit version of Windows 7, I have 8Gigs of RAM but the system is only using 3.2 of it whilst it can see it all. I thought the 64 Bit version could use it all. Can anyone help or shed any light on this matter.
Cheers a lot.
PS please see attachment.
 


Last edited:
#2
Btw there is no attachment. Also dosent windows have ram programs. Like i have 3gb and windows uses only 2gbs.
 


#3
Hi I have recently installed the 64 Bit version of Windows 7, I have 8Gigs of RAM but the system is only using 3.2 of it whilst it can see it all. I thought the 64 Bit version could use it all. Can anyone help or shed any light on this matter.
Cheers a lot.
PS please see attachment.
The RAM is obviously defective. Go ahead and send it to me and I'll send it back when I'm finished repairing it ;)

On a more serious note, there's no attachment.
 


#4
Hi Sorry about that it didn't attach here goes again.
JJ
 


#5
Btw there is no attachment. Also dosent windows have ram programs. Like i have 3gb and windows uses only 2gbs.
Yeah sorry about that tried to upload a docx and it didn't like it I have put up a doc now. I'm sorry to sound dum but what did you mean by windows having RAM programs?
Cheers
jj
 


#6
Very Interesting

Have you by chance used Vista or XP X64? Did they see your memory? Sounds like you may need to get a BIOS Update or at least check your BIOS Settings.
 


dam89

Honorable Member
#7
Check your bios
 


#8
You have to remember that 64-bit DOES in fact use all the ram but Windows distributes it amongst all your hardware.. Things such as Video Cards, Sound Cards, etc... Check you BIOS to make sure it is in fact detecting it all.. If it is than you should be fine, if it isn't than you may have defective ram on your hands.. ;)
 


#9
Long shot, and I don't see why'd it'd be limited as such.. But go Windows+R and go into 'msconfig', go to the boot tab, advanced options, and make sure 'maximum memory' IS NOT ticked. If it is, and it happens to be set on 3200 mbs or whatever, then theres your answer.. Only Idea I can think of.. Probably wrong, it's prob the BIOS like the others said but hey can't hurt to try :p
 


#10
Hi, OK I've done everything you all sugested. In the BIOS the RAM is recognised correctly. The MB is an Asrock P43Twins1600 and yes it does support 8Gigs look here ASRock > Products > P43Twins1600 If there was a problem with the RAM then surely the system wouldn't boot or they wouldn't be recognised. Had a look at the advanced settings under the Boot tab of msconfig and the limit memory box is not ticked. I am not sure what to do next. Please see yet ScreenPrint that proves the system can see the whole 8 Gig.
Cheers
JJ
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.