Access Denied C:\

Discussion in 'Windows 7 Help and Support' started by Scrueball, May 25, 2009.

  1. Scrueball

    Scrueball New Member

    Joined:
    May 25, 2009
    Messages:
    6
    Likes Received:
    0
    Hi,

    I've seen other similar threads which have been resolved but my problem differs slightly.

    The problem started when I was trying to share files with an XP machine, however I'm not sure what the exact cause was.

    What changed before the problem:

    I played around in HomeGroup and advanced sharing and permissions tab of the C: drive.
    Neither machine could see the other one in the network until I tried the \\COMPUTERNAME command on the xp machine. A user account window appeared so I typed in the name and password of the account on the win7 machine. Which is the admin and only account on there. It gave me access but the C: drive was denied access.
    This is when I noticed I was unable to access it on the win7 machine too so I'm not sure which of these caused it. However I still have access to the documents/user files.

    Problem:

    The C:\ drive shows 0bytes and the folder appears to have an icon showing 2 people in the bottom left corner. Since access to C:\ is denied, i'm unable to run a lot of things:

    Nothing runs as admin and I cant access any user account settings in control panel that require administrator rights.
    Regedit wont run.
    System Restore doesn't show any restore points.
    The only way I can access command prompt as admin is rebooting in safe mode, even then the "takeown" command still results in access denied.
    Trying to edit the registry in safe mode cmd prompt shows access denied too.
    I'm unable to click the advanced sharing options of C:\
    When right clicking C:\ then going to security/advanced sharing/owner, it says "unable to display current owner" and even though the account shows in the change owner tab, clicking it doesn't do anything.

    The solutions i've tried so far are the Takeown /f command, something like "net user administrator activate:yes", and trying to disable user account checks via cmd prompt registry edit. No luck so far.

    Anyone had this and found a solution?

    Thanks
     
  2. deadon2

    deadon2 New Member

    Joined:
    May 26, 2009
    Messages:
    6
    Likes Received:
    0
    Wow, I've got the same problem(s). I was running Win7(64) for a few days with no problems whatsoever, and then the system went haywire after a WinWord 2003 install. I can't access any drives, and the software uninstall feature is disabled. Logging into safe mode does no good. Like you, I was trying to share files to an XP on the network prior to the install. I initially thought it was WinWord's fault, but after reading your post, maybe it was because of trying to set up the network.

    Unless someone comes up with a fix, I'm probably going to wipe the HDD and start over with a clean install tonight. I'll do some troubleshooting with the software installs and networking to see if I can narrow down what caused this.

    Also, what AV or security suite are you running? I loaded AVG for 64 bit, and it's settings are locked out too.
     
    #2 deadon2, May 26, 2009
    Last edited: May 26, 2009
  3. maximus01701

    maximus01701 New Member

    Joined:
    May 27, 2009
    Messages:
    16
    Likes Received:
    2
    http://windows7forums.com/windows-7-support/6336-major-partition-hard-drive-problem.html#post29837

    i totally did not see this before posting that...

    But now that you mention it; l My brother was trying to access my
    second partition, when this happened.... (hes on XP)

    He said he was not able to access the drive, because of it being password protected, so i removed myself form
    a homegroup and disable the password protection on the drive.....

    Let me know if you come up with ANYTHING!!
     
  4. maximus01701

    maximus01701 New Member

    Joined:
    May 27, 2009
    Messages:
    16
    Likes Received:
    2
    Got it...

    Had to go in w/ safe mode, then for some odd reason i was able to re add the users/groups polices
    under the security tab......
     
  5. Scrueball

    Scrueball New Member

    Joined:
    May 25, 2009
    Messages:
    6
    Likes Received:
    0
    I'm running Avast and it's got the same problem because the files are located on C:\ therefore I cant get access to them.
    It looks like I'm gonna have to do a clean install too, glad I only installed win7 a week or 2 ago. Not much to lose and everything is backed up but still it's a pain in the arse.


    Awesome, thanks that seems to have worked! Still didn't give access to a few files when giving permissions, such as BOOT.ini and program files. It seems I dont gain permissions for them them, but i can access them. I'm assuming it just means I cant write to it. Means I can copy it to my external hard drive and back it up before wiping anything new and important! *unsure whether to give manhug*

    System restore also seems to be working now, hoping that it resets the user changes too, I'll edit the post with the results.

    Also apparently using your idea showed "Trustedinstaller" as the owner of C:\ instead of "unable to show owner", anybody know anything about what that is or means?

    Thanks again!

    Edit: System restore didn't give back full permissions but atleast I can access everything now.

    Also it now says the owner is:
    "Administrators(COMPUTERNAME\administrators)" yet the original user account that was admin doesn't count there apparently.
     
    #5 Scrueball, May 27, 2009
    Last edited: May 27, 2009
  6. deadon2

    deadon2 New Member

    Joined:
    May 26, 2009
    Messages:
    6
    Likes Received:
    0
    I couldn't access any security or networking commands in regular of safe mode Couldn't even run commands from the DOS command line. So I gave up and reinstalled. Running fine now. I'm gonna give it a day and try to set up the network again, and try to see where/when the bug comes up.

    Scrueball, after you partially fixed the prob, were you able to see drive volume on C? Or was it still showing 0?
     
  7. Scrueball

    Scrueball New Member

    Joined:
    May 25, 2009
    Messages:
    6
    Likes Received:
    0
    Bit late, but after going into safe mode then going into the sharing permissions tabs I was able to see the drive volume, still couldn't get administrative rights though. Just used it to copy the files to an external hard drive then format.
     
  8. maximus01701

    maximus01701 New Member

    Joined:
    May 27, 2009
    Messages:
    16
    Likes Received:
    2
    Well im not the sure it's the same for the both of us, and i hope but i hope it is... (that way it works).

    But when i was in windows, and went my comp>right click D> Properties i was NOT able to get to the SECURITY tab and add groups and users. But when i went into safe mode, THEN i did have the security tab and was able to add groups and users.

    It wasn't under the sharing..

    i hope i understood you correctly...
     
  9. StrikeR

    StrikeR New Member

    Joined:
    Jun 26, 2009
    Messages:
    2
    Likes Received:
    0
    i just had the same problem runing win 7 on my netbook, messing up with the sharin advance option and permission while trying to enter the c drive fomr my desktop...


    now.... im formating and instaling all again >.< i think that this is the best fix for that cos the netbook only have 3 day of use and i have an application to make a backup fo all the drivers installed on the pc...
     
  10. ruggb

    ruggb Honorable Member

    Joined:
    Jan 14, 2009
    Messages:
    510
    Likes Received:
    4
    Sounds a lot like the virus I had.
    Most AVs didn't detect it.
    It hosed up 3 of my drives, apparently by wiping a sector on the drive that tells the system what FS is present.
    (My take).

    The system boots just fine but files are not accessable. WE will show folder structure but can't access any files.
    Programs won't run because the files can't be found/read.
    Brute force recovery programs will eventually figure out what FS it is and recover the files.
    The virus file spreads all over the drives.
    Had to reinstall.
     
  11. zephyrgard

    zephyrgard New Member

    Joined:
    Oct 26, 2009
    Messages:
    10
    Likes Received:
    0
    Hmm... So it can be a Virus infection?? by the way was there anything downloaded to the computer??? Im just a new Windows 7 user just looking for issues that might arise
     

Share This Page

Loading...