Acer laptops DVD/CD drive help after win7 upgrade

#1
I have an Acer and since upgrading to Windows 7, the DVD drive is only there intermittently.

If I start the computer and go to 'Computer', the drive will be there. I double click and it will say 'Please insert a disc'.....no problem.
If I start the computer and put a disc straight in, nothing will happen. Double clicking the DVD drive results in 'you dont have permission to format this drive' error displayed. Then the DVD drive icon will disappear.

I've tried the fixes as per microsoft like altering the upper filters (reg entry not there) and also stopping the power management software via cmd prompt.

I'm out of ideas so wondered if anyone else had and suggestions for me.

Thanks in advance everyone........

PS I know there is a separate thread similar but it is for a specific model laptop.
 


Mitchell_A

Essential Member
#2
did you do a clean installation of Windows 7 or did you choose the "upgrade" option from Vista?
 


#3
Yes it was a clean install or 'custom install' as the disc called it.
I've tried everything I can think of an desperate for help here people!!
 


Mitchell_A

Essential Member
#4
Post the model of your Acer here (example: Aspire Time 4810)
I'll find some drivers for you.
 


#5
Thanks. Its an Acer 5410 Timeline.
Just want to say that it does not appear in device manager as an unknown device or anything when the icon disappears. Its like the drive is just not there until I restart again.
 


#7
Thanks mate, I will try this and let you know how I get on.
 


RAK

Extraordinary Member
#8
I presume this is with different disks? That's the message I get , and the same action, if I put a dead disk in. But try uninstalling the dvd drive in the Device manager, and rebooting. The OS will automatically reinstall it and, hopefully, reinstall with the correct drivers.
 


#9
Thanks RAK, Unfortunately the drive is not present in device manager for long enough to uninstall it.
I have tried other discs etc yes.
 


#10
Acer Aspire 4810 tz OD missing after hard button eject

I did a win 7 home premium upgrade on Vista. Ive got a similar problem, missing the DVD from the device list, but it reappears after reboot. It seems to me that the device get lost only when I eject with the hardbutton, not when I use the push put command in explorer? I cant find a specific driver update to solve this problem for the 4810 at Acer Europe. In other forums, users have been reporting missing dvd drives for other aspire models as well, running on XP and Vista - so perhaps ist a general weakness in Acers BIOS?

Does anyone know a fix?

Thanks a lot
 


#11
I will, then.. Thanks!
 


#12
Contacting Acer is the logical step I agree, but once you have spoken to Acer you will see why it is pointless.
They just told me to recovery the computer by ALT and F10 etc etc which of course will go back to Vista.

They told one other person that Windows 7 was 'not compatible' with the Acer 5410.
The problem you said about is exactly what I get Hendrix. It can work but if you use the eject button you need to restart.

I tried the drivers that were posted by Micthell_A (thanks for the help) however these did not solve the problem.
I have seen this happen on a Toshiba laptop now too which actually came with Windows 7. This one worked fine and then it just disappeared and shows Error 39 in device manager.

I'm still searching for a solution but if anyone has more info then please post it.
 


#13
Actually, Acer did suggest a workaround to my OD problem, the same workaround that is found in the Microsoft Answers win 7 forum. Which is to clean some upper and lower filters in a specified registry value. However, for those of us that dont like to diddle with regedit, Acer recently came up w an application that does the job. This application was not included on the Acer Win 7 upgrade disc. As melvinpd wrote in MS Answers:

go download OpticalDrive PM Application from the downloads part of the acer website for your version of windows 7, install, reboot, and voila. maybe the windows workers could have spent less time with their amazing new 3 features (OMG "SNAP" we are now out of the dark ages.....) and a little more time making things work right to begin with as advertised.

It worked for my Aspire 4810TZ at least
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.