Any way to unpin computer from start menu?


Essential Member
Premium Supporter
Follow this path:Users - Username - Appdata - Roaming - Microsoft - W#indows - Start Menu - Programs.
Delete the entry.

it's not there


Essential Member
Premium Supporter
OK. There is only one other path:
\ProgramData\Microsoft\Windows\Start Menu
Try that and delete there

nope,it's not there


Essential Member
Premium Supporter
We must sort this !!
One more try:
\Users\All Users\Microsoft\Windows\Start Menu

I have just looked at my first entry. I don't think this is the problem but, if the above path shows nothing, follow the first procedure again:
Right click the Start and then "Properties"
Under the tab "Start Menu" select customise.
and uncheck the recent items" entry

Last edited by a moderator:


Essential Member

I admire your persistence as I'm the same way. I hate to give up without finding a solution for the poster with a problem.

I hope you the best, but the only way I could figure it out was with some registry hacking. I dragged the Computer folder myself, but made sure I created a Restore point, just in case, then I finally found the solution by deleting some registry keys. I tried so many things in the registry, I don't even think I could duplicate my steps.

If you get this one, I'll up your rep by 3 points. (is that allowed?):D

Good luck!!


Essential Member
Premium Supporter
That's a kind thought. I don't mean rudeness, but I have little interest in the rep points. I think they can have a down side in their (mis(use).
Anyway. Back to the thread. I have emulated the Computer entry in several diferent ways, but have had no problem removing it again.
I think we are on the wrong track. I do not know the circumstances of the other posters here, but I run, always, as the global Administrator.
I started wondering, After the last post. I cannot undersstand the lack of information in the OP's right click drop down menu. I have a full menu, including delete -- and it is that simple!
Perhaps he should try and open the Adminaccount and do it from there. there are two or three ways, here is the simple mouse click method I use after install.
Run - Control UserPassowrds2
Advanced and Advanced again.
Users - Administrator
Untick "Account is disabled"

Back out (OK) from the windows. Log off and the entry is there for the user to logon as the Administrator.
There will be a short break as the OS needs to set up the basic desktop for the Admin.
Thats all, then try the right click procedures again.


At last Ive got it. You've been moving a lot of programs around!
Right click "computer" and drag it back to Accessories/System Tools, where it belongs.

Last edited by a moderator:


Honorable Member
i would have if it were that's my \"right click\" pic

Untitled-1.jpg -
What a shame.
Just one thought, did you install build7000 or upgrade from earlier versions?
Dunno if it makes any difference but it might trigger a thought with someone :)


Essential Member
I don't mean rudeness, but I have little interest in the rep points. I think they can have a down side in their (mis(use).
Yea, I hear that, some members even point out that fact. If I do earn points, I hope it's because I've helped the poster solve his/her problem.

I hope anykey comes back and tries your solution.


Honorable Member
I hope anykey comes back and tries your solution.
Hello reghakr, forgive me, I am a bit slow :redface:
What would you like me to try.
I actually do not have an problem with the item Computer listed top left of the Start Menu - it gives me the option to Unpin :cool:


Essential Member
Premium Supporter
Mistake anykey. The poster meant Ihavofrnds

ok i tried to look in many of the "start menu" folders under users...not sure if i hit all the right spots, but i didn't see references to "computer"

i tried the administrator account, but when i log onto that, the start menu's pretty much completely different with no "computer" pinned on.

not sure what's going on...but i appreciate the help.


Essential Member
Premium Supporter
And did you try dragging and dropping it back to its rightful place , as I suggedted in my prevous post? (Accesories\System tools)

that just creates a link.


Essential Member
Premium Supporter
I surrender!

found the solution!

How to add "Pin to Start menu" option for folders in Windows 7/Vista/XP

1. Click Start, Run and type regedit.exe
2. Navigate to the following location:
HKEY_CLASSES_ROOT \ Folder \ shellex \ ContextMenuHandlers
3. Create a sub-key named {a2a9545d-a0c2-42b4-9708-a0b2badd77c8}
4. Exit the Registry Editor.


Essential Member

Did you prove this fact by actually doing it yourself?

This does not work because Computer is not the same as a folder. I can drag any folder to the Start Menu and right-click and choose Unpin from Start Menu. You can't do this with the Computer entry.


Extraordinary Member
Premium Supporter
Terrific Solution that i as well am impressed with because it worked on all three of my computers. Well Done ihav0frnds!

And reghackr unfortunately i have to disagree with you. this can be done because computer is actually if you think about is as the root folder and not just any folder. You can attach anything to the start menu now and remove it happily.

Last edited:


Essential Member

Did you actually have a Computer entry in your start menu on all three machines? I mean listed above the All Programs entry, not the Computer entry that appears on the right-hand side of the Start menu? Sure it removed that entry, but that's not what this question pertained to.

I can't understand how creating a subkey without a values associated with it will work.

I double-checked the registry subkey exactly as described and it did not work.

I even restarted just to be sure.

I can't understand how it works, because if you noticed under the HKEY_CLASSES_ROOT\Folder\shellex\
ContextMenuHandlers, all entries have recognizable names and have a CLSID associated with the entry under the Default entry. This is the location where most items appear on the context menu when you right-click on a file, but that's determined by the type of program you right-click on.

Also if an entry is included under HKEY_CLASSES_ROOT\AllFileSystemObjects, they always appear on the context menu no matter what type of file you right-click on

This same entry is located under the HKEY_CLASSES_ROOT\shellex\ContextMenuHandlers and it's Default value is Start Menu Pin

Mine include:

Briefcase Menu
Glary Utilities
library location
Offline Files
Unlocker shell extension

What can I say, it simply didn't work on my machine.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.