Application Compatibility Toolkit sometimes works, sometimes doesn't

rlincolnh

Honorable Member
#1
I finally got sick of answering the pop-up "Do you want to allow this program from an unknown publisher to ..." which occurs for several programs that I use frequently, so I installed Application Compatibility Toolkit 5.6 and set the 'RunAsInvoker' option for those programs. As I configured each one, I used the 'Test Run' button and they all worked. After saving and installing the database I clicked on the first program in the Start menu, great, no popup. Then I tried the second program and damn, there's the popup again. Similarly with a couple more programs.
To cut a long frustrating story short, it turned out that the 'failing' program shortcuts on the start menu were set to 'Run as Administrator'. Note that this wasn't the Privilege Level checkbox on the Compatibility tab, but in the 'Advanced' dialog on the Shortcut tab. Clearing the 'Run as Administrator' box in that dialog fixed all my problems.
I guess that I must have set them in days past when trying to fix various compatibility issues (before I knew about ACT).

Hope this helps someone.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top