Booting from USB - Can't install on selected disk of the GPT partition style!

#1
Hi everyone, first time posting here,

I'm trying to reinstall windows on my dell xps 15 from USB, but when I go to choose a drive to install on, they are GPT and need to be MBR, according to my tech friend. However, I can't access command prompt to change this through bios, and my hard drive is totally wiped. So i'm kind of stuck!
Any replies appreciated!
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#2
Hi and welcome to the forum :up:
That's not necessarily true unless your bootdrive is larger than 2TB. If it is, yes the format should be GPT. If your bootdrive is 2TB or less than MBR is the preferred method. To access the Dell BIOS it's usually done by mashing the <F2> key on your keyboard during startup.

You can then use the <F12> key on startup to change your BOOT PREFERENCES ORDER to your USB device with W10 install on it. Where did you get that USB W10 install key from? Did you make it yourself or buy it?

In a normally working PC this will work. It would help to know the exact capacity of the hard drive you are attempting to install W10 on as well as the Make/Model too.

Good luck,:encouragement:
<<<BIGBEARJEDI>>>
 


#3
Hi and welcome to the forum :up:
That's not necessarily true unless your bootdrive is larger than 2TB. If it is, yes the format should be GPT. If your bootdrive is 2TB or less than MBR is the preferred method. To access the Dell BIOS it's usually done by mashing the <F2> key on your keyboard during startup.

You can then use the <F12> key on startup to change your BOOT PREFERENCES ORDER to your USB device with W10 install on it. Where did you get that USB W10 install key from? Did you make it yourself or buy it?

In a normally working PC this will work. It would help to know the exact capacity of the hard drive you are attempting to install W10 on as well as the Make/Model too.

Good luck,:encouragement:
<<<BIGBEARJEDI>>>
Thanks bigbearsjedi,
I don't know how big the specific bootdrive is, but my hard drive is 1tb and I also have a 32gb ssd on board.
I made the install key on a 4gb usb last night using the tool you can download on the windows website.
I'm still getting the can't install on GPT partition style message.
The model is the Dell xps 15 9530
:)
 


Neemobeer

Windows Forum Team
Staff member
#4
Make sure when creating the boot drive that you select UEFI/GPT if you are using rufus to create it. Also make sure when booting to the flash drive you also select UEFI (GPT) otherwise the boot drive will boot into the MBR installer and won't work.
 


#5
Make sure when creating the boot drive that you select UEFI/GPT if you are using rufus to create it. Also make sure when booting to the flash drive you also select UEFI (GPT) otherwise the boot drive will boot into the MBR installer and won't work.
So I shouldn't be using legacy. If I 'add boot option' in UEFI in BIOS, and select usb 2.0, it then asks me to 'select media file' and shows everything thats on the usb.
 


Attachments

Neemobeer

Windows Forum Team
Staff member
#6
Was this computer previously set to boot UEFI? You would know by when Windows loads you would see the manufacturer logo and the spinning dots versus WIndows logo and spinning dots
 


#7
Was this computer previously set to boot UEFI? You would know by when Windows loads you would see the manufacturer logo and the spinning dots versus WIndows logo and spinning dots
Yes i see the manufacturer logo and spinner dots. Thanks for your reply Neemobeer :) is it something wrong with my usb key perhaps? But now when it boots up to the install screen it shows the latter.
 


Neemobeer

Windows Forum Team
Staff member
#8
I believe you want to turn Secure boot back on. If you still get that media file menu select BOOTMGR.EFI
 


#9
Done and done! But now im making violations apparently!?
Excuse the reflection in the image.
 


Attachments

Neemobeer

Windows Forum Team
Staff member
#10
Go back into BIOS and locate "Clear Secure Boot Keys" and run that and try again.
 


#11
Go back into BIOS and locate "Clear Secure Boot Keys" and run that and try again.
Hey thanks for your reply! Tried that and it just ends up booting up with the windows logo, which as you said before indicates it not booting in uefi. Think I might be in for a trip to thw tech store!
 


Neemobeer

Windows Forum Team
Staff member
#12
Make sure secure boot is still enabled and make sure to select UEFI boot
 


#13
Make sure secure boot is still enabled and make sure to select UEFI boot
Still getting 'secure boot violation' message with secure boot enabled and eufi selected as 'boot list option'.
 


Neemobeer

Windows Forum Team
Staff member
#14
I would rebuild the USB at that point it's probably not setup correctly. Use Rufus and set it to striclty UEFI
 


#15
I would rebuild the USB at that point it's probably not setup correctly. Use Rufus and set it to striclty UEFI
Ah ha there is progress, I tried disabling secure boot and realised that legacy was automatically enabling. I disabled both, and got to the dell logo and no 'secure boot violation' message but instead got this: (see pic)
Does this mean that my usb boot is probably whacked? In any case how do i build another one when my hard drive is wiped and I have no os on my computer to build one?!?!? R.I.P
 


Attachments

Neemobeer

Windows Forum Team
Staff member
#16
Was that booting from the flash drive or the hard disk?
 


#17
Was that booting from the flash drive or the hard disk?
Well under boot option priorities I have selected the 'usb 2.0' - the only thing to choose from at this point - with the media file as 'BOOTMGR.EFI', like you said. I don't even have a hard disk drive so I have no clue why it thinks that.
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#18
Hi again,
You'll need to figure out which drive inside your dell computer is your bootdrive to fix this. You should NOT be using both drives while trying to repair or reconstruct your computer.:noway: You need to find out which drive is was booting your Windows; the 1TB or the 32GB SSD drive! You can check this in your BIOS setup, and simply look for the lowest numbered SATA # drive in the list of drives under the storage tab in your BIOS. The bootdrive will always be Drive #0. If the 1TB HDD is showing there, that's your bootdrive. If the 32GB SSD drive is showing there, then your SSD drive is the boot drive. Whichever drive is NOT the bootdrive must be manually disconnected--you have to physically open your case to do this! YOU CANNOT DISABLE IT IN BIOS--THIS IS NOT SUFFICIENT!!

Once you get to troubleshooting your computer with only 1 physical drive, you'll know for sure whether or not you borked the creation of your USB bootable flash drive with Windows on it or not. If following neem's suggestions does not work, then you most likely have a failed hard drive or Motherboard, and you may indeed wish to take it to a shop and get it professionally reinstalled.:waah: By the way, the VERY first thing the Tech will do once they attempt to troubleshoot your problem, will be to disconnect that secondary drive. Most home users have no idea that they are supposed to do this. But, if your secondary drive has a failure, that could also keep your USB key from working with a Windows boot repair or install. The fact that you do not know which drive is your bootdrive, tells me you are missing things. UEFI can be very tricky to work with. Ordinarily, if you can't produce a Windows bootable media on USB with your computer on either of your drives, it's very likely you have a hardware failure.:( The other thing you can try is to produce the Windows bootable media on DVD as a test. If that doesn't work either, either 1 or both of your drives have failed and must be replaced.:waah: If you buy a brand new drive and cannot get Windows bootable media to load, then it's very likely you have a Motherboard failure.:waah: Fooling around with UEFI settings can make your Motherboard appear to have failed when it's only improper settings! :headache: If you get to this point; you should really take your computer to a local shop and pay a Tech to sort it out for you.

<<<BIGBEARJEDI>>>
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.